summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-21 17:22:16 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-21 17:22:16 +0000
commit1767ae21c7f98b69d7f2ebad87b0684b25636c26 (patch)
treea00e3e793176f1f1f196abd423e98d064f3608b5 /media-sound/aucdtect
parentMark arm64/m68k/s390/sh stable. (diff)
downloadgentoo-2-1767ae21c7f98b69d7f2ebad87b0684b25636c26.tar.gz
gentoo-2-1767ae21c7f98b69d7f2ebad87b0684b25636c26.tar.bz2
gentoo-2-1767ae21c7f98b69d7f2ebad87b0684b25636c26.zip
Install prebuilt into /opt and handle QA checks, #448758
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'media-sound/aucdtect')
-rw-r--r--media-sound/aucdtect/ChangeLog10
-rw-r--r--media-sound/aucdtect/aucdtect-0.8.2-r1.ebuild (renamed from media-sound/aucdtect/aucdtect-0.8.2.ebuild)11
2 files changed, 15 insertions, 6 deletions
diff --git a/media-sound/aucdtect/ChangeLog b/media-sound/aucdtect/ChangeLog
index 1d8006c60621..51bc635a1bdc 100644
--- a/media-sound/aucdtect/ChangeLog
+++ b/media-sound/aucdtect/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/aucdtect
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/aucdtect/ChangeLog,v 1.2 2014/09/05 11:27:29 ulm Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aucdtect/ChangeLog,v 1.3 2015/03/21 17:22:16 jlec Exp $
+
+*aucdtect-0.8.2-r1 (21 Mar 2015)
+
+ 21 Mar 2015; Justin Lecher <jlec@gentoo.org> +aucdtect-0.8.2-r1.ebuild,
+ -aucdtect-0.8.2.ebuild:
+ Install prebuilt into /opt and handle QA checks, #448758
05 Sep 2014; Ulrich Müller <ulm@gentoo.org> aucdtect-0.8.2.ebuild:
QA: Remove unnecessary dependency on emul-linux-x86-compat, bug 522002.
diff --git a/media-sound/aucdtect/aucdtect-0.8.2.ebuild b/media-sound/aucdtect/aucdtect-0.8.2-r1.ebuild
index 7a2a87b484e0..a07955ceef19 100644
--- a/media-sound/aucdtect/aucdtect-0.8.2.ebuild
+++ b/media-sound/aucdtect/aucdtect-0.8.2-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/aucdtect/aucdtect-0.8.2.ebuild,v 1.2 2014/09/05 11:27:29 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aucdtect/aucdtect-0.8.2-r1.ebuild,v 1.1 2015/03/21 17:22:16 jlec Exp $
EAPI=5
+
inherit rpm versionator
MY_PV=$(replace_version_separator 2 '-')
@@ -20,7 +21,9 @@ IUSE=""
S="${WORKDIR}/usr/local/bin"
+QA_PREBUILT="opt/bin/.*"
+
src_install() {
- exeinto /usr/bin
- doexe "${MY_PN}"
+ into /opt
+ dobin "${MY_PN}"
}