summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-12-29 17:41:37 +0000
committerDan Armak <danarmak@gentoo.org>2001-12-29 17:41:37 +0000
commit31ea401556c658c3b023797bba71370f471437d6 (patch)
tree8675242200fdcbca6ae10a94064e5ff3fbe4c818 /media-sound/apollo
parentunmasked fam (diff)
downloadgentoo-2-31ea401556c658c3b023797bba71370f471437d6.tar.gz
gentoo-2-31ea401556c658c3b023797bba71370f471437d6.tar.bz2
gentoo-2-31ea401556c658c3b023797bba71370f471437d6.zip
big commit :-) read gentoo-announce msg and eclass/doc/news.txt for details
Diffstat (limited to 'media-sound/apollo')
-rw-r--r--media-sound/apollo/apollo-1.1.1-r1.ebuild46
-rw-r--r--media-sound/apollo/files/digest-apollo-1.1.1-r11
2 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/apollo/apollo-1.1.1-r1.ebuild b/media-sound/apollo/apollo-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..fe18d6398a80
--- /dev/null
+++ b/media-sound/apollo/apollo-1.1.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/apollo/apollo-1.1.1-r1.ebuild,v 1.1 2001/12/29 17:41:37 danarmak Exp $
+. /usr/portage/eclass/inherit.eclass || die
+use kde && ( inherit kde-base || die )
+
+S=${WORKDIR}/${P}-1
+DESCRIPTION="A Qt-based front-end to mpg123"
+SRC_URI="http://prdownloads.sourceforge.net/apolloplayer/apollo-src-1.1.1-1.tar.bz2"
+HOMEPAGE="http://www.apolloplayer.org"
+
+use kde && need-kde 2.2 && need-qt 2.3
+
+RDEPEND="$RDEPEND >=media-sound/mpg123-0.59r"
+use kde || DEPEND="$DEPEND >=x11-libs/qt-2.3"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack apollo-src-1.1.1-1.tar.bz2
+ cd ${S}
+ mv install.sh install.sh.orig
+ cat install.sh.orig | sed -e 's:$PREFIX/local:$PREFIX:g' > install.sh
+}
+
+src_compile() {
+
+ make || die "died making"
+
+}
+
+src_install () {
+
+ if [ "`use kde`" ]
+ then
+ myconf="$myconf --with-kde=${KDEDIR}"
+ dodir /usr/share/applnk/Multimedia
+ fi
+
+ dodir usr/bin
+ echo `pwd`
+ sh install.sh --prefix=${D}/usr $myconf
+
+}
+
diff --git a/media-sound/apollo/files/digest-apollo-1.1.1-r1 b/media-sound/apollo/files/digest-apollo-1.1.1-r1
new file mode 100644
index 000000000000..bb3149ff1f1b
--- /dev/null
+++ b/media-sound/apollo/files/digest-apollo-1.1.1-r1
@@ -0,0 +1 @@
+MD5 e22b4e706315701dbb5f017aaca642ac apollo-src-1.1.1-1.tar.bz2 81920