summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-10 15:40:58 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-10 15:40:58 +0000
commit7b225d122d614a2b3cf2a170ce07baa79d099c12 (patch)
tree6fa45dc6b6fb93f1e71c350c5f366118b991ef5a /media-sound/amsynth
parentmask cuda dep for opencv bug 365451 (diff)
downloadgentoo-2-7b225d122d614a2b3cf2a170ce07baa79d099c12.tar.gz
gentoo-2-7b225d122d614a2b3cf2a170ce07baa79d099c12.tar.bz2
gentoo-2-7b225d122d614a2b3cf2a170ce07baa79d099c12.zip
Respect CFLAGS. bug #376665
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/amsynth')
-rw-r--r--media-sound/amsynth/ChangeLog6
-rw-r--r--media-sound/amsynth/amsynth-1.2.3.ebuild11
-rw-r--r--media-sound/amsynth/files/amsynth-1.2.3-cflags.patch30
3 files changed, 44 insertions, 3 deletions
diff --git a/media-sound/amsynth/ChangeLog b/media-sound/amsynth/ChangeLog
index 6fe65c63202c..914aed2626f3 100644
--- a/media-sound/amsynth/ChangeLog
+++ b/media-sound/amsynth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/amsynth
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/ChangeLog,v 1.36 2011/08/07 17:29:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/ChangeLog,v 1.37 2011/08/10 15:40:58 hwoarang Exp $
+
+ 10 Aug 2011; Markos Chandras <hwoarang@gentoo.org> amsynth-1.2.3.ebuild,
+ +files/amsynth-1.2.3-cflags.patch:
+ Respect CFLAGS. bug #376665
07 Aug 2011; Raúl Porcel <armin76@gentoo.org> amsynth-1.2.0.ebuild,
amsynth-1.2.2.ebuild, amsynth-1.2.3.ebuild:
diff --git a/media-sound/amsynth/amsynth-1.2.3.ebuild b/media-sound/amsynth/amsynth-1.2.3.ebuild
index 55d01ddb79a4..330ea8567289 100644
--- a/media-sound/amsynth/amsynth-1.2.3.ebuild
+++ b/media-sound/amsynth/amsynth-1.2.3.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.2.3.ebuild,v 1.3 2011/08/07 17:29:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.2.3.ebuild,v 1.4 2011/08/10 15:40:58 hwoarang Exp $
EAPI=2
-MY_P=${P/ams/amS}
+inherit autotools eutils
+
+MY_P=${P/ams/amS}
DESCRIPTION="Virtual analogue synthesizer."
HOMEPAGE="http://amsynthe.sourceforge.net/"
SRC_URI="mirror://sourceforge/amsynthe/${MY_P}.tar.gz"
@@ -24,6 +26,11 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ eautoreconf
+}
+
src_configure() {
econf \
$(use_with oss) \
diff --git a/media-sound/amsynth/files/amsynth-1.2.3-cflags.patch b/media-sound/amsynth/files/amsynth-1.2.3-cflags.patch
new file mode 100644
index 000000000000..8e063144c7de
--- /dev/null
+++ b/media-sound/amsynth/files/amsynth-1.2.3-cflags.patch
@@ -0,0 +1,30 @@
+Index: amSynth-1.2.3/configure.in
+===================================================================
+--- amSynth-1.2.3.orig/configure.in
++++ amSynth-1.2.3/configure.in
+@@ -5,7 +5,6 @@ AC_CONFIG_HEADERS([config.h])
+
+
+ addCXXFLAGS="-D_REENTRANT"
+-CXXFLAGS="$CXXFLAGS -Wall -W"
+
+ AC_PROG_CXX
+ AC_PROG_INSTALL
+@@ -90,7 +89,6 @@ AC_ARG_ENABLE(debug,
+ if test "${enable_debug}" = "yes" ; then
+ AC_MSG_RESULT([yes])
+ debugging=yes
+- CXXFLAGS="$CXXFLAGS -g -Wall -D_DEBUG"
+ COMPOPSTR="debugging $COMPOPSTR"
+ OPTION_DEBUG="yes"
+ else
+@@ -113,9 +111,6 @@ if test "$enable_profile" = "yes" ; then
+ CXXFLAGS="$CXXFLAGS -p"
+ fi
+ else
+- if test "$GCC" = "yes" ; then
+- CXXFLAGS="$CXXFLAGS -O3 -ffast-math -fno-exceptions -fomit-frame-pointer"
+- fi
+ AC_MSG_RESULT([no])
+ profiling=no
+ fi