summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-04-10 17:32:10 +0000
committerSamuli Suominen <drac@gentoo.org>2008-04-10 17:32:10 +0000
commitd086d20b443a7d17beb4949a716fde844abc2ebe (patch)
tree85528dfa46eade8999214276bef423b3b03ed8ee /media-sound/adplay/adplay-1.6.ebuild
parentgnome-base/gnome: Bump to 2.22.1, mostly bugfix and translations (diff)
downloadgentoo-2-d086d20b443a7d17beb4949a716fde844abc2ebe.tar.gz
gentoo-2-d086d20b443a7d17beb4949a716fde844abc2ebe.tar.bz2
gentoo-2-d086d20b443a7d17beb4949a716fde844abc2ebe.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-sound/adplay/adplay-1.6.ebuild')
-rw-r--r--media-sound/adplay/adplay-1.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/adplay/adplay-1.6.ebuild b/media-sound/adplay/adplay-1.6.ebuild
new file mode 100644
index 000000000000..7991173732fc
--- /dev/null
+++ b/media-sound/adplay/adplay-1.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/adplay/adplay-1.6.ebuild,v 1.1 2008/04/10 17:32:10 drac Exp $
+
+DESCRIPTION="A console player for AdLib music"
+HOMEPAGE="http://adplug.sourceforge.net"
+SRC_URI="mirror://sourceforge/adplug/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa ao esd oss sdl"
+
+RDEPEND="media-libs/adplug
+ dev-cpp/libbinio
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ esd? ( media-sound/esound )
+ sdl? ( media-libs/libsdl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf --disable-dependency-tracking \
+ $(use_enable alsa output-alsa) \
+ $(use_enable ao output-ao) \
+ $(use_enable esd output-esound) \
+ $(use_enable oss output-oss) \
+ $(use_enable sdl output-sdl)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}