summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-03 10:33:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-03 10:33:39 +0000
commitfbbaf57fd015c3128f2d45f712fb136aa1807a61 (patch)
tree77cbe85cdddfb5b5066d795cc23b480a4bf9bb7c /media-plugins
parentFixed typo in elog notice, thank Sergei Trofimovich for report. (diff)
downloadgentoo-2-fbbaf57fd015c3128f2d45f712fb136aa1807a61.tar.gz
gentoo-2-fbbaf57fd015c3128f2d45f712fb136aa1807a61.tar.bz2
gentoo-2-fbbaf57fd015c3128f2d45f712fb136aa1807a61.zip
Remove -O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops from CFLAGS wrt #286993.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/swh-lv2/ChangeLog8
-rw-r--r--media-plugins/swh-lv2/swh-lv2-1.0.15.ebuild14
2 files changed, 16 insertions, 6 deletions
diff --git a/media-plugins/swh-lv2/ChangeLog b/media-plugins/swh-lv2/ChangeLog
index daa609f34183..329eaef63e2d 100644
--- a/media-plugins/swh-lv2/ChangeLog
+++ b/media-plugins/swh-lv2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/swh-lv2
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-lv2/ChangeLog,v 1.5 2008/01/27 20:03:53 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-lv2/ChangeLog,v 1.6 2009/10/03 10:33:39 ssuominen Exp $
+
+ 03 Oct 2009; Samuli Suominen <ssuominen@gentoo.org> swh-lv2-1.0.15.ebuild:
+ Remove -O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops from
+ CFLAGS wrt #286993.
27 Jan 2008; Alexis Ballier <aballier@gentoo.org> -swh-lv2-1.0.14.ebuild:
remove old
diff --git a/media-plugins/swh-lv2/swh-lv2-1.0.15.ebuild b/media-plugins/swh-lv2/swh-lv2-1.0.15.ebuild
index 850c921e3327..daf4f4de48fe 100644
--- a/media-plugins/swh-lv2/swh-lv2-1.0.15.ebuild
+++ b/media-plugins/swh-lv2/swh-lv2-1.0.15.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-lv2/swh-lv2-1.0.15.ebuild,v 1.1 2008/01/10 08:24:32 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-lv2/swh-lv2-1.0.15.ebuild,v 1.2 2009/10/03 10:33:39 ssuominen Exp $
+EAPI=2
inherit toolchain-funcs multilib
DESCRIPTION="Large collection of LV2 audio plugins/effects"
@@ -18,11 +19,16 @@ DEPEND="${RDEPEND}
dev-libs/libxslt
dev-util/pkgconfig"
+src_prepare() {
+ sed -e 's:-O3 -fomit-frame-pointer -fstrength-reduce -funroll-loops::g' \
+ -i Makefile || die
+}
+
src_compile() {
- emake CC=$(tc-getCC) || die "make failed"
+ emake CC=$(tc-getCC) || die
}
src_install() {
- emake INSTALL_DIR="${D}/usr/$(get_libdir)/lv2" install-system || die "failed to install"
+ emake INSTALL_DIR="${D}/usr/$(get_libdir)/lv2" install-system || die
dodoc README
}