summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-31 16:35:16 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-31 16:35:16 +0000
commitbdf0bc77b04d616686f6614ad3e42782d68d715a (patch)
tree70b6b7d2183a10b0000a52c46569004930196be5 /media-plugins/xmms-itouch/xmms-itouch-0.1.2.ebuild
parentxmms plugin for keyboard input (diff)
downloadgentoo-2-bdf0bc77b04d616686f6614ad3e42782d68d715a.tar.gz
gentoo-2-bdf0bc77b04d616686f6614ad3e42782d68d715a.tar.bz2
gentoo-2-bdf0bc77b04d616686f6614ad3e42782d68d715a.zip
xmms plugin for keyboard input
Diffstat (limited to 'media-plugins/xmms-itouch/xmms-itouch-0.1.2.ebuild')
-rw-r--r--media-plugins/xmms-itouch/xmms-itouch-0.1.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-plugins/xmms-itouch/xmms-itouch-0.1.2.ebuild b/media-plugins/xmms-itouch/xmms-itouch-0.1.2.ebuild
new file mode 100644
index 000000000000..1d9700e66475
--- /dev/null
+++ b/media-plugins/xmms-itouch/xmms-itouch-0.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-itouch/xmms-itouch-0.1.2.ebuild,v 1.1 2002/10/31 16:35:16 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XMMS plugin for multimedia keys on Logitech keyboards and others alike"
+HOMEPAGE="http://www.saunalahti.fi/~syrjala/xmms-itouch/"
+SRC_URI="http://www.saunalahti.fi/~syrjala/xmms-itouch/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="media-sound/xmms"
+
+src_install () {
+ make DESTDIR=${D} install || die
+}
+
+
+src_compile() {
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf}
+ emake || die
+}
+
+pkg_postinst() {
+ einfo "To configure the multimedia keys, run \"xev\" and"
+ einfo "press desired keys to get the corresponding keycode."
+ einfo "Insert this into the xmms plugin config screen."
+ einfo "Multimedia key codes can also be found at"
+ einfo "\"http://www.saunalahti.fi/~syrjala/xmms-itouch/\""
+ einfo "for some keyboard models - but for complete freedom of choice "
+ einfo "xev is your friend :-)"
+}