summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2011-01-29 23:29:34 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2011-01-29 23:29:34 +0000
commite2b03ca8f8cce1dc2a6c33a7da05086ab9d478bd (patch)
treedfefef7130c488474f92baa4022d4c8ca880ed84 /media-plugins/vdr-infosatepg
parentdep on virtual/daemontools - assign RDEPEND (diff)
downloadgentoo-2-e2b03ca8f8cce1dc2a6c33a7da05086ab9d478bd.tar.gz
gentoo-2-e2b03ca8f8cce1dc2a6c33a7da05086ab9d478bd.tar.bz2
gentoo-2-e2b03ca8f8cce1dc2a6c33a7da05086ab9d478bd.zip
eapi=3; cleanup; version bump
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'media-plugins/vdr-infosatepg')
-rw-r--r--media-plugins/vdr-infosatepg/ChangeLog11
-rw-r--r--media-plugins/vdr-infosatepg/vdr-infosatepg-0.0.10.ebuild11
-rw-r--r--media-plugins/vdr-infosatepg/vdr-infosatepg-0.0.11.ebuild (renamed from media-plugins/vdr-infosatepg/vdr-infosatepg-0.0.8.ebuild)18
3 files changed, 31 insertions, 9 deletions
diff --git a/media-plugins/vdr-infosatepg/ChangeLog b/media-plugins/vdr-infosatepg/ChangeLog
index c574dafad644..f2fa2def102e 100644
--- a/media-plugins/vdr-infosatepg/ChangeLog
+++ b/media-plugins/vdr-infosatepg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/vdr-infosatepg
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-infosatepg/ChangeLog,v 1.2 2010/06/06 11:07:08 hd_brummy Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-infosatepg/ChangeLog,v 1.3 2011/01/29 23:29:34 hd_brummy Exp $
+
+*vdr-infosatepg-0.0.11 (29 Jan 2011)
+
+ 29 Jan 2011; Joerg Bornkessel <hd_brummy@gentoo.org>
+ -vdr-infosatepg-0.0.8.ebuild, vdr-infosatepg-0.0.10.ebuild,
+ +vdr-infosatepg-0.0.11.ebuild:
+ eapi=3; cleanup; version bump
*vdr-infosatepg-0.0.10 (06 Jun 2010)
diff --git a/media-plugins/vdr-infosatepg/vdr-infosatepg-0.0.10.ebuild b/media-plugins/vdr-infosatepg/vdr-infosatepg-0.0.10.ebuild
index 501740259f32..0c7ad8dbef51 100644
--- a/media-plugins/vdr-infosatepg/vdr-infosatepg-0.0.10.ebuild
+++ b/media-plugins/vdr-infosatepg/vdr-infosatepg-0.0.10.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-infosatepg/vdr-infosatepg-0.0.10.ebuild,v 1.1 2010/06/06 11:07:08 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-infosatepg/vdr-infosatepg-0.0.10.ebuild,v 1.2 2011/01/29 23:29:34 hd_brummy Exp $
-EAPI="2"
+EAPI="3"
inherit vdr-plugin
+VERSION="163" # every bump, new version!
+
DESCRIPTION="VDR Plugin: Reads the contents of infosat and writes the data into the EPG."
HOMEPAGE="http://projects.vdr-developer.org/projects/show/plg-infosatepg"
-SRC_URI="http://projects.vdr-developer.org/attachments/download/163/${P}.tgz"
+SRC_URI="http://projects.vdr-developer.org/attachments/download/${VERSION}/${P}.tgz"
SLOT="0"
LICENSE="GPL-2"
@@ -16,3 +18,4 @@ KEYWORDS="~x86 ~amd64"
IUSE=""
DEPEND=">=media-video/vdr-1.6.0"
+RDEPEND="${DEPEND}"
diff --git a/media-plugins/vdr-infosatepg/vdr-infosatepg-0.0.8.ebuild b/media-plugins/vdr-infosatepg/vdr-infosatepg-0.0.11.ebuild
index 1c0db3a3edf3..907f258830cb 100644
--- a/media-plugins/vdr-infosatepg/vdr-infosatepg-0.0.8.ebuild
+++ b/media-plugins/vdr-infosatepg/vdr-infosatepg-0.0.11.ebuild
@@ -1,12 +1,16 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-infosatepg/vdr-infosatepg-0.0.8.ebuild,v 1.2 2009/02/19 18:40:54 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-infosatepg/vdr-infosatepg-0.0.11.ebuild,v 1.1 2011/01/29 23:29:34 hd_brummy Exp $
+
+EAPI="3"
inherit vdr-plugin
+VERSION="324" # every bump, new version!
+
DESCRIPTION="VDR Plugin: Reads the contents of infosat and writes the data into the EPG."
HOMEPAGE="http://projects.vdr-developer.org/projects/show/plg-infosatepg"
-SRC_URI="http://projects.vdr-developer.org/attachments/download/65/${P}.tgz"
+SRC_URI="http://projects.vdr-developer.org/attachments/download/${VERSION}/${P}.tgz"
SLOT="0"
LICENSE="GPL-2"
@@ -14,3 +18,11 @@ KEYWORDS="~x86 ~amd64"
IUSE=""
DEPEND=">=media-video/vdr-1.6.0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ vdr-plugin_src_prepare
+
+ sed '2a\
+#include <cctype>' -i global.cpp
+}