summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2007-06-26 19:54:28 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2007-06-26 19:54:28 +0000
commit186ec368a41221767613260443fdbaa0c8c3136a (patch)
treea3796a85fd76d4cfb17c80652135ff2fdb2d9ecc /media-plugins/vdr-graphlcd
parentMarked ~ppc for bug #182733. (diff)
downloadgentoo-2-186ec368a41221767613260443fdbaa0c8c3136a.tar.gz
gentoo-2-186ec368a41221767613260443fdbaa0c8c3136a.tar.bz2
gentoo-2-186ec368a41221767613260443fdbaa0c8c3136a.zip
patch added, fix compile probs with vdr up from 1.5.3
(Portage version: 2.1.2.7)
Diffstat (limited to 'media-plugins/vdr-graphlcd')
-rw-r--r--media-plugins/vdr-graphlcd/ChangeLog6
-rw-r--r--media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5_vdr-1.5.3.diff19
-rw-r--r--media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.5.ebuild5
3 files changed, 27 insertions, 3 deletions
diff --git a/media-plugins/vdr-graphlcd/ChangeLog b/media-plugins/vdr-graphlcd/ChangeLog
index d27092d92e0f..48347d157774 100644
--- a/media-plugins/vdr-graphlcd/ChangeLog
+++ b/media-plugins/vdr-graphlcd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/vdr-graphlcd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphlcd/ChangeLog,v 1.17 2007/06/08 10:05:46 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphlcd/ChangeLog,v 1.18 2007/06/26 19:54:28 hd_brummy Exp $
+
+ 26 Jun 2007; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +files/0.1.5/graphlcd-0.1.5_vdr-1.5.3.diff, vdr-graphlcd-0.1.5.ebuild:
+ patch added, fix compile probs with vdr up from 1.5.3
08 Jun 2007; Matthias Schwarzott <zzam@gentoo.org>
vdr-graphlcd-0.1.3.ebuild, vdr-graphlcd-0.1.3-r1.ebuild,
diff --git a/media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5_vdr-1.5.3.diff b/media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5_vdr-1.5.3.diff
new file mode 100644
index 000000000000..fac88fb5e615
--- /dev/null
+++ b/media-plugins/vdr-graphlcd/files/0.1.5/graphlcd-0.1.5_vdr-1.5.3.diff
@@ -0,0 +1,19 @@
+fix compile Probs up from vdr-1.5.3
+
+Joerg Bornkessel <hd_brummy@gentoo.org> 2007 06 26
+
+diff -Naur graphlcd-0.1.5.orig/layout.c graphlcd-0.1.5/layout.c
+--- graphlcd-0.1.5.orig/layout.c 2007-06-26 21:43:52.000000000 +0200
++++ graphlcd-0.1.5/layout.c 2007-06-26 21:46:05.000000000 +0200
+@@ -65,7 +65,11 @@
+ file += "/fonts/";
+ file += url.substr(4, pos - 4);
+ }
++#if APIVERSNUM >= 10503
++ return font.LoadFT2(file, cCharSetConv::SystemCharacterTable(), size);
++#else
+ return font.LoadFT2(file, I18nCharSets()[Setup.OSDLanguage], size);
++#endif
+ }
+ else
+ {
diff --git a/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.5.ebuild b/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.5.ebuild
index bfb4e15af656..ffd5e4f83e39 100644
--- a/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.5.ebuild
+++ b/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.5.ebuild,v 1.3 2007/06/08 10:05:46 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.5.ebuild,v 1.4 2007/06/26 19:54:28 hd_brummy Exp $
inherit eutils vdr-plugin
@@ -20,7 +20,8 @@ DEPEND=">=media-video/vdr-1.2.6
PATCHES="
${FILESDIR}/${PV}/graphlcd-${PV}-span.diff
${FILESDIR}/${PV}/graphlcd-${PV}-radiotext-lcr-service.diff
- ${FILESDIR}/${PV}/${P}-missing-include.patch"
+ ${FILESDIR}/${PV}/${P}-missing-include.patch
+ ${FILESDIR}/${PV}/graphlcd-${PV}_vdr-1.5.3.diff"
pkg_setup() {
vdr-plugin_pkg_setup