summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2007-02-04 23:38:35 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2007-02-04 23:38:35 +0000
commit0a1cb8321333d43c34a492bdd23575cdb1593d57 (patch)
treefcf4f1d1d838b6c4b061b40764e94474a5cb5453 /media-plugins/vdr-graphlcd
parentamd64 stable, bug 158434 (diff)
downloadgentoo-2-0a1cb8321333d43c34a492bdd23575cdb1593d57.tar.gz
gentoo-2-0a1cb8321333d43c34a492bdd23575cdb1593d57.tar.bz2
gentoo-2-0a1cb8321333d43c34a492bdd23575cdb1593d57.zip
version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'media-plugins/vdr-graphlcd')
-rw-r--r--media-plugins/vdr-graphlcd/ChangeLog10
-rw-r--r--media-plugins/vdr-graphlcd/files/0.1.4/graphlcd-0.1.4-better-readable-on-medium-displays.diff38
-rw-r--r--media-plugins/vdr-graphlcd/files/0.1.4/graphlcd-0.1.4-radiotext-lcr-service.diff126
-rw-r--r--media-plugins/vdr-graphlcd/files/0.1.4/graphlcd-0.1.4-span.diff356
-rw-r--r--media-plugins/vdr-graphlcd/files/digest-vdr-graphlcd-0.1.43
-rw-r--r--media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.4.ebuild84
6 files changed, 616 insertions, 1 deletions
diff --git a/media-plugins/vdr-graphlcd/ChangeLog b/media-plugins/vdr-graphlcd/ChangeLog
index 5b9a78f8f48c..8f9c2c83957a 100644
--- a/media-plugins/vdr-graphlcd/ChangeLog
+++ b/media-plugins/vdr-graphlcd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-plugins/vdr-graphlcd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphlcd/ChangeLog,v 1.10 2007/01/05 16:31:15 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphlcd/ChangeLog,v 1.11 2007/02/04 23:38:35 hd_brummy Exp $
+
+*vdr-graphlcd-0.1.4 (04 Feb 2007)
+
+ 04 Feb 2007; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +files/0.1.4/graphlcd-0.1.4-better-readable-on-medium-displays.diff,
+ +files/0.1.4/graphlcd-0.1.4-radiotext-lcr-service.diff,
+ +files/0.1.4/graphlcd-0.1.4-span.diff, +vdr-graphlcd-0.1.4.ebuild:
+ version bump
05 Jan 2007; Joerg Bornkessel <hd_brummy@gentoo.org>
vdr-graphlcd-0.1.2_pre6-r1.ebuild, vdr-graphlcd-0.1.3.ebuild,
diff --git a/media-plugins/vdr-graphlcd/files/0.1.4/graphlcd-0.1.4-better-readable-on-medium-displays.diff b/media-plugins/vdr-graphlcd/files/0.1.4/graphlcd-0.1.4-better-readable-on-medium-displays.diff
new file mode 100644
index 000000000000..63f2d61066bf
--- /dev/null
+++ b/media-plugins/vdr-graphlcd/files/0.1.4/graphlcd-0.1.4-better-readable-on-medium-displays.diff
@@ -0,0 +1,38 @@
+--- display.c.old 2007-01-22 15:40:18.000000000 +0100
++++ display.c 2007-01-22 15:45:09.000000000 +0100
+@@ -239,7 +239,7 @@
+ TEXT_OFFSET_Y_CHANNEL = 3;
+ TEXT_OFFSET_Y_TITLE = 3;
+ SYMBOL_SPACE = 1;
+- TIMEBAR_HEIGHT = 3;
++ TIMEBAR_HEIGHT = 6;
+ }
+ else
+ {
+@@ -1367,14 +1367,14 @@
+ if (bitmap->Height() >= MINY_L)
+ nProgressbarHeight = 15;
+ else if (bitmap->Height() >= MINY_M)
+- nProgressbarHeight = 9;
++ nProgressbarHeight = 5; // nProgressbarHeight = 9;
+ else if (bitmap->Height() >= MINY_S)
+ nProgressbarHeight = 5;
+ else
+ nProgressbarHeight = 3;
+
+ if (IsLogoActive())
+- nTopY = FRAME_SPACE_Y + logo->Height() + 2;
++ nTopY = FRAME_SPACE_Y + logo->Height() + 0; // nTopY = FRAME_SPACE_Y + logo->Height() + 2;
+ else if (GraphLCDSetup.ShowDateTime)
+ nTopY = FRAME_SPACE_Y + normalFont->TotalAscent() + 2 * TEXT_OFFSET_Y_TIME + FRAME_SPACE_YB;
+ else
+@@ -1386,7 +1386,8 @@
+
+ nMaxX = std::max(1, bitmap->Width() - (2 * FRAME_SPACE_X) - 2 * TEXT_OFFSET_X);
+ lineHeight = FRAME_SPACE_Y + largeFont->TotalHeight();
+- maxLines = std::max(0, (bitmap->Height() - normalFont->TotalHeight() - FRAME_SPACE_Y - nProgressbarHeight - 2 - nTopY) / lineHeight);
++ maxLines = std::max(0, (bitmap->Height() - normalFont->TotalHeight() - FRAME_SPACE_Y - nProgressbarHeight - 0 - nTopY) / lineHeight);
++ // maxLines = std::max(0, (bitmap->Height() - normalFont->TotalHeight() - FRAME_SPACE_Y - nProgressbarHeight - 2 - nTopY) / lineHeight);
+
+ if (maxLines == 0)
+ {
diff --git a/media-plugins/vdr-graphlcd/files/0.1.4/graphlcd-0.1.4-radiotext-lcr-service.diff b/media-plugins/vdr-graphlcd/files/0.1.4/graphlcd-0.1.4-radiotext-lcr-service.diff
new file mode 100644
index 000000000000..8c2c180ab2c2
--- /dev/null
+++ b/media-plugins/vdr-graphlcd/files/0.1.4/graphlcd-0.1.4-radiotext-lcr-service.diff
@@ -0,0 +1,126 @@
+diff -Naur graphlcd-0.1.4.orig/state.c graphlcd-0.1.4/state.c
+--- graphlcd-0.1.4.orig/state.c 2007-02-04 23:35:16.317687570 +0100
++++ graphlcd-0.1.4/state.c 2007-02-04 23:42:12.065780817 +0100
+@@ -16,6 +16,7 @@
+
+ #include <vdr/eitscan.h>
+ #include <vdr/i18n.h>
++#include <vdr/plugin.h>
+
+ #include "compat.h"
+
+@@ -654,6 +655,8 @@
+
+ void cGraphLCDState::GetProgramme()
+ {
++ bool ptitle = false;
++
+ mutex.Lock();
+ #if VDRVERSNUM < 10300
+ const cEventInfo * present = NULL, * following = NULL;
+@@ -670,9 +673,11 @@
+ {
+ event.presentTime = present->GetTime();
+ event.presentTitle = "";
+- if (!isempty(present->GetTitle()))
++ if (!isempty(present->GetTitle())) {
+ event.presentTitle = present->GetTitle();
+ event.presentSubtitle = "";
++ ptitle = true;
++ }
+ if (!isempty(present->GetSubtitle()))
+ event.presentSubtitle = present->GetSubtitle();
+ }
+@@ -704,9 +709,11 @@
+ {
+ event.presentTime = present->StartTime();
+ event.presentTitle = "";
+- if (!isempty(present->Title()))
++ if (!isempty(present->Title())) {
+ event.presentTitle = present->Title();
+ event.presentSubtitle = "";
++ ptitle = true;
++ }
+ if (!isempty(present->ShortText()))
+ event.presentSubtitle = present->ShortText();
+ }
+@@ -724,6 +731,54 @@
+ }
+ }
+ #endif
++
++#if VDRVERSNUM >= 10330
++ { // get&display Radiotext
++ cPlugin *p;
++ p = cPluginManager::CallFirstService("RadioTextService-v1.0", NULL);
++ if (p) {
++ RadioTextService_v1_0 rtext;
++ if (cPluginManager::CallFirstService("RadioTextService-v1.0", &rtext)) {
++ if (rtext.rds_info == 2 && strstr(rtext.rds_title, "---") == NULL) {
++ char rtpinfo[2][65], rtstr[140];
++ strcpy(rtpinfo[0], rtext.rds_title);
++ strcpy(rtpinfo[1], rtext.rds_artist);
++ sprintf(rtstr, "%02d:%02d %s | %s", rtext.title_start->tm_hour, rtext.title_start->tm_min, trim(((std::string)(rtpinfo[0]))).c_str(), trim(((std::string)(rtpinfo[1]))).c_str());
++ ptitle ? event.presentSubtitle = rtstr : event.presentTitle = rtstr;
++ }
++ else if (rtext.rds_info > 0) {
++ char rtstr[65];
++ strcpy(rtstr, rtext.rds_text);
++ ptitle ? event.presentSubtitle = trim(rtstr) : event.presentTitle = trim(rtstr);
++ }
++ }
++ }
++ }
++#endif
++
++#if VDRVERSNUM >= 10330
++ { // get&display LcrData
++ cPlugin *p;
++ p = cPluginManager::CallFirstService("LcrService-v1.0", NULL);
++ if (p)
++ {
++ LcrService_v1_0 lcrData;
++ if (cPluginManager::CallFirstService("LcrService-v1.0", &lcrData))
++ {
++ if ( strstr( lcrData.destination, "---" ) == NULL )
++ {
++ char lcrStringParts[3][25], lcrString[100];
++ strcpy( lcrStringParts[0], (const char *)lcrData.destination );
++ strcpy( lcrStringParts[1], (const char *)lcrData.price );
++ strcpy( lcrStringParts[2], (const char *)lcrData.pulse );
++ sprintf(lcrString, "%s | %s", trim((std::string)(lcrStringParts[1])).c_str(), trim((std::string)(lcrStringParts[2])).c_str());
++ event.presentTitle = trim(lcrStringParts[0]);
++ event.presentSubtitle = trim(lcrString);
++ }
++ }
++ }
++ }
++#endif
+ mutex.Unlock();
+ }
+
+diff -Naur graphlcd-0.1.4.orig/state.h graphlcd-0.1.4/state.h
+--- graphlcd-0.1.4.orig/state.h 2007-02-04 23:35:16.317687570 +0100
++++ graphlcd-0.1.4/state.h 2007-02-04 23:43:05.728759351 +0100
+@@ -130,4 +130,21 @@
+ tVolumeState GetVolumeState();
+ };
+
++// Radiotext
++struct RadioTextService_v1_0 {
++ int rds_info;
++ int rds_pty;
++ char *rds_text;
++ char *rds_title;
++ char *rds_artist;
++ struct tm *title_start;
++};
++
++// LcrData
++struct LcrService_v1_0 {
++ cString destination;
++ cString price;
++ cString pulse;
++};
++
+ #endif
diff --git a/media-plugins/vdr-graphlcd/files/0.1.4/graphlcd-0.1.4-span.diff b/media-plugins/vdr-graphlcd/files/0.1.4/graphlcd-0.1.4-span.diff
new file mode 100644
index 000000000000..949049af050f
--- /dev/null
+++ b/media-plugins/vdr-graphlcd/files/0.1.4/graphlcd-0.1.4-span.diff
@@ -0,0 +1,356 @@
+diff -Naur graphlcd-0.1.4.orig/display.c graphlcd-0.1.4/display.c
+--- graphlcd-0.1.4.orig/display.c 2007-02-04 23:10:36.609384554 +0100
++++ graphlcd-0.1.4/display.c 2007-02-04 23:17:48.756350745 +0100
+@@ -115,6 +115,7 @@
+ nCurrentBrightness = -1;
+ LastTimeBrightness = 0;
+ bBrightnessActive = true;
++ LastTimeSA.Set(0);
+ }
+
+ cGraphLCDDisplay::~cGraphLCDDisplay()
+@@ -373,6 +374,11 @@
+ update = true;
+ }
+
++ if ( LastTimeSA.TimedOut() )
++ {
++ update = true;
++ LastTimeSA.Set(1000);
++ }
+ // update Display every second or due to an update
+ if (CurrTime != LastTime || update)
+ {
+@@ -1460,6 +1466,8 @@
+ nTopY + nProgressbarHeight,
+ GLCD::clrBlack, false);
+
++ DisplaySA();
++
+ if (1 < replay.total && 1 < replay.current) // Don't show full progressbar for endless streams
+ {
+ bitmap->DrawRectangle(FRAME_SPACE_X,
+@@ -1945,3 +1953,141 @@
+ }
+ mutex.Unlock();
+ }
++
++void cGraphLCDDisplay::DisplaySA()
++{
++// Spectrum Analyzer visualization
++ if ( GraphLCDSetup.enableSpectrumAnalyzer )
++ {
++ if (cPluginManager::CallFirstService(SPAN_GET_BAR_HEIGHTS_ID, NULL))
++ {
++ Span_GetBarHeights_v1_0 GetBarHeights;
++
++ int bandsSA = 20;
++ int falloffSA = 8;
++ int channelsSA = 1;
++
++ unsigned int bar;
++ unsigned int *barHeights = new unsigned int[bandsSA];
++ unsigned int *barHeightsLeftChannel = new unsigned int[bandsSA];
++ unsigned int *barHeightsRightChannel = new unsigned int[bandsSA];
++ unsigned int volumeLeftChannel;
++ unsigned int volumeRightChannel;
++ unsigned int volumeBothChannels;
++ unsigned int *barPeaksBothChannels = new unsigned int[bandsSA];
++ unsigned int *barPeaksLeftChannel = new unsigned int[bandsSA];
++ unsigned int *barPeaksRightChannel = new unsigned int[bandsSA];
++
++ GetBarHeights.bands = bandsSA;
++ GetBarHeights.barHeights = barHeights;
++ GetBarHeights.barHeightsLeftChannel = barHeightsLeftChannel;
++ GetBarHeights.barHeightsRightChannel = barHeightsRightChannel;
++ GetBarHeights.volumeLeftChannel = &volumeLeftChannel;
++ GetBarHeights.volumeRightChannel = &volumeRightChannel;
++ GetBarHeights.volumeBothChannels = &volumeBothChannels;
++ GetBarHeights.name = "graphlcd";
++ GetBarHeights.falloff = falloffSA;
++ GetBarHeights.barPeaksBothChannels = barPeaksBothChannels;
++ GetBarHeights.barPeaksLeftChannel = barPeaksLeftChannel;
++ GetBarHeights.barPeaksRightChannel = barPeaksRightChannel;
++
++ if ( cPluginManager::CallFirstService(SPAN_GET_BAR_HEIGHTS_ID, &GetBarHeights ))
++ {
++ int i;
++ int barWidth = 2;
++ int saStartX = FRAME_SPACE_X;
++ int saEndX = saStartX + barWidth*bandsSA*2 + bandsSA/4 - 1;
++ int saStartY = FRAME_SPACE_Y;
++ int saEndY = FRAME_SPACE_Y + bitmap->Height()/2 - 3;
++
++ LastTimeSA.Set(100);
++
++ if ( GraphLCDSetup.SAShowVolume )
++ {
++
++ saStartX = FRAME_SPACE_X + bitmap->Width()/2 - (barWidth*bandsSA*2 + bandsSA/4)/2 - 2;
++ saEndX = saStartX + barWidth*bandsSA*2 + bandsSA/4 - 1;
++
++ // left volume
++ bitmap->DrawRectangle(FRAME_SPACE_X,
++ saStartY,
++ saStartX-1,
++ saEndY + 1,
++ GLCD::clrWhite, true);
++
++ for ( i=0; (i<logo->Width()/2-2) && (i<3*(volumeLeftChannel*saStartX)/100); i++)
++ {
++ bitmap->DrawRectangle(saStartX - i - 2,
++ saStartY + saEndY/2 - i,
++ saStartX - i - 4,
++ saStartY + saEndY/2 + i,
++ GLCD::clrBlack, true);
++ }
++
++ // right volume
++ bitmap->DrawRectangle(saEndX + 1,
++ saStartY,
++ bitmap->Width() - 1,
++ saEndY + 1,
++ GLCD::clrWhite, true);
++
++ for ( i=0; (i<logo->Width()/2-2) && (i<3*(volumeRightChannel*saStartX)/100); i++)
++ {
++ bitmap->DrawRectangle(saEndX + 2 + i,
++ saStartY + saEndY/2 - i,
++ saEndX + i + 4,
++ saStartY + saEndY/2 + i,
++ GLCD::clrBlack, true);
++ }
++ }
++ // black background
++ bitmap->DrawRectangle(saStartX,
++ saStartY,
++ saEndX,
++ saEndY + 1,
++ GLCD::clrBlack, true);
++
++ for ( i=0; i < bandsSA; i++ )
++ {
++/* if ( channelsSA == 2 )
++ {
++ bar = barHeightsLeftChannel[i];
++ bar = barHeightsRightChannel[i];
++ }*/
++ if ( channelsSA == 1)
++ {
++ // the bar
++ bar = (barHeights[i]*(saEndY-saStartY))/100;
++ bitmap->DrawRectangle(saStartX + barWidth*2*(i)+ barWidth + 1,
++ saEndY,
++ saStartX + barWidth*2*(i) + barWidth+ barWidth + 1,
++ saEndY - bar,
++ GLCD::clrWhite, true);
++
++ // the peak
++ bar = (barPeaksBothChannels[i]*(saEndY-saStartY))/100;
++ if ( bar > 0 )
++ {
++ bitmap->DrawRectangle(saStartX + barWidth*2*(i)+ barWidth + 1,
++ saEndY - bar,
++ saStartX + barWidth*2*(i) + barWidth+ barWidth + 1,
++ saEndY - bar+1,
++ GLCD::clrWhite, true);
++ }
++ }
++ }
++ }
++
++ delete [] barHeights;
++ delete [] barHeightsLeftChannel;
++ delete [] barHeightsRightChannel;
++ delete [] barPeaksBothChannels;
++ delete [] barPeaksLeftChannel;
++ delete [] barPeaksRightChannel;
++ }
++ }
++}
++
++//#############################################################################################
++
++
+diff -Naur graphlcd-0.1.4.orig/display.h graphlcd-0.1.4/display.h
+--- graphlcd-0.1.4.orig/display.h 2007-02-04 23:10:36.609384554 +0100
++++ graphlcd-0.1.4/display.h 2007-02-04 23:20:24.209000170 +0100
+@@ -29,10 +29,33 @@
+ #include <vdr/thread.h>
+ #include <vdr/player.h>
+
++#define SPAN_CLIENT_CHECK_ID "Span-ClientCheck-v1.0"
++#define SPAN_GET_BAR_HEIGHTS_ID "Span-GetBarHeights-v1.0"
+
+ #define LCDMAXCARDS 4
+ static const int kMaxTabCount = 10;
+
++struct Span_Client_Check_1_0 {
++ bool *isActive;
++ bool *isRunning;
++};
++
++struct Span_GetBarHeights_v1_0 {
++ unsigned int bands; // number of bands to compute
++ unsigned int *barHeights; // the heights of the bars of the two channels combined
++ unsigned int *barHeightsLeftChannel; // the heights of the bars of the left channel
++ unsigned int *barHeightsRightChannel; // the heights of the bars of the right channel
++ unsigned int *volumeLeftChannel; // the volume of the left channels
++ unsigned int *volumeRightChannel; // the volume of the right channels
++ unsigned int *volumeBothChannels; // the combined volume of the two channels
++ const char *name; // name of the plugin that wants to get the data
++ // (must be unique for each client!)
++ unsigned int falloff; // bar falloff value
++ unsigned int *barPeaksBothChannels; // bar peaks of the two channels combined
++ unsigned int *barPeaksLeftChannel; // bar peaks of the left channel
++ unsigned int *barPeaksRightChannel; // bar peaks of the right channel
++};
++
+ enum ThreadState
+ {
+ Normal,
+@@ -104,6 +127,7 @@
+ time_t LastTime;
+ time_t LastTimeCheckSym;
+ time_t LastTimeModSym;
++ cTimeMs LastTimeSA;
+ struct timeval CurrTimeval;
+ struct timeval UpdateAt;
+
+@@ -125,6 +149,7 @@
+ void DisplayTextItem();
+ void DisplayColorButtons();
+ void DisplayVolume();
++ void DisplaySA();
+
+ void UpdateIn(long usec);
+ bool CheckAndUpdateSymbols();
+diff -Naur graphlcd-0.1.4.orig/i18n.c graphlcd-0.1.4/i18n.c
+--- graphlcd-0.1.4.orig/i18n.c 2007-02-04 23:10:38.792567843 +0100
++++ graphlcd-0.1.4/i18n.c 2007-02-04 23:23:31.966096053 +0100
+@@ -966,5 +966,53 @@
+ # endif
+ #endif
+ },
++{
++ "Show spectrum analyzer",
++ "Zeige Spectrum Analyzer",
++ "",// TODO Slovenski
++ "",// TODO Italiano
++ "",// TODO Nederlands
++ "",// TODO Portuguçês
++ "",// TODO Franais
++ "",// TODO Norsk
++ "",// TODO Suomi
++ "",// TODO Polski
++ "",// TODO Español
++ "",// TODO Ellinika
++ "",// TODO Svenska
++ "",// TODO Romnâã
++ "",// TODO Magyar
++ "",// TODO Catalàà
++#if VDRVERSNUM > 10302
++ "",// TODO Russian
++# if VDRVERSNUM > 10307
++ "",// TODO Croatian
++# endif
++#endif
++ },
++ {
++ "Show SA volume",
++ "Zeige SA Lautstrke",
++ "",// TODO Slovenski
++ "",// TODO Italiano
++ "",// TODO Nederlands
++ "",// TODO Portugus
++ "",// TODO Franêçais
++ "",// TODO Norsk
++ "",// TODO Suomi
++ "",// TODO Polski
++ "",// TODO Español
++ "",// TODO Ellinika
++ "",// TODO Svenska
++ "",// TODO Romnâã
++ "",// TODO Magyar
++ "",// TODO Catal
++#if VDRVERSNUM > 10302
++ "",// TODO Russian
++# if VDRVERSNUM > 10307
++ "",// TODO Croatian
++# endif
++#endif
++ },
+ { NULL }
+ };
+diff -Naur graphlcd-0.1.4.orig/menu.c graphlcd-0.1.4/menu.c
+--- graphlcd-0.1.4.orig/menu.c 2007-02-04 23:10:38.862563031 +0100
++++ graphlcd-0.1.4/menu.c 2007-02-04 23:24:53.710477952 +0100
+@@ -101,4 +101,6 @@
+ SetupStore("BrightnessActive", GraphLCDSetup.BrightnessActive = newGraphLCDSetup.BrightnessActive);
+ SetupStore("BrightnessIdle", GraphLCDSetup.BrightnessIdle = newGraphLCDSetup.BrightnessIdle);
+ SetupStore("BrightnessDelay", GraphLCDSetup.BrightnessDelay = newGraphLCDSetup.BrightnessDelay);
++ SetupStore("enableSpectrumAnalyzer", GraphLCDSetup.enableSpectrumAnalyzer = newGraphLCDSetup.enableSpectrumAnalyzer);
++ SetupStore("SAShowVolume", GraphLCDSetup.SAShowVolume = newGraphLCDSetup.SAShowVolume);
+ }
+diff -Naur graphlcd-0.1.4.orig/plugin.c graphlcd-0.1.4/plugin.c
+--- graphlcd-0.1.4.orig/plugin.c 2007-02-04 23:10:38.862563031 +0100
++++ graphlcd-0.1.4/plugin.c 2007-02-04 23:26:57.655292837 +0100
+@@ -54,6 +54,7 @@
+ virtual cOsdObject * MainMenuAction();
+ virtual cMenuSetupPage * SetupMenu();
+ virtual bool SetupParse(const char * Name, const char * Value);
++ virtual bool Service(const char *Id, void *Data);
+ };
+
+ cPluginGraphLCD::cPluginGraphLCD()
+@@ -243,8 +244,24 @@
+ else if (!strcasecmp(Name, "BrightnessActive")) GraphLCDSetup.BrightnessActive = atoi(Value);
+ else if (!strcasecmp(Name, "BrightnessIdle")) GraphLCDSetup.BrightnessIdle = atoi(Value);
+ else if (!strcasecmp(Name, "BrightnessDelay")) GraphLCDSetup.BrightnessDelay = atoi(Value);
++ else if (!strcasecmp(Name, "enableSpectrumAnalyzer")) GraphLCDSetup.enableSpectrumAnalyzer = atoi(Value);
++ else if (!strcasecmp(Name, "SAShowVolume")) GraphLCDSetup.SAShowVolume = atoi(Value);
+ else return false;
+ return true;
+ }
+
++bool cPluginGraphLCD::Service(const char *Id, void *Data)
++{
++ if (strcmp(Id, SPAN_CLIENT_CHECK_ID) == 0)
++ {
++ if ( GraphLCDSetup.enableSpectrumAnalyzer && (Data != NULL) )
++ {
++ *((Span_Client_Check_1_0*)Data)->isActive = true;
++ }
++ return true;
++ }
++
++ return false;
++}
++
+ VDRPLUGINCREATOR(cPluginGraphLCD); // Don't touch this!
+diff -Naur graphlcd-0.1.4.orig/setup.c graphlcd-0.1.4/setup.c
+--- graphlcd-0.1.4.orig/setup.c 2007-02-04 23:10:38.865896137 +0100
++++ graphlcd-0.1.4/setup.c 2007-02-04 23:27:59.671030635 +0100
+@@ -52,7 +52,9 @@
+ ScrollTime(500),
+ BrightnessActive(100),
+ BrightnessIdle(100),
+- BrightnessDelay(30)
++ BrightnessDelay(30),
++ enableSpectrumAnalyzer(1),
++ SAShowVolume(1)
+ {
+ }
+
+diff -Naur graphlcd-0.1.4.orig/setup.h graphlcd-0.1.4/setup.h
+--- graphlcd-0.1.4.orig/setup.h 2007-02-04 23:10:38.865896137 +0100
++++ graphlcd-0.1.4/setup.h 2007-02-04 23:28:55.347204140 +0100
+@@ -54,6 +54,8 @@
+ int BrightnessActive;
+ int BrightnessIdle;
+ int BrightnessDelay;
++ int enableSpectrumAnalyzer;
++ int SAShowVolume;
+
+ public:
+ cGraphLCDSetup(void);
diff --git a/media-plugins/vdr-graphlcd/files/digest-vdr-graphlcd-0.1.4 b/media-plugins/vdr-graphlcd/files/digest-vdr-graphlcd-0.1.4
new file mode 100644
index 000000000000..12528299d02b
--- /dev/null
+++ b/media-plugins/vdr-graphlcd/files/digest-vdr-graphlcd-0.1.4
@@ -0,0 +1,3 @@
+MD5 08e8645f708c7724e193399440940d76 vdr-graphlcd-0.1.4.tgz 240053
+RMD160 88114a3bbf68231428de441c4cf5cc45b0d2e6a4 vdr-graphlcd-0.1.4.tgz 240053
+SHA256 f5cbe57b559d5b68492301bf89eca9ec16022a4bb8c09ccd2727cfeb273ac146 vdr-graphlcd-0.1.4.tgz 240053
diff --git a/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.4.ebuild b/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.4.ebuild
new file mode 100644
index 000000000000..c554f24b081b
--- /dev/null
+++ b/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.4.ebuild,v 1.1 2007/02/04 23:38:35 hd_brummy Exp $
+
+inherit eutils vdr-plugin
+
+DESCRIPTION="VDR Graphical LCD Plugin"
+HOMEPAGE="http://graphlcd.berlios.de/"
+SRC_URI="http://download.berlios.de/graphlcd/${P}.tgz"
+
+KEYWORDS="~x86 ~amd64"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="truetype"
+
+DEPEND=">=media-video/vdr-1.2.6
+ >=app-misc/graphlcd-base-${PV}"
+
+PATCHES="
+ ${FILESDIR}/0.1.4/graphlcd-0.1.4-span.diff
+ ${FILESDIR}/0.1.4/graphlcd-0.1.4-radiotext-lcr-service.diff"
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ sed -i "s:/usr/local:/usr:" Makefile
+}
+
+src_install() {
+ vdr-plugin_src_install
+
+ insopts -m0644 -ovdr -gvdr
+
+ insinto /usr/share/vdr/${VDRPLUGIN}/logos
+ doins -r ${VDRPLUGIN}/logos/*
+
+ insinto /usr/share/vdr/${VDRPLUGIN}/fonts
+ doins ${VDRPLUGIN}/fonts/*.fnt
+
+ if use truetype; then
+ for font in /usr/share/fonts/corefonts/*.ttf; do
+ elog ${font}
+ dosym ${font} /usr/share/vdr/graphlcd/fonts
+ done
+ fi
+
+ insinto /etc/vdr/plugins/${VDRPLUGIN}
+ doins ${VDRPLUGIN}/logonames.alias.*
+ doins ${VDRPLUGIN}/fonts.conf.*
+
+ dosym /usr/share/vdr/${VDRPLUGIN}/fonts /etc/vdr/plugins/${VDRPLUGIN}/fonts
+ dosym /usr/share/vdr/${VDRPLUGIN}/logos /etc/vdr/plugins/${VDRPLUGIN}/logos
+ dosym /etc/graphlcd.conf /etc/vdr/plugins/${VDRPLUGIN}/graphlcd.conf
+
+ if has_version ">=media-video/vdr-1.3.2" ; then
+ dosym /etc/vdr/plugins/${VDRPLUGIN}/logonames.alias.1.3 /etc/vdr/plugins/${VDRPLUGIN}/logonames.alias
+ else
+ dosym /etc/vdr/plugins/${VDRPLUGIN}/logonames.alias.1.2 /etc/vdr/plugins/${VDRPLUGIN}/logonames.alias
+ fi
+}
+
+pkg_preinst() {
+
+ if [[ -e /etc/vdr/plugins/graphlcd/fonts ]] && [[ ! -L /etc/vdr/plugins/graphlcd/fonts ]] \
+ || [[ -e /etc/vdr/plugins/graphlcd/logos ]] && [[ ! -L /etc/vdr/plugins/graphlcd/logos ]] ;then
+
+ elog "Remove wrong DIR in /etc/vdr/plugins/graphlcd from prior install"
+ elog "Press CTRL+C to abbort"
+ epause
+ rmdir -R /etc/vdrplugins/graphlcd/{fonts,logos}
+ fi
+}
+
+pkg_postinst() {
+ vdr-plugin_pkg_postinst
+
+ elog "Add additional options in /etc/conf.d/vdr.graphlcd"
+ elog
+ elog "Please copy or link one of the supplied fonts.conf.*"
+ elog "files in /etc/vdr/plugins/graphlcd/ to"
+ elog "/etc/vdr/plugins/graphlcd/fonts.conf"
+}
+