summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2009-07-17 06:51:05 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2009-07-17 06:51:05 +0000
commit099d45491598da4014088c6e21775e59780878dc (patch)
tree340ab9c62a55424c555c8a68ab3ab6fc5717301f /media-plugins/vdr-epgsearch
parentVersion bump (diff)
downloadgentoo-2-099d45491598da4014088c6e21775e59780878dc.tar.gz
gentoo-2-099d45491598da4014088c6e21775e59780878dc.tar.bz2
gentoo-2-099d45491598da4014088c6e21775e59780878dc.zip
Version bumped.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-plugins/vdr-epgsearch')
-rw-r--r--media-plugins/vdr-epgsearch/ChangeLog8
-rw-r--r--media-plugins/vdr-epgsearch/vdr-epgsearch-0.9.25_beta14.ebuild89
2 files changed, 96 insertions, 1 deletions
diff --git a/media-plugins/vdr-epgsearch/ChangeLog b/media-plugins/vdr-epgsearch/ChangeLog
index 262714116342..15ed42bb23bb 100644
--- a/media-plugins/vdr-epgsearch/ChangeLog
+++ b/media-plugins/vdr-epgsearch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/vdr-epgsearch
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-epgsearch/ChangeLog,v 1.43 2009/04/11 10:07:16 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-epgsearch/ChangeLog,v 1.44 2009/07/17 06:51:05 zzam Exp $
+
+*vdr-epgsearch-0.9.25_beta14 (17 Jul 2009)
+
+ 17 Jul 2009; Matthias Schwarzott <zzam@gentoo.org>
+ +vdr-epgsearch-0.9.25_beta14.ebuild:
+ Version bumped.
*vdr-epgsearch-0.9.25_beta13 (11 Apr 2009)
diff --git a/media-plugins/vdr-epgsearch/vdr-epgsearch-0.9.25_beta14.ebuild b/media-plugins/vdr-epgsearch/vdr-epgsearch-0.9.25_beta14.ebuild
new file mode 100644
index 000000000000..8fd28577e2f6
--- /dev/null
+++ b/media-plugins/vdr-epgsearch/vdr-epgsearch-0.9.25_beta14.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-epgsearch/vdr-epgsearch-0.9.25_beta14.ebuild,v 1.1 2009/07/17 06:51:05 zzam Exp $
+
+inherit vdr-plugin
+
+DESCRIPTION="Video Disk Recorder epgsearch plugin"
+HOMEPAGE="http://winni.vdr-developer.org/epgsearch"
+
+case ${P#*_} in
+ rc*|beta*)
+ MY_P="${P/_/.}"
+ SRC_URI="http://winni.vdr-developer.org/epgsearch/downloads/beta/${MY_P}.tgz"
+ S="${WORKDIR}/${MY_P#vdr-}"
+ ;;
+ *)
+ SRC_URI="http://winni.vdr-developer.org/epgsearch/downloads/${P}.tgz"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pcre tre"
+
+DEPEND=">=media-video/vdr-1.3.45
+ pcre? ( dev-libs/libpcre )
+ tre? ( dev-libs/tre )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ cd "${S}"
+ fix_vdr_libsi_include conflictcheck.c
+
+ # disable automagic deps
+ sed -i Makefile -e '/^AUTOCONFIG=/s/^/#/'
+
+ if use pcre; then
+ einfo "Using pcre for regexp searches"
+ sed -i Makefile -e 's/^#HAVE_PCREPOSIX/HAVE_PCREPOSIX/'
+ fi
+
+ if use tre; then
+ einfo "Using tre for unlimited fuzzy searches"
+ sed -i Makefile -e 's/^#HAVE_LIBTRE/HAVE_LIBTRE/'
+ fi
+
+ # install conf-file disabled
+ sed -e '/^Menu/s:^:#:' -i conf/epgsearchmenu.conf
+}
+
+src_install() {
+ vdr-plugin_src_install
+ cd "${S}"
+ diropts "-m755 -o vdr -g vdr"
+ keepdir /etc/vdr/plugins/epgsearch
+ insinto /etc/vdr/plugins/epgsearch
+
+ doins conf/epgsearchmenu.conf
+ doins conf/epgsearchconflmail.templ conf/epgsearchupdmail.templ
+
+ dodoc conf/*.templ
+
+ emake install-doc MANDIR="${D}/usr/share/man"
+ dodoc MANUAL
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.9.18"
+ previous_less_than_0_9_18=$?
+}
+
+pkg_postinst() {
+ vdr-plugin_pkg_postinst
+ if [[ $previous_less_than_0_9_18 = 0 ]] ; then
+ elog "Moving config-files to new location /etc/vdr/plugins/epgsearch"
+ cd "${ROOT}"/etc/vdr/plugins
+ local f
+ local moved=""
+ for f in epgsearch*.* .epgsearch*; do
+ [[ -e ${f} ]] || continue
+ mv "${f}" "${ROOT}/etc/vdr/plugins/epgsearch"
+ moved="${moved} ${f}"
+ done
+ elog "These files were moved:${moved}"
+ fi
+}