summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2010-04-01 07:58:08 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2010-04-01 07:58:08 +0000
commit6153685dd42d3a8af59f41d42fbdea3818d99429 (patch)
tree16336454803f37d2cea524471b4dae4dcb018125 /media-plugins/banshee-community-extensions
parentBump to 1.6.0. This is the latest stable version with a huge number of new fe... (diff)
downloadgentoo-2-6153685dd42d3a8af59f41d42fbdea3818d99429.tar.gz
gentoo-2-6153685dd42d3a8af59f41d42fbdea3818d99429.tar.bz2
gentoo-2-6153685dd42d3a8af59f41d42fbdea3818d99429.zip
Bump to 1.6.0. Mostly bug fixes, and a new plugin we don't care about.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/banshee-community-extensions')
-rw-r--r--media-plugins/banshee-community-extensions/ChangeLog8
-rw-r--r--media-plugins/banshee-community-extensions/banshee-community-extensions-1.6.0.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/media-plugins/banshee-community-extensions/ChangeLog b/media-plugins/banshee-community-extensions/ChangeLog
index 36d483f2265a..25b8f006817d 100644
--- a/media-plugins/banshee-community-extensions/ChangeLog
+++ b/media-plugins/banshee-community-extensions/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/banshee-community-extensions
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/banshee-community-extensions/ChangeLog,v 1.2 2010/03/25 22:30:34 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/banshee-community-extensions/ChangeLog,v 1.3 2010/04/01 07:58:08 ford_prefect Exp $
+
+*banshee-community-extensions-1.6.0 (01 Apr 2010)
+
+ 01 Apr 2010; Arun Raghavan <ford_prefect@gentoo.org>
+ +banshee-community-extensions-1.6.0.ebuild:
+ Bump to 1.6.0. Mostly bug fixes, and a new plugin we don't care about.
*banshee-community-extensions-1.5.5 (25 Mar 2010)
diff --git a/media-plugins/banshee-community-extensions/banshee-community-extensions-1.6.0.ebuild b/media-plugins/banshee-community-extensions/banshee-community-extensions-1.6.0.ebuild
new file mode 100644
index 000000000000..5fedfae40762
--- /dev/null
+++ b/media-plugins/banshee-community-extensions/banshee-community-extensions-1.6.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/banshee-community-extensions/banshee-community-extensions-1.6.0.ebuild,v 1.1 2010/04/01 07:58:08 ford_prefect Exp $
+
+EAPI=3
+
+inherit base mono
+
+DESCRIPTION="Community-developed plugins for the Banshee media player"
+HOMEPAGE="http://banshee-project.org/"
+SRC_URI="http://download.banshee-project.org/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lirc lyrics mirage telepathy"
+
+DEPEND=">=dev-lang/mono-2.0
+ >=media-sound/banshee-1.5.4
+ >=gnome-base/gconf-2.0
+ dev-dotnet/gconf-sharp:2
+ lyrics? (
+ >=dev-dotnet/webkit-sharp-0.2
+ )
+ mirage? (
+ dev-libs/glib:2
+ dev-db/sqlite:3
+ sci-libs/fftw:3.0
+ media-libs/libsamplerate
+ >=media-libs/gstreamer-0.10.15
+ >=media-libs/gst-plugins-base-0.10.15
+ )
+ telepathy? (
+ dev-dotnet/notify-sharp
+ >=dev-lang/mono-2.4.2
+ )"
+RDEPEND="${DEPEND}
+ !media-plugins/banshee-lyrics
+ !media-plugins/banshee-mirage"
+
+src_configure() {
+ # Disable ClutterFlow as we don't have clutter in tree yet
+ # Disable UbuntuOneMusicStore as we don't have ubuntuone-sharp
+ # Disable AppIndicator as it's not in tree
+ local myconf="--enable-gnome --disable-static --enable-release
+ --with-gconf-schema-file-dir=/etc/gconf/schemas
+ --with-vendor-build-id=Gentoo/${PN}/${PVR}
+ --disable-clutterflow --enable-liveradio
+ --enable-coverwallpaper --enable-magnatune
+ --disable-ubuntuonemusicstore --disable-appindicator"
+
+ econf \
+ $(use_enable lirc) \
+ $(use_enable lyrics) \
+ $(use_enable mirage) \
+ $(use_enable telepathy) \
+ $(use_enable test tests) \
+ ${myconf}
+}
+
+src_install() {
+ base_src_install
+}