summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-09 14:28:44 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-09 14:28:44 +0000
commitb5d0fdefe3e56275535ff14089a542e72115a369 (patch)
treebfc5b66cda64cafde44da8620de75a76f20a75e0 /media-plugins/alsa-plugins
parentMask multilib alsa-oss & alsa-plugins. (diff)
downloadgentoo-2-b5d0fdefe3e56275535ff14089a542e72115a369.tar.gz
gentoo-2-b5d0fdefe3e56275535ff14089a542e72115a369.tar.bz2
gentoo-2-b5d0fdefe3e56275535ff14089a542e72115a369.zip
Introduce multilib support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-plugins/alsa-plugins')
-rw-r--r--media-plugins/alsa-plugins/ChangeLog7
-rw-r--r--media-plugins/alsa-plugins/alsa-plugins-1.0.27-r2.ebuild99
2 files changed, 105 insertions, 1 deletions
diff --git a/media-plugins/alsa-plugins/ChangeLog b/media-plugins/alsa-plugins/ChangeLog
index ccc47697210c..07d4fa1d13a4 100644
--- a/media-plugins/alsa-plugins/ChangeLog
+++ b/media-plugins/alsa-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/alsa-plugins
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.192 2014/04/05 19:20:01 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/ChangeLog,v 1.193 2014/05/09 14:28:44 mgorny Exp $
+
+*alsa-plugins-1.0.27-r2 (09 May 2014)
+
+ 09 May 2014; Michał Górny <mgorny@gentoo.org> +alsa-plugins-1.0.27-r2.ebuild:
+ Introduce multilib support.
05 Apr 2014; Samuli Suominen <ssuominen@gentoo.org>
-alsa-plugins-1.0.26.ebuild, -alsa-plugins-1.0.27.ebuild,
diff --git a/media-plugins/alsa-plugins/alsa-plugins-1.0.27-r2.ebuild b/media-plugins/alsa-plugins/alsa-plugins-1.0.27-r2.ebuild
new file mode 100644
index 000000000000..ba439ec1aef7
--- /dev/null
+++ b/media-plugins/alsa-plugins/alsa-plugins-1.0.27-r2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/alsa-plugins/alsa-plugins-1.0.27-r2.ebuild,v 1.1 2014/05/09 14:28:44 mgorny Exp $
+
+EAPI=5
+inherit autotools eutils flag-o-matic multilib multilib-minimal
+
+DESCRIPTION="ALSA extra plugins"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/plugins/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux"
+IUSE="debug ffmpeg jack libsamplerate pulseaudio speex"
+
+# TODO: handle USE=ffmpeg once it is converted
+
+RDEPEND=">=media-libs/alsa-lib-${PV}:=[${MULTILIB_USEDEP}]
+ ffmpeg? ( virtual/ffmpeg )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.98[${MULTILIB_USEDEP}] )
+ libsamplerate? ( media-libs/libsamplerate:=[${MULTILIB_USEDEP}] )
+ pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )
+ speex? ( media-libs/speex:=[${MULTILIB_USEDEP}] )
+ abi_x86_32? (
+ !<app-emulation/emul-linux-x86-soundlibs-20140406-r1
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32]
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.0.19-missing-avutil.patch \
+ "${FILESDIR}"/${PN}-1.0.23-automagic.patch \
+ "${FILESDIR}"/${P}-{ffmpeg,ffmpeg-version-check}.patch
+
+ epatch_user
+
+ # For some reasons the polyp/pulse plugin does fail with alsaplayer with a
+ # failed assert. As the code works just fine with asserts disabled, for now
+ # disable them waiting for a better solution.
+ sed -i \
+ -e '/AM_CFLAGS/s:-Wall:-DNDEBUG -Wall:' \
+ pulse/Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ use debug || append-cppflags -DNDEBUG
+
+ local myspeex=no
+ use speex && myspeex=lib
+
+ ECONF_SOURCE=${S} \
+ econf \
+ $(multilib_native_use_enable ffmpeg avcodec) \
+ $(use_enable jack) \
+ $(use_enable libsamplerate samplerate) \
+ $(use_enable pulseaudio) \
+ --with-speex=${myspeex}
+}
+
+src_install_all() {
+ einstalldocs
+
+ cd doc || die
+ dodoc upmix.txt vdownmix.txt README-pcm-oss
+ use jack && dodoc README-jack
+ use libsamplerate && dodoc samplerate.txt
+ use ffmpeg && dodoc lavcrate.txt a52.txt
+
+ if use pulseaudio; then
+ dodoc README-pulse
+ # install ALSA configuration files
+ # making PA to be used by alsa clients
+ insinto /usr/share/alsa
+ doins "${FILESDIR}"/pulse-default.conf
+ insinto /usr/share/alsa/alsa.conf.d
+ doins "${FILESDIR}"/51-pulseaudio-probe.conf
+ # bug #410261, comment 5+
+ # seems to work fine without any path
+ sed -i \
+ -e "s:/usr/lib/alsa-lib/::" \
+ "${ED}"/usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf || die #410261
+ fi
+
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ if use pulseaudio; then
+ einfo "The PulseAudio device is now set as the default device if the"
+ einfo "PulseAudio server is found to be running. Any custom"
+ einfo "configuration in /etc/asound.conf or ~/.asoundrc for this"
+ einfo "purpose should now be unnecessary."
+ fi
+}