summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-11 02:18:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-11 02:18:04 +0000
commitf4f01a7e6332e620f49e0bc03866f7aa7d40748e (patch)
tree1d2e91d925899e3aa3dabe654d719b07ce93eeea /media-libs
parentmark x86 for gnome 2.8 (Manifest recommit) (diff)
downloadgentoo-2-f4f01a7e6332e620f49e0bc03866f7aa7d40748e.tar.gz
gentoo-2-f4f01a7e6332e620f49e0bc03866f7aa7d40748e.tar.bz2
gentoo-2-f4f01a7e6332e620f49e0bc03866f7aa7d40748e.zip
Version bump.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/raptor/ChangeLog7
-rw-r--r--media-libs/raptor/files/digest-raptor-1.4.21
-rw-r--r--media-libs/raptor/raptor-1.4.2.ebuild67
3 files changed, 74 insertions, 1 deletions
diff --git a/media-libs/raptor/ChangeLog b/media-libs/raptor/ChangeLog
index 3986a2f5d20c..7d8da2188a99 100644
--- a/media-libs/raptor/ChangeLog
+++ b/media-libs/raptor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/raptor
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.18 2004/10/01 20:36:57 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.19 2004/11/11 02:18:04 vapier Exp $
+
+*raptor-1.4.2 (10 Nov 2004)
+
+ 10 Nov 2004; Mike Frysinger <vapier@gentoo.org> +raptor-1.4.2.ebuild:
+ Version bump.
01 Oct 2004; kito@gentoo.org raptor-1.2.0.ebuild:
added ~ppc-macos
diff --git a/media-libs/raptor/files/digest-raptor-1.4.2 b/media-libs/raptor/files/digest-raptor-1.4.2
new file mode 100644
index 000000000000..64a8bedc94d7
--- /dev/null
+++ b/media-libs/raptor/files/digest-raptor-1.4.2
@@ -0,0 +1 @@
+MD5 0c7336e2fe66591afef281136a9ecd30 raptor-1.4.2.tar.gz 919498
diff --git a/media-libs/raptor/raptor-1.4.2.ebuild b/media-libs/raptor/raptor-1.4.2.ebuild
new file mode 100644
index 000000000000..03c7b4690a94
--- /dev/null
+++ b/media-libs/raptor/raptor-1.4.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-1.4.2.ebuild,v 1.1 2004/11/11 02:18:04 vapier Exp $
+
+DESCRIPTION="The RDF Parser Toolkit"
+HOMEPAGE="http://www.redland.opensource.ac.uk/raptor/"
+SRC_URI="http://www.redland.opensource.ac.uk/dist/source/${P}.tar.gz"
+
+LICENSE="LGPL-2 MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~x86"
+IUSE="curl xml2 gnome ssl"
+
+DEPEND="virtual/libc
+ gnome? ( >=dev-libs/glib-2.2.1 dev-util/pkgconfig )
+ xml2? ( >=dev-libs/libxml2-2.4.0 )
+ !xml2? ( dev-libs/expat )
+ ssl? ( dev-libs/openssl )
+ curl? ( net-misc/curl )"
+RDEPEND="virtual/libc
+ gnome? ( >=dev-libs/glib-2.2.1 )
+ xml2? ( >=dev-libs/libxml2-2.4.0 )
+ !xml2? ( dev-libs/expat )
+ ssl? ( dev-libs/openssl )
+ curl? ( net-misc/curl )"
+
+# compilation with libwww currently breaks and for using libfetch I didn't find the right USE flag
+#IUSE="curl xml2 libwww gnome"
+#DEPEND="virtual/libc
+# gnome? ( >=dev-libs/glib-2.2.1 dev-util/pkgconfig )
+# xml2? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
+# ssl? ( dev-libs/openssl )
+# curl? ( net-misc/curl ) : ( !xml2? ( libwww? ( net-libs/libwww ) ) )
+# "
+#RDEPEND="virtual/libc
+# gnome? ( >=dev-libs/glib-2.2.1 )
+# xml2? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
+# ssl? ( dev-libs/openssl )
+# curl? ( net-misc/curl ) : ( !xml2? ( libwww? ( net-libs/libwww ) ) )"
+
+DOC="AUTHORS ChangeLog INSTALL NEWS README"
+HTML="INSTALL.html NEWS.html README.html"
+
+src_compile() {
+ myraptorconf=""
+
+ use xml2 \
+ && myraptorconf="${myraptorconf} --with-xml-parser=libxml" \
+ || myraptorconf="${myraptorconf} --with-xml-parser=expat"
+
+ use curl && myraptorconf="${myraptorconf} --with-www=curl" \
+ || use xml2 && myraptorconf="${myraptorconf} --with-www=xml" \
+ || myraptorconf="${myraptorconf} --with-www=none"
+# || use libwww && myraptorconf="${myraptorconf} --with-www=libwww" \
+ econf \
+ `use_enable gnome nfc-check` \
+ ${myraptorconf} \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc ${DOC}
+ dohtml ${HTML}
+}