summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2012-07-13 11:25:35 +0000
committerHanno Böck <hanno@gentoo.org>2012-07-13 11:25:35 +0000
commitb35fd74377084d1b0bcf336728601f26d579ed2a (patch)
tree4d9ff1cb291734979f4dae748f6eda6b81275f2c /media-libs
parentFix building with gcc 4.7 (bug #426332) (diff)
downloadgentoo-2-b35fd74377084d1b0bcf336728601f26d579ed2a.tar.gz
gentoo-2-b35fd74377084d1b0bcf336728601f26d579ed2a.tar.bz2
gentoo-2-b35fd74377084d1b0bcf336728601f26d579ed2a.zip
gegl: fix compilation with ffmpeg 0.11.
(Portage version: 2.1.11.6/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gegl/ChangeLog6
-rw-r--r--media-libs/gegl/files/gegl-0.2.0-ffmpeg-0.11.diff12
-rw-r--r--media-libs/gegl/gegl-0.2.0.ebuild3
3 files changed, 19 insertions, 2 deletions
diff --git a/media-libs/gegl/ChangeLog b/media-libs/gegl/ChangeLog
index f5598339a4ac..c71479e5e1fd 100644
--- a/media-libs/gegl/ChangeLog
+++ b/media-libs/gegl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/gegl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/ChangeLog,v 1.71 2012/05/30 13:43:51 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/ChangeLog,v 1.72 2012/07/13 11:25:35 hanno Exp $
+
+ 13 Jul 2012; Hanno Boeck <hanno@gentoo.org> gegl-0.2.0.ebuild,
+ +files/gegl-0.2.0-ffmpeg-0.11.diff:
+ Build with ffmpeg 0.11, patch from linuxfromscratch.
30 May 2012; Alexis Ballier <aballier@gentoo.org> gegl-0.2.0.ebuild:
keyword ~amd64-fbsd
diff --git a/media-libs/gegl/files/gegl-0.2.0-ffmpeg-0.11.diff b/media-libs/gegl/files/gegl-0.2.0-ffmpeg-0.11.diff
new file mode 100644
index 000000000000..a33ec6f7fdcf
--- /dev/null
+++ b/media-libs/gegl/files/gegl-0.2.0-ffmpeg-0.11.diff
@@ -0,0 +1,12 @@
+diff -Naur gegl-0.2.0/operations/external/ff-load.c gegl-0.2.0-1/operations/external/ff-load.c
+--- gegl-0.2.0/operations/external/ff-load.c 2012-04-01 13:17:57.000000000 +0200
++++ gegl-0.2.0-1/operations/external/ff-load.c 2012-07-11 12:42:05.174756560 +0200
+@@ -271,7 +271,7 @@
+ gint err;
+
+ ff_cleanup (o);
+- err = av_open_input_file (&p->ic, o->path, NULL, 0, NULL);
++err = avformat_open_input (&p->ic, o->path, NULL, NULL);
+ if (err < 0)
+ {
+ print_error (o->path, err);
diff --git a/media-libs/gegl/gegl-0.2.0.ebuild b/media-libs/gegl/gegl-0.2.0.ebuild
index 675fbe9a9161..57ca828e4eb3 100644
--- a/media-libs/gegl/gegl-0.2.0.ebuild
+++ b/media-libs/gegl/gegl-0.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/gegl-0.2.0.ebuild,v 1.4 2012/05/30 13:43:51 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/gegl-0.2.0.ebuild,v 1.5 2012/07/13 11:25:35 hanno Exp $
EAPI=4
@@ -54,6 +54,7 @@ RESTRICT="test"
DOCS=( ChangeLog INSTALL README NEWS )
src_prepare() {
+ epatch "${FILESDIR}/${P}-ffmpeg-0.11.diff"
# fix OSX loadable module filename extension
sed -i -e 's/\.dylib/.bundle/' configure.ac || die
# don't require Apple's OpenCL on versions of OSX that don't have it