summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-03-26 03:02:49 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-03-26 03:02:49 +0000
commit7a852b90edfd8f2454cd4b33cb2d1af5a1355fed (patch)
tree8895f6d9ee8d5edde6dab139b73e2989153c2ec3 /media-libs
parentVersion bump. (diff)
downloadgentoo-2-7a852b90edfd8f2454cd4b33cb2d1af5a1355fed.tar.gz
gentoo-2-7a852b90edfd8f2454cd4b33cb2d1af5a1355fed.tar.bz2
gentoo-2-7a852b90edfd8f2454cd4b33cb2d1af5a1355fed.zip
Bump, p.masked because API changed
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/clutter-gst/ChangeLog8
-rw-r--r--media-libs/clutter-gst/clutter-gst-1.5.4.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/media-libs/clutter-gst/ChangeLog b/media-libs/clutter-gst/ChangeLog
index 374bb0f62387..62e85538f428 100644
--- a/media-libs/clutter-gst/ChangeLog
+++ b/media-libs/clutter-gst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/clutter-gst
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter-gst/ChangeLog,v 1.23 2012/02/19 10:09:50 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter-gst/ChangeLog,v 1.24 2012/03/26 03:02:49 nirbheek Exp $
+
+*clutter-gst-1.5.4 (26 Mar 2012)
+
+ 26 Mar 2012; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +clutter-gst-1.5.4.ebuild:
+ Bump, p.masked because API changed
19 Feb 2012; Tobias Klausmann <klausman@gentoo.org> clutter-gst-1.4.6.ebuild:
Keyworded on alpha, bug #379649
diff --git a/media-libs/clutter-gst/clutter-gst-1.5.4.ebuild b/media-libs/clutter-gst/clutter-gst-1.5.4.ebuild
new file mode 100644
index 000000000000..f1f812423597
--- /dev/null
+++ b/media-libs/clutter-gst/clutter-gst-1.5.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter-gst/clutter-gst-1.5.4.ebuild,v 1.1 2012/03/26 03:02:49 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+CLUTTER_LA_PUNT="yes"
+
+# inherit clutter after gnome2 so that defaults aren't overriden
+# inherit gnome.org in the end so we use gnome mirrors and get the xz tarball
+# no PYTHON_DEPEND, python2 is just a build-time dependency
+inherit python gnome2 clutter gnome.org
+
+DESCRIPTION="GStreamer Integration library for Clutter"
+
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE="doc examples +introspection"
+
+# FIXME: Support for gstreamer-basevideo-0.10 (HW decoder support) is automagic
+RDEPEND="
+ >=dev-libs/glib-2.20:2
+ >=media-libs/clutter-1.6.0:1.0[introspection?]
+ >=media-libs/gstreamer-0.10.26:0.10[introspection?]
+ >=media-libs/gst-plugins-bad-0.10.22:0.10[introspection?]
+ media-libs/gst-plugins-base:0.10[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.8 )"
+DEPEND="${RDEPEND}
+ =dev-lang/python-2*
+ doc? ( >=dev-util/gtk-doc-1.8 )"
+# eautoreconf does *not* need gtk-doc-am, see build/autotools/ directory
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS README"
+ EXAMPLES="examples/{*.c,*.png,README}"
+ G2CONF="${G2CONF}
+ --disable-maintainer-flags
+ $(use_enable introspection)"
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # bug #401383, https://bugzilla.gnome.org/show_bug.cgi?id=669054
+ # FIXME: is this still needed? I don't think so, but not sure. ~nirbheek
+ #eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_compile() {
+ # Clutter tries to access dri without userpriv, upstream bug #661873
+ # Massive failure of a hack, see bug 360219, bug 360073, bug 363917
+ DISPLAY="999invalid" emake
+}