summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-12-26 15:42:53 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-12-26 15:42:53 +0000
commit75232806b63631bf7b2e38ad843f6fdbfb710a8b (patch)
treea9a4ce660e4c315a94174c7f1b51b2ffa755b701 /media-libs
parentx86 stable. Closes 36444. (Manifest recommit) (diff)
downloadgentoo-2-75232806b63631bf7b2e38ad843f6fdbfb710a8b.tar.gz
gentoo-2-75232806b63631bf7b2e38ad843f6fdbfb710a8b.tar.bz2
gentoo-2-75232806b63631bf7b2e38ad843f6fdbfb710a8b.zip
Fixing syntax to not apply with gcc2. Closes 36451
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libvorbis/ChangeLog5
-rw-r--r--media-libs/libvorbis/libvorbis-1.0.1.ebuild16
2 files changed, 16 insertions, 5 deletions
diff --git a/media-libs/libvorbis/ChangeLog b/media-libs/libvorbis/ChangeLog
index ebda32aa82c2..c183562633ef 100644
--- a/media-libs/libvorbis/ChangeLog
+++ b/media-libs/libvorbis/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/libvorbis
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/ChangeLog,v 1.22 2003/12/18 20:49:53 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/ChangeLog,v 1.23 2003/12/26 15:42:53 mholzer Exp $
+
+ 26 Dec 2003; Martin Holzer <mholzer@gentoo.org> libvorbis-1.0.1.ebuild:
+ Fixing syntax to not apply with gcc2. Closes 36451
18 Dec 2003; Martin Holzer <mholzer@gentoo.org> libvorbis-1.0.1.ebuild:
marking stable.
diff --git a/media-libs/libvorbis/libvorbis-1.0.1.ebuild b/media-libs/libvorbis/libvorbis-1.0.1.ebuild
index a3c35e639259..4b173c9cef5f 100644
--- a/media-libs/libvorbis/libvorbis-1.0.1.ebuild
+++ b/media-libs/libvorbis/libvorbis-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.0.1.ebuild,v 1.4 2003/12/19 23:07:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.0.1.ebuild,v 1.5 2003/12/26 15:42:53 mholzer Exp $
inherit libtool eutils flag-o-matic
@@ -37,6 +37,17 @@ src_unpack() {
# Fix a gcc crash. With the new atexit patch to gcc, it
# seems it do not handle -mno-ieee-fp too well.
sed -i -e "s:-mno-ieee-fp::g" configure
+
+ #got this from xine-lib
+ #fix build errors with -march/mcpu=pentium4
+ #Closes #36104
+ if [ "$COMPILER" == "gcc3" ]; then
+ if [ -n "`is-flag -march=pentium4`" -o -n "`is-flag -mcpu=pentium4`" ];
+ then
+ einfo "no-sse2 for P4"
+ append-flags -mno-sse2
+ fi
+ fi
}
src_compile() {
@@ -50,9 +61,6 @@ src_compile() {
# filter march, see bug #26463 for details
filter-flags "-march=pentium?"
- # remove sse2 support #36104
- append-flags -mno-sse2
-
./configure --prefix=/usr \
--host=${CHOST} || die