summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-23 16:58:46 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-23 16:58:46 +0000
commit57c17f973915b88e4b7ae9e593ea57c8bb277616 (patch)
tree72e73abdb40f85d1e682682c85e4c68e30399dee /media-libs
parentnew release 'n cleanup (Manifest recommit) (diff)
downloadgentoo-2-57c17f973915b88e4b7ae9e593ea57c8bb277616.tar.gz
gentoo-2-57c17f973915b88e4b7ae9e593ea57c8bb277616.tar.bz2
gentoo-2-57c17f973915b88e4b7ae9e593ea57c8bb277616.zip
-fPIC update. Makefile overhaul. Supports user CFLAGS.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/daaplib/ChangeLog6
-rw-r--r--media-libs/daaplib/daaplib-0.1.1a.ebuild33
-rw-r--r--media-libs/daaplib/files/daaplib-0.1.1a-Makefile42
3 files changed, 61 insertions, 20 deletions
diff --git a/media-libs/daaplib/ChangeLog b/media-libs/daaplib/ChangeLog
index 58af03aa1bd7..66a832870351 100644
--- a/media-libs/daaplib/ChangeLog
+++ b/media-libs/daaplib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/daaplib
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/daaplib/ChangeLog,v 1.2 2004/03/25 11:56:17 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/daaplib/ChangeLog,v 1.3 2004/04/23 16:58:46 eradicator Exp $
+
+ 23 Apr 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ daaplib-0.1.1a.ebuild, files/daaplib-0.1.1a-Makefile:
+ -fPIC update. Makefile overhaul. Supports user CFLAGS.
25 Mar 2004; David Holm <dholm@gentoo.org> daaplib-0.1.1a.ebuild:
Added to ~ppc.
diff --git a/media-libs/daaplib/daaplib-0.1.1a.ebuild b/media-libs/daaplib/daaplib-0.1.1a.ebuild
index 83d228f4a033..e618ea314b82 100644
--- a/media-libs/daaplib/daaplib-0.1.1a.ebuild
+++ b/media-libs/daaplib/daaplib-0.1.1a.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/daaplib/daaplib-0.1.1a.ebuild,v 1.2 2004/03/25 11:56:17 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/daaplib/daaplib-0.1.1a.ebuild,v 1.3 2004/04/23 16:58:46 eradicator Exp $
+
+inherit eutils
DESCRIPTION="a tiny, portable C++ library to read and write low-level DAAP streams in memory"
HOMEPAGE="http://www.deleet.de/projekte/daap/daaplib/"
@@ -14,29 +16,22 @@ RDEPEND=""
S=${WORKDIR}/${PN}.${PV}/daaplib/src
+src_unpack() {
+ unpack ${A}
+
+ # Use updated gentoo Makefile
+ ebegin "Updating Makefile"
+ cp ${FILESDIR}/${P}-Makefile ${S}/makefile
+ eend $?
+}
+
src_compile() {
- # There is no configure step
emake || die
-
- if use static; then
- ranlib libdaaplib.a
- else
- c++ -shared --soname=libdaaplib.so -o libdaaplib.so taginput.o tagoutput.o registry.o
- fi
}
src_install() {
- # Not an autoconf make file :(
-
- if use static; then
- dolib.a libdaaplib.a
- else
- dolib.so libdaaplib.so
- fi
-
- mkdir -p ${D}/usr/include/
- cp -r ../include/daap ${D}/usr/include/
- chmod -R a+r ${D}/usr/include/daap
+ make DESTDIR="${D}" PREFIX=/usr install
+ use static || rm ${D}/usr/lib/libdaaplib.a
dodoc ../../COPYING ../../README
}
diff --git a/media-libs/daaplib/files/daaplib-0.1.1a-Makefile b/media-libs/daaplib/files/daaplib-0.1.1a-Makefile
new file mode 100644
index 000000000000..4d8f5cca42fb
--- /dev/null
+++ b/media-libs/daaplib/files/daaplib-0.1.1a-Makefile
@@ -0,0 +1,42 @@
+CXX = c++
+AR = ar
+CP = cp
+RM = rm
+
+TARGET = libdaaplib.a libdaaplib.so
+OBJS = taginput.o tagoutput.o registry.o
+
+LIBS =
+LIBPATH =
+PREFIX = /usr/local
+LIBDEPLOY = $(PREFIX)/lib
+INCDEPLOY = $(PREFIX)/include
+INCPATH = ../include
+DESTDIR =
+FLAGS = -Wall -Wno-multichar -fPIC $(CXXFLAGS) $(CPPFLAGS)
+
+.cpp.o:
+ $(CXX) $(FLAGS) -I$(INCPATH) -c $<
+
+libdaaplib.a: $(OBJS)
+ $(AR) rs libdaaplib.a $(OBJS)
+ ranlib libdaaplib.a
+
+libdaaplib.so: $(OBJS)
+ $(CXX) -shared --soname=libdaaplib.so -o libdaaplib.so $(OBJS)
+
+$(OBJS): $(<:.o=.h) $(INCPATH)/daap/basic.h
+
+clean:
+ rm $(OBJS) $(TARGET)
+
+install: $(TARGET)
+ mkdir -p $(DESTDIR)$(LIBDEPLOY)
+ cp libdaaplib.a $(DESTDIR)$(LIBDEPLOY)
+ chmod 644 $(DESTDIR)$(LIBDEPLOY)/libdaaplib.a
+ cp libdaaplib.so $(DESTDIR)$(LIBDEPLOY)
+ chmod 755 $(DESTDIR)$(LIBDEPLOY)/libdaaplib.so
+
+ mkdir -p $(DESTDIR)$(INCDEPLOY)
+ cp -r $(INCPATH)/daap $(DESTDIR)$(INCDEPLOY)
+ chmod -R a+r $(DESTDIR)$(INCDEPLOY)/daap