summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-03-15 16:10:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-03-15 16:10:45 +0000
commit50403c1164824b08b587a34e3bfef1a9778030db (patch)
tree6d01f4c940980da07964df3d5d33d7c7b46f40a1 /media-libs
parentstable ppc64, bug 261797 (diff)
downloadgentoo-2-50403c1164824b08b587a34e3bfef1a9778030db.tar.gz
gentoo-2-50403c1164824b08b587a34e3bfef1a9778030db.tar.bz2
gentoo-2-50403c1164824b08b587a34e3bfef1a9778030db.zip
Ebuild improvements by Roberto Castagnola <roberto.castagnola@gmail.com>, bug #255321 : Add qt4 yuseflag to build the qimage module with it, drop unused useflags, support for compressed lumas and kde useflag
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mlt/ChangeLog8
-rw-r--r--media-libs/mlt/files/mlt-0.3.6-qimage.patch20
-rw-r--r--media-libs/mlt/metadata.xml3
-rw-r--r--media-libs/mlt/mlt-0.3.6.ebuild54
4 files changed, 69 insertions, 16 deletions
diff --git a/media-libs/mlt/ChangeLog b/media-libs/mlt/ChangeLog
index 2844b409c6ff..5fd2103c2a03 100644
--- a/media-libs/mlt/ChangeLog
+++ b/media-libs/mlt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/mlt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/ChangeLog,v 1.37 2009/03/10 07:39:11 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/ChangeLog,v 1.38 2009/03/15 16:10:45 aballier Exp $
+
+ 15 Mar 2009; Alexis Ballier <aballier@gentoo.org>
+ +files/mlt-0.3.6-qimage.patch, metadata.xml, mlt-0.3.6.ebuild:
+ Ebuild improvements by Roberto Castagnola <roberto.castagnola@gmail.com>,
+ bug #255321 : Add qt4 yuseflag to build the qimage module with it, drop
+ unused useflags, support for compressed lumas and kde useflag
10 Mar 2009; Alexis Ballier <aballier@gentoo.org>
+files/mlt-0.3.6-avutil.patch, mlt-0.3.6.ebuild:
diff --git a/media-libs/mlt/files/mlt-0.3.6-qimage.patch b/media-libs/mlt/files/mlt-0.3.6-qimage.patch
new file mode 100644
index 000000000000..eee73bbed772
--- /dev/null
+++ b/media-libs/mlt/files/mlt-0.3.6-qimage.patch
@@ -0,0 +1,20 @@
+--- src/modules/qimage/configure
++++ src/modules/qimage/configure
+@@ -41,7 +41,7 @@
+ if [ "$KDEDIR" != "" ]
+ then
+ kde_includedir="$KDEDIR/include"
+- kde_libdir="$KDEDIR"
++ kde_libdir="$KDEDIR/lib"
+ fi
+ fi
+
+@@ -95,7 +95,7 @@
+ echo "#define USE_QT3" >> config.h
+ echo "USE_QT3=1" >> config.mak
+ echo QTCXXFLAGS=-I$qimage_includedir -I$kde_includedir -DQT_THREAD_SUPPORT >> config.mak
+- echo QTLIBS=-L$qimage_libdir -L$kde_libdir/lib -lqt-mt >> config.mak
++ echo QTLIBS=-L$qimage_libdir -L$kde_libdir -lqt-mt >> config.mak
+ else
+ echo "qimage: KDE environment not found - disabling extra image formats"
+ echo "#define USE_QT3" >> config.h
diff --git a/media-libs/mlt/metadata.xml b/media-libs/mlt/metadata.xml
index bdf618d73523..081f091644b2 100644
--- a/media-libs/mlt/metadata.xml
+++ b/media-libs/mlt/metadata.xml
@@ -5,5 +5,8 @@
<maintainer>
<email>media-video@gentoo.org</email>
</maintainer>
+<use>
+ <flag name="compressed-lumas">Compress the luma files in png.</flag>
+</use>
</pkgmetadata>
diff --git a/media-libs/mlt/mlt-0.3.6.ebuild b/media-libs/mlt/mlt-0.3.6.ebuild
index 5c69c810bb5b..e846b1abed93 100644
--- a/media-libs/mlt/mlt-0.3.6.ebuild
+++ b/media-libs/mlt/mlt-0.3.6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/mlt-0.3.6.ebuild,v 1.2 2009/03/10 07:39:11 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/mlt-0.3.6.ebuild,v 1.3 2009/03/15 16:10:45 aballier Exp $
EAPI=1
-inherit eutils toolchain-funcs qt3
+inherit kde-functions eutils toolchain-funcs multilib
DESCRIPTION="MLT is an open source multimedia framework, designed and developed
for television broadcasting"
@@ -14,12 +14,11 @@ SRC_URI="mirror://sourceforge/mlt/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="dv xml jack gtk sdl vorbis sox quicktime mmx lame xine lame ogg theora xine ffmpeg libsamplerate qt3 sse"
+IUSE="dv compressed-lumas ffmpeg gtk jack kde libsamplerate mmx qt3 qt4 quicktime sdl sox sse vorbis xine xml"
-DEPEND="ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080326 )
+RDEPEND="ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080326 )
dv? ( >=media-libs/libdv-0.104 )
xml? ( >=dev-libs/libxml2-2.5 )
- ogg? ( >=media-libs/libogg-1.1.3 )
vorbis? ( >=media-libs/libvorbis-1.1.2 )
sdl? ( >=media-libs/libsdl-1.2.10
>=media-libs/sdl-image-1.2.4 )
@@ -32,10 +31,12 @@ DEPEND="ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080326 )
sox? ( media-sound/sox )
quicktime? ( media-libs/libquicktime )
xine? ( >=media-libs/xine-lib-1.1.2_pre20060328-r7 )
- lame? ( >=media-sound/lame-3.97_beta2 )
- qt3? ( x11-libs/qt:3 )
- theora? ( >=media-libs/libtheora-1.0_alpha5 )"
-RDEPEND=${DEPEND}
+ qt3? ( x11-libs/qt:3
+ kde? ( kde-base/kdelibs:3.5 ) )
+ !qt3? ( qt4? ( x11-libs/qt-gui:4 ) )"
+
+DEPEND="${RDEPEND}
+ compressed-lumas? ( media-gfx/imagemagick )"
pkg_setup() {
local fail="USE sox needs also USE libsamplerate enabled."
@@ -51,28 +52,24 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/mlt-0.2.3-nostrip.patch
epatch "${FILESDIR}"/${P}-avutil.patch
+ epatch "${FILESDIR}"/${P}-qimage.patch
}
src_compile() {
tc-export CC
- local myconf=" --enable-gpl --enable-shared
- --enable-pp --enable-shared-pp
+ local myconf=" --enable-gpl
--enable-motion-est
$(use_enable dv)
$(use_enable mmx)
$(use_enable sse)
$(use_enable gtk gtk2)
$(use_enable vorbis)
- $(use_enable ogg)
$(use_enable sdl)
$(use_enable jack jackrack)
$(use_enable sox)
- $(use_enable theora)
- $(use_enable lame mp3lame)
$(use_enable ffmpeg avformat)
$(use_enable libsamplerate resample)
- $(use_enable qt3 qimage)
$(use_enable xml westley)
$(use_enable xine)"
@@ -81,6 +78,33 @@ src_compile() {
(use quicktime && use dv) || myconf="${myconf} --disable-kino"
+ use compressed-lumas && myconf="${myconf} --luma-compress"
+
+ # Waiting for media-plugins/frei0r (bug 255321)
+ myconf="${myconf} --disable-frei0r"
+
+ if use qt3; then
+ myconf="${myconf} --disable-kdenlive"
+ else
+ myconf="${myconf} $(use_enable kde kdenlive)"
+ fi
+
+ if use qt3; then
+ myconf="${myconf} --qimage-libdir=$QTDIR/$(get_libdir)
+ --qimage-includedir=$QTDIR/include"
+ if use kde; then
+ # compile extra image formats using kde
+ set-kdedir 3.5
+ myconf="${myconf} --kde-libdir=$KDEDIR/$(get_libdir)
+ --kde-includedir=$KDEDIR/include"
+ fi
+ elif use qt4; then
+ myconf="${myconf} --qimage-libdir=/usr/$(get_libdir)/qt4
+ --qimage-includedir=/usr/include/qt4"
+ else
+ myconf="${myconf} --disable-qimage"
+ fi
+
econf ${myconf} || die "econf failed"
sed -i -e s/^OPT/#OPT/ "${S}/config.mak"
emake || die "emake failed"