summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-30 18:54:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-30 18:54:27 +0000
commit31db761c09e0d72f3497c90fcacf427a3ec2198c (patch)
treef2cb276ab453cbaf04c772513e137ec47e511453 /media-libs
parentVersion bump. (diff)
downloadgentoo-2-31db761c09e0d72f3497c90fcacf427a3ec2198c.tar.gz
gentoo-2-31db761c09e0d72f3497c90fcacf427a3ec2198c.tar.bz2
gentoo-2-31db761c09e0d72f3497c90fcacf427a3ec2198c.zip
Version bump wrt #409417 by Agostino Sarubbo
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/raptor/ChangeLog7
-rw-r--r--media-libs/raptor/raptor-2.0.7.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/media-libs/raptor/ChangeLog b/media-libs/raptor/ChangeLog
index 07ac90746df7..08389672fd75 100644
--- a/media-libs/raptor/ChangeLog
+++ b/media-libs/raptor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/raptor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.120 2012/03/05 21:10:08 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.121 2012/03/30 18:54:27 ssuominen Exp $
+
+*raptor-2.0.7 (30 Mar 2012)
+
+ 30 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> +raptor-2.0.7.ebuild:
+ Version bump wrt #409417 by Agostino Sarubbo
05 Mar 2012; Markus Meier <maekke@gentoo.org> raptor-2.0.6.ebuild:
arm stable, bug #404795
diff --git a/media-libs/raptor/raptor-2.0.7.ebuild b/media-libs/raptor/raptor-2.0.7.ebuild
new file mode 100644
index 000000000000..601c5c5839f5
--- /dev/null
+++ b/media-libs/raptor/raptor-2.0.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-2.0.7.ebuild,v 1.1 2012/03/30 18:54:27 ssuominen Exp $
+
+# FIXME: It should be possible to use net-nntp/inn for libinn.h and -linn!
+
+EAPI=4
+inherit libtool
+
+MY_P=${PN}2-${PV}
+
+DESCRIPTION="The RDF Parser Toolkit"
+HOMEPAGE="http://librdf.org/raptor/"
+SRC_URI="http://download.librdf.org/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+curl debug json static-libs unicode"
+
+RDEPEND="dev-libs/libxml2
+ dev-libs/libxslt
+ curl? ( net-misc/curl )
+ json? ( dev-libs/yajl )
+ unicode? ( dev-libs/icu )
+ !<media-libs/raptor-1.4.21-r1"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/flex"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS ChangeLog NEWS NOTICE README"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ local myconf='--with-www=xml'
+ use curl && myconf='--with-www=curl'
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug) \
+ $(use unicode && echo --with-icu-config="${EPREFIX}"/usr/bin/icu-config) \
+ $(use_with json yajl) \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ ${myconf}
+}
+
+src_install() {
+ default
+ dohtml {NEWS,README,RELEASE,UPGRADING}.html
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}