summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-11-05 18:23:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-11-05 18:23:16 +0000
commit03a1d1e6d93fb73c3926224498d8edf9178c8640 (patch)
tree60a6455dd108d135f57f230873b232680d811144 /media-libs
parentarm/ia64 stable wrt #289174 (diff)
downloadgentoo-2-03a1d1e6d93fb73c3926224498d8edf9178c8640.tar.gz
gentoo-2-03a1d1e6d93fb73c3926224498d8edf9178c8640.tar.bz2
gentoo-2-03a1d1e6d93fb73c3926224498d8edf9178c8640.zip
Version bump wrt #291948, thanks to Jean-Claude Repetto for reporting.
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/tiff/ChangeLog7
-rw-r--r--media-libs/tiff/tiff-3.9.2.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/media-libs/tiff/ChangeLog b/media-libs/tiff/ChangeLog
index 78b021c9dd94..1b26d8f0fdd1 100644
--- a/media-libs/tiff/ChangeLog
+++ b/media-libs/tiff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/tiff
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/ChangeLog,v 1.133 2009/11/04 16:03:58 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/ChangeLog,v 1.134 2009/11/05 18:23:16 ssuominen Exp $
+
+*tiff-3.9.2 (05 Nov 2009)
+
+ 05 Nov 2009; Samuli Suominen <ssuominen@gentoo.org> +tiff-3.9.2.ebuild:
+ Version bump wrt #291948, thanks to Jean-Claude Repetto for reporting.
04 Nov 2009; Markus Meier <maekke@gentoo.org> tiff-3.9.1.ebuild:
amd64/arm/x86 stable, bug #291612
diff --git a/media-libs/tiff/tiff-3.9.2.ebuild b/media-libs/tiff/tiff-3.9.2.ebuild
new file mode 100644
index 000000000000..3b5404ee0e50
--- /dev/null
+++ b/media-libs/tiff/tiff-3.9.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/tiff-3.9.2.ebuild,v 1.1 2009/11/05 18:23:16 ssuominen Exp $
+
+EAPI=2
+inherit eutils libtool
+
+DESCRIPTION="Library for manipulation of TIFF (Tag Image File Format) images"
+HOMEPAGE="http://www.remotesensing.org/libtiff/"
+SRC_URI="ftp://ftp.remotesensing.org/pub/libtiff/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="jpeg jbig +cxx zlib"
+
+DEPEND="jpeg? ( >=media-libs/jpeg-6b )
+ jbig? ( media-libs/jbigkit )
+ zlib? ( sys-libs/zlib )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.8.2-CVE-2009-2285.patch
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable cxx) \
+ $(use_enable zlib) \
+ $(use_enable jpeg) \
+ $(use_enable jbig) \
+ --without-x \
+ --with-docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README TODO
+}
+
+pkg_postinst() {
+ if use jbig; then
+ echo
+ elog "JBIG support is intended for Hylafax fax compression, so we"
+ elog "really need more feedback in other areas (most testing has"
+ elog "been done with fax). Be sure to recompile anything linked"
+ elog "against tiff if you rebuild it with jbig support."
+ echo
+ fi
+}