summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-24 09:09:45 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-24 09:09:45 +0000
commitb8c6de1c488264cc6c416e194aa4ec6ec740cab9 (patch)
treecdf52fe5b5c8e92e11baeb6511d9b1a834be362b /media-libs/xvid/xvid-1.0.3.ebuild
parents390 lovin (diff)
downloadgentoo-2-b8c6de1c488264cc6c416e194aa4ec6ec740cab9.tar.gz
gentoo-2-b8c6de1c488264cc6c416e194aa4ec6ec740cab9.tar.bz2
gentoo-2-b8c6de1c488264cc6c416e194aa4ec6ec740cab9.zip
fix building with ia64 and mark hppa/ia64 stable
(Portage version: 2.0.51.20)
Diffstat (limited to 'media-libs/xvid/xvid-1.0.3.ebuild')
-rw-r--r--media-libs/xvid/xvid-1.0.3.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/media-libs/xvid/xvid-1.0.3.ebuild b/media-libs/xvid/xvid-1.0.3.ebuild
index 809178756479..b516aaac6b25 100644
--- a/media-libs/xvid/xvid-1.0.3.ebuild
+++ b/media-libs/xvid/xvid-1.0.3.ebuild
@@ -1,32 +1,34 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/xvid-1.0.3.ebuild,v 1.4 2005/04/19 20:11:59 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xvid/xvid-1.0.3.ebuild,v 1.5 2005/04/24 09:09:45 vapier Exp $
inherit eutils
MY_P=${PN}core-${PV/_rc/-rc}
-DESCRIPTION="XviD, a high performance/quality MPEG-4 video de-/encoding solution."
+DESCRIPTION="XviD, a high performance/quality MPEG-4 video de-/encoding solution"
HOMEPAGE="http://www.xvid.org/"
SRC_URI="http://files.xvid.org/downloads/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="1"
-KEYWORDS="~x86 ~amd64 ~sparc ~ppc64 ~ppc"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc"
-DEPEND="virtual/libc
- x86? ( >=dev-lang/nasm-0.98.36 )"
+DEPEND="x86? ( >=dev-lang/nasm-0.98.36 )"
+RDEPEND=""
S="${WORKDIR}/${MY_P}/build/generic"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-DESTDIR.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-DESTDIR.patch
+ cd "${S}"/../..
+ epatch "${FILESDIR}"/${PN}-1.0-ia64.patch
}
src_install() {
- make install DESTDIR=${D} || die
+ make install DESTDIR="${D}" || die
cd ${S}/../../
dodoc AUTHORS ChangeLog README TODO doc/*