summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-05-20 17:55:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-05-20 17:55:26 +0000
commit3a946c624f632a335075ba2f6c3697ccc210dabc (patch)
tree1ad94e651a4d67520b056cedf4033a8860d398df /media-libs/x265
parentversion bump (diff)
downloadgentoo-2-3a946c624f632a335075ba2f6c3697ccc210dabc.tar.gz
gentoo-2-3a946c624f632a335075ba2f6c3697ccc210dabc.tar.bz2
gentoo-2-3a946c624f632a335075ba2f6c3697ccc210dabc.zip
build as PIC (that is what is done for amd64 in CMakeLists.txt anyway); patch by Jeroen Roovers, bug #510444.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/x265')
-rw-r--r--media-libs/x265/ChangeLog7
-rw-r--r--media-libs/x265/x265-0.8.ebuild6
-rw-r--r--media-libs/x265/x265-9999.ebuild6
3 files changed, 14 insertions, 5 deletions
diff --git a/media-libs/x265/ChangeLog b/media-libs/x265/ChangeLog
index 28255608ebc9..50862b3a8c75 100644
--- a/media-libs/x265/ChangeLog
+++ b/media-libs/x265/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/x265
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x265/ChangeLog,v 1.4 2014/04/28 17:50:08 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x265/ChangeLog,v 1.5 2014/05/20 17:55:26 aballier Exp $
+
+ 20 May 2014; Alexis Ballier <aballier@gentoo.org> x265-0.8.ebuild,
+ x265-9999.ebuild:
+ build as PIC (that is what is done for amd64 in CMakeLists.txt anyway); patch
+ by Jeroen Roovers, bug #510444.
28 Apr 2014; Michał Górny <mgorny@gentoo.org> x265-0.8.ebuild,
x265-9999.ebuild:
diff --git a/media-libs/x265/x265-0.8.ebuild b/media-libs/x265/x265-0.8.ebuild
index 989447f1ce6c..65fd6ed4ab4f 100644
--- a/media-libs/x265/x265-0.8.ebuild
+++ b/media-libs/x265/x265-0.8.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x265/x265-0.8.ebuild,v 1.2 2014/04/28 17:50:08 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x265/x265-0.8.ebuild,v 1.3 2014/05/20 17:55:26 aballier Exp $
EAPI=5
-inherit cmake-multilib
+inherit cmake-multilib flag-o-matic
if [[ ${PV} = 9999* ]]; then
inherit mercurial
@@ -45,6 +45,8 @@ src_unpack() {
}
multilib_src_configure() {
+ append-cflags -fPIC
+ append-cxxflags -fPIC
local mycmakeargs=(
$(cmake-utils_use_enable test TESTS)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
diff --git a/media-libs/x265/x265-9999.ebuild b/media-libs/x265/x265-9999.ebuild
index 6efd44eaebd0..e4de321b56a0 100644
--- a/media-libs/x265/x265-9999.ebuild
+++ b/media-libs/x265/x265-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x265/x265-9999.ebuild,v 1.4 2014/04/28 17:50:08 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x265/x265-9999.ebuild,v 1.5 2014/05/20 17:55:26 aballier Exp $
EAPI=5
-inherit cmake-multilib multilib
+inherit cmake-multilib multilib flag-o-matic
if [[ ${PV} = 9999* ]]; then
inherit mercurial
@@ -40,6 +40,8 @@ src_unpack() {
}
multilib_src_configure() {
+ append-cflags -fPIC
+ append-cxxflags -fPIC
local mycmakeargs=(
$(cmake-utils_use_enable test TESTS)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")