summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-17 12:42:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-17 12:42:01 +0000
commit8f24b1ce1611e5814ccd9eddf5ca014460111104 (patch)
tree92b955ebc4805b76578c84c6676d76bbe73a52ca /media-libs/urt
parentAdd ~x86-fbsd keyword (before I forget), although this requires masked ghc/gh... (diff)
downloadgentoo-2-8f24b1ce1611e5814ccd9eddf5ca014460111104.tar.gz
gentoo-2-8f24b1ce1611e5814ccd9eddf5ca014460111104.tar.bz2
gentoo-2-8f24b1ce1611e5814ccd9eddf5ca014460111104.zip
Add patch to fix usage of make vs $(MAKE) with some flags enabled.
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'media-libs/urt')
-rw-r--r--media-libs/urt/ChangeLog6
-rw-r--r--media-libs/urt/files/digest-urt-3.1b-r12
-rw-r--r--media-libs/urt/files/urt-3.1b-make.patch75
-rw-r--r--media-libs/urt/urt-3.1b-r1.ebuild3
4 files changed, 84 insertions, 2 deletions
diff --git a/media-libs/urt/ChangeLog b/media-libs/urt/ChangeLog
index 0a54f40f6909..49d7518e0451 100644
--- a/media-libs/urt/ChangeLog
+++ b/media-libs/urt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/urt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/urt/ChangeLog,v 1.25 2006/04/12 14:34:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/urt/ChangeLog,v 1.26 2006/05/17 12:42:01 flameeyes Exp $
+
+ 17 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/urt-3.1b-make.patch, urt-3.1b-r1.ebuild:
+ Add patch to fix usage of make vs $(MAKE) with some flags enabled.
12 Apr 2006; Diego Pettenò <flameeyes@gentoo.org> urt-3.1b-r1.ebuild:
Add ~x86-fbsd keyword.
diff --git a/media-libs/urt/files/digest-urt-3.1b-r1 b/media-libs/urt/files/digest-urt-3.1b-r1
index fe0ff33a5163..6cd152ced6ad 100644
--- a/media-libs/urt/files/digest-urt-3.1b-r1
+++ b/media-libs/urt/files/digest-urt-3.1b-r1
@@ -1 +1,3 @@
MD5 c9a377284d00c102c1a8af53d95a6b39 urt-3.1b.tar.Z 1016405
+RMD160 fd99f3a4ec7cb6c9195752e227ad95428e331bba urt-3.1b.tar.Z 1016405
+SHA256 6d8b67f03507818ebdca3a342c96454780cc5eadcc58ac2713cbcdfdb61a6b41 urt-3.1b.tar.Z 1016405
diff --git a/media-libs/urt/files/urt-3.1b-make.patch b/media-libs/urt/files/urt-3.1b-make.patch
new file mode 100644
index 000000000000..d8f6c74cd890
--- /dev/null
+++ b/media-libs/urt/files/urt-3.1b-make.patch
@@ -0,0 +1,75 @@
+Index: urt/makefile.src
+===================================================================
+--- urt.orig/makefile.src
++++ urt/makefile.src
+@@ -17,7 +17,7 @@ all: default
+ # clean deletes all but source, pristine (below) deletes installed stuff, too
+ default clean: doit
+ @for d in $(DIRS) ; do \
+- ( cd $$d ; echo make $@ on $$d ; make $(MFLAGS) $@ ) ; \
++ ( cd $$d ; echo $(MAKE) $@ on $$d ; $(MAKE) $(MFLAGS) $@ ) ; \
+ done
+
+ # install puts library, binaries and documentation into global location
+@@ -29,7 +29,7 @@ MAKE_TARGET =
+
+ install $(MAKE_TARGET) pristine depend:: doit
+ @for d in $(ALLDIRS) ; do \
+- ( cd $$d ; echo make $@ on $$d ; make $(MFLAGS) $@ ) ; \
++ ( cd $$d ; echo $(MAKE) $@ on $$d ; $(MAKE) $(MFLAGS) $@ ) ; \
+ done
+
+
+Index: urt/tools/makefile.src
+===================================================================
+--- urt.orig/tools/makefile.src
++++ urt/tools/makefile.src
+@@ -82,7 +82,7 @@ rlebox.out: rlebox.c rle_box.o
+ # rleClock has it's own directory, must be built special
+
+ rleClock.out: clock/font.c clock/font.h clock/font.src clock/rleClock.c
+- (cd clock ; make)
++ (cd clock ; $(MAKE))
+
+ # Incremental install, copies everything ("$?") since last install to DEST dir.
+ install: $(PGMS) install-pgm
+Index: urt/makefile.tlr
+===================================================================
+--- urt.orig/makefile.tlr
++++ urt/makefile.tlr
+@@ -7,7 +7,7 @@ subdirs:
+ @sh -c "if test 'x$(DIRS)' != x ; then eval \
+ 'set -e ; for dir in $(DIRS) ; do \
+ (cd \$$dir ; echo Make ${HERE}\$$dir ; \
+- make $(MFLAGS) $(DIRMFLAGS) ) ; \
++ $(MAKE) $(MFLAGS) $(DIRMFLAGS) ) ; \
+ done' ; \
+ else \
+ true ; \
+@@ -46,7 +46,7 @@ install-subdirs: subdirs
+ @sh -c "if test 'x$(DIRS)' != x ; then eval \
+ 'for dir in $(DIRS) ; do \
+ (cd \$$dir ; echo Install ${HERE}\$$dir ; \
+- make $(MFLAGS) $(DIRMFLAGS) install) ; \
++ $(MAKE) $(MFLAGS) $(DIRMFLAGS) install) ; \
+ done' ; \
+ else \
+ true ; \
+@@ -105,7 +105,7 @@ pristine-pgm: clean-pgm
+ 'for dir in $(ALLDIRS); do \
+ if test -d $$dir ; then \
+ (cd $$dir; echo Make ${HERE}$$dir pristine ; \
+- make $(MFLAGS) pristine); \
++ $(MAKE) $(MFLAGS) pristine); \
+ else \
+ true; \
+ fi; \
+@@ -124,7 +124,7 @@ clean-pgm:
+ 'for dir in $(ALLDIRS); do \
+ if test -d $$dir ; then \
+ (cd $$dir; echo Clean ${HERE}$$dir ; \
+- make $(MFLAGS) clean); \
++ $(MAKE) $(MFLAGS) clean); \
+ else \
+ true; \
+ fi; \
diff --git a/media-libs/urt/urt-3.1b-r1.ebuild b/media-libs/urt/urt-3.1b-r1.ebuild
index e53acd661d07..e2c62b4938de 100644
--- a/media-libs/urt/urt-3.1b-r1.ebuild
+++ b/media-libs/urt/urt-3.1b-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/urt/urt-3.1b-r1.ebuild,v 1.24 2006/04/12 14:34:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/urt/urt-3.1b-r1.ebuild,v 1.25 2006/05/17 12:42:01 flameeyes Exp $
inherit eutils toolchain-funcs
@@ -38,6 +38,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-compile-updates.patch
epatch "${FILESDIR}"/${P}-tempfile.patch
epatch "${FILESDIR}"/${P}-build-fixes.patch
+ epatch "${FILESDIR}/${P}-make.patch"
# punt bogus manpage #109511
rm -f man/man1/template.1