summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2008-08-26 14:51:21 +0000
committerRobert Buchholz <rbu@gentoo.org>2008-08-26 14:51:21 +0000
commit14eb7f29fd384821bf1278b8d93e1bf73638e03a (patch)
tree881b697eb2742cdbfd22317e480eb88f8063e7be /media-libs/tiff/tiff-3.8.2-r4.ebuild
parentAdd ~ia64 wrt #227677 (diff)
downloadgentoo-2-14eb7f29fd384821bf1278b8d93e1bf73638e03a.tar.gz
gentoo-2-14eb7f29fd384821bf1278b8d93e1bf73638e03a.tar.bz2
gentoo-2-14eb7f29fd384821bf1278b8d93e1bf73638e03a.zip
+ Fix buffer underflow in LZW encoding (CVE-2008-2327), straight to stable for
+ alpha amd64 hppa ppc64 x86 (seccurity bug #234080) (Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc4-git1 x86_64, RepoMan options: --force)
Diffstat (limited to 'media-libs/tiff/tiff-3.8.2-r4.ebuild')
-rw-r--r--media-libs/tiff/tiff-3.8.2-r4.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/media-libs/tiff/tiff-3.8.2-r4.ebuild b/media-libs/tiff/tiff-3.8.2-r4.ebuild
new file mode 100644
index 000000000000..02250f8d45f2
--- /dev/null
+++ b/media-libs/tiff/tiff-3.8.2-r4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/tiff-3.8.2-r4.ebuild,v 1.1 2008/08/26 14:51:20 rbu Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="Library for manipulation of TIFF (Tag Image File Format) images"
+HOMEPAGE="http://www.remotesensing.org/libtiff/"
+SRC_URI="ftp://ftp.remotesensing.org/pub/libtiff/${P}.tar.gz
+ mirror://gentoo/${P}-tiff2pdf.patch.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ~ia64 ~m68k ~mips ~ppc ppc64 ~s390 ~sh ~sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE="jpeg jbig nocxx zlib"
+
+DEPEND="jpeg? ( >=media-libs/jpeg-6b )
+ jbig? ( >=media-libs/jbigkit-1.6-r1 )
+ zlib? ( >=sys-libs/zlib-1.1.3-r2 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${P}-tiff2pdf.patch
+ epatch "${FILESDIR}"/${P}-tiffsplit.patch
+ if use jbig; then
+ epatch "${FILESDIR}"/${PN}-jbig.patch
+ fi
+ epatch "${FILESDIR}"/${P}-goo-sec.patch
+ epatch "${FILESDIR}"/${P}-CVE-2008-2327.patch
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable !nocxx cxx) \
+ $(use_enable zlib) \
+ $(use_enable jpeg) \
+ $(use_enable jbig) \
+ --with-pic --without-x \
+ --with-docdir=/usr/share/doc/${PF} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc README TODO VERSION
+}
+
+pkg_postinst() {
+ echo
+ elog "JBIG support is intended for Hylafax fax compression, so we"
+ elog "really need more feedback in other areas (most testing has"
+ elog "been done with fax). Be sure to recompile anything linked"
+ elog "against tiff if you rebuild it with jbig support."
+ echo
+}