summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-10-31 20:36:00 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-10-31 20:36:00 +0000
commit7619d9869bca3ce36bed5777e5e856c7a7151109 (patch)
treeb0dab65bb9b02047067ceb23bf62202a863f98d7 /media-libs/swfdec
parenthppa stable (diff)
downloadgentoo-2-7619d9869bca3ce36bed5777e5e856c7a7151109.tar.gz
gentoo-2-7619d9869bca3ce36bed5777e5e856c7a7151109.tar.bz2
gentoo-2-7619d9869bca3ce36bed5777e5e856c7a7151109.zip
rev bump. add +gtk to USE since every usage of swfdec currently needs it. remove old versions
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'media-libs/swfdec')
-rw-r--r--media-libs/swfdec/ChangeLog9
-rw-r--r--media-libs/swfdec/swfdec-0.6.4.ebuild93
-rw-r--r--media-libs/swfdec/swfdec-0.6.6.ebuild93
-rw-r--r--media-libs/swfdec/swfdec-0.8.2.ebuild (renamed from media-libs/swfdec/swfdec-0.6.6-r1.ebuild)33
4 files changed, 27 insertions, 201 deletions
diff --git a/media-libs/swfdec/ChangeLog b/media-libs/swfdec/ChangeLog
index d63879d1579a..e415939602b2 100644
--- a/media-libs/swfdec/ChangeLog
+++ b/media-libs/swfdec/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/swfdec
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/swfdec/ChangeLog,v 1.53 2008/10/18 22:50:44 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/swfdec/ChangeLog,v 1.54 2008/10/31 20:36:00 cardoe Exp $
+
+*swfdec-0.8.2 (31 Oct 2008)
+
+ 31 Oct 2008; Doug Goldstein <cardoe@gentoo.org> -swfdec-0.6.4.ebuild,
+ -swfdec-0.6.6.ebuild, -swfdec-0.6.6-r1.ebuild, +swfdec-0.8.2.ebuild:
+ rev bump. add +gtk to USE since every usage of swfdec currently needs it.
+ remove old versions
18 Oct 2008; Brent Baude <ranger@gentoo.org> swfdec-0.6.8.ebuild:
Marking swfdec-0.6.8 ppc stable for bug 236971
diff --git a/media-libs/swfdec/swfdec-0.6.4.ebuild b/media-libs/swfdec/swfdec-0.6.4.ebuild
deleted file mode 100644
index b78bd9541ae4..000000000000
--- a/media-libs/swfdec/swfdec-0.6.4.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/swfdec/swfdec-0.6.4.ebuild,v 1.4 2008/05/27 03:28:25 jer Exp $
-
-EAPI=1
-
-inherit eutils versionator confutils
-
-MY_PV=$(get_version_component_range 1-2)
-DESCRIPTION="Macromedia Flash decoding library"
-HOMEPAGE="http://swfdec.freedesktop.org"
-SRC_URI="http://swfdec.freedesktop.org/download/${PN}/${MY_PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
-
-IUSE="alsa doc ffmpeg gstreamer gtk mad oss pulseaudio"
-
-# For <media-video/ffmpeg-0.4.9_p2008032, see #216978
-RDEPEND=">=dev-libs/glib-2.12
- >=dev-libs/liboil-0.3.1
- >=x11-libs/pango-1.16.4
- gtk? (
- >=x11-libs/gtk+-2.8.0
- net-libs/libsoup:2.4
- )
- >=x11-libs/cairo-1.2
- ffmpeg? (
- >=media-video/ffmpeg-0.4.9_p20070330
- <media-video/ffmpeg-0.4.9_p20080326
- )
- mad? ( >=media-libs/libmad-0.15.1b )
- gstreamer? (
- >=media-libs/gstreamer-0.10.11
- >=media-libs/gst-plugins-base-0.10.15
- )
- alsa? ( >=media-libs/alsa-lib-1.0.12 )
- pulseaudio? ( media-sound/pulseaudio )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? ( >=dev-util/gtk-doc-1.6 )"
-
-pkg_setup() {
- if use !gtk ; then
- ewarn "swfdec will be built without swfdec-gtk convenience"
- ewarn "library, which is needed by swfdec-mozilla and"
- ewarn "swfdec-gnome. Please add 'gtk' to your USE flags"
- ewarn "unless you really know what you are doing."
- fi
- confutils_use_conflict oss alsa pulseaudio
-}
-
-src_compile() {
- local myconf
- local myaudio
-
- #--with-audio=[auto/alsa/oss/none]
- myaudio="none"
- use oss && myaudio="oss"
- use pulseaudio && myaudio="pa"
- use alsa && myaudio="alsa"
- myconf=" --with-audio=$myaudio"
-
- # bug #216009
- # avoid writing to /root/.gstreamer-0.10/registry.xml
- export GST_REGISTRY="${T}"/registry.xml
- # also avoid loading gconf plugins, which may write to /root/.gconfd
- export GST_PLUGIN_SYSTEM_PATH="${T}"
-
- econf \
- $(use_enable doc gtk-doc) \
- $(use_enable gstreamer) \
- $(use_enable ffmpeg) \
- $(use_enable mad) \
- $(use_enable gtk) \
- ${myconf} || die "configure failed"
-
- # bug #216284 image tests are not ready yet
- cat >test/image/Makefile <<EOF
-all:
-check:
-install:
-EOF
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc AUTHORS ChangeLog README
-}
diff --git a/media-libs/swfdec/swfdec-0.6.6.ebuild b/media-libs/swfdec/swfdec-0.6.6.ebuild
deleted file mode 100644
index 3476c831dcbe..000000000000
--- a/media-libs/swfdec/swfdec-0.6.6.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/swfdec/swfdec-0.6.6.ebuild,v 1.4 2008/06/02 10:39:07 aballier Exp $
-
-EAPI=1
-
-inherit eutils versionator confutils
-
-MY_PV=$(get_version_component_range 1-2)
-DESCRIPTION="Macromedia Flash decoding library"
-HOMEPAGE="http://swfdec.freedesktop.org"
-SRC_URI="http://swfdec.freedesktop.org/download/${PN}/${MY_PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-
-IUSE="alsa doc ffmpeg gstreamer gtk mad oss pulseaudio"
-
-# For <media-video/ffmpeg-0.4.9_p2008032, see #216978
-RDEPEND=">=dev-libs/glib-2.12
- >=dev-libs/liboil-0.3.1
- >=x11-libs/pango-1.16.4
- gtk? (
- >=x11-libs/gtk+-2.8.0
- net-libs/libsoup:2.4
- )
- >=x11-libs/cairo-1.2
- ffmpeg? (
- >=media-video/ffmpeg-0.4.9_p20070330
- <media-video/ffmpeg-0.4.9_p20080326
- )
- mad? ( >=media-libs/libmad-0.15.1b )
- gstreamer? (
- >=media-libs/gstreamer-0.10.11
- >=media-libs/gst-plugins-base-0.10.15
- )
- alsa? ( >=media-libs/alsa-lib-1.0.12 )
- pulseaudio? ( media-sound/pulseaudio )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? ( >=dev-util/gtk-doc-1.6 )"
-
-pkg_setup() {
- if use !gtk ; then
- ewarn "swfdec will be built without swfdec-gtk convenience"
- ewarn "library, which is needed by swfdec-mozilla and"
- ewarn "swfdec-gnome. Please add 'gtk' to your USE flags"
- ewarn "unless you really know what you are doing."
- fi
- confutils_use_conflict oss alsa pulseaudio
-}
-
-src_compile() {
- local myconf
- local myaudio
-
- #--with-audio=[auto/alsa/oss/none]
- myaudio="none"
- use oss && myaudio="oss"
- use pulseaudio && myaudio="pa"
- use alsa && myaudio="alsa"
- myconf=" --with-audio=$myaudio"
-
- # bug #216009
- # avoid writing to /root/.gstreamer-0.10/registry.xml
- export GST_REGISTRY="${T}"/registry.xml
- # also avoid loading gconf plugins, which may write to /root/.gconfd
- export GST_PLUGIN_SYSTEM_PATH="${T}"
-
- econf \
- $(use_enable doc gtk-doc) \
- $(use_enable gstreamer) \
- $(use_enable ffmpeg) \
- $(use_enable mad) \
- $(use_enable gtk) \
- ${myconf} || die "configure failed"
-
- # bug #216284 image tests are not ready yet
- cat >test/image/Makefile <<EOF
-all:
-check:
-install:
-EOF
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc AUTHORS ChangeLog README
-}
diff --git a/media-libs/swfdec/swfdec-0.6.6-r1.ebuild b/media-libs/swfdec/swfdec-0.8.2.ebuild
index b0b8a4a6a954..4be87ce497de 100644
--- a/media-libs/swfdec/swfdec-0.6.6-r1.ebuild
+++ b/media-libs/swfdec/swfdec-0.8.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/swfdec/swfdec-0.6.6-r1.ebuild,v 1.5 2008/08/12 13:53:09 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/swfdec/swfdec-0.8.2.ebuild,v 1.1 2008/10/31 20:36:00 cardoe Exp $
EAPI=1
-inherit eutils versionator confutils
+inherit eutils versionator
MY_PV=$(get_version_component_range 1-2)
DESCRIPTION="Macromedia Flash decoding library"
@@ -13,18 +13,18 @@ SRC_URI="http://swfdec.freedesktop.org/download/${PN}/${MY_PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="alpha amd64 ~hppa ia64 ppc ~ppc64 sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="alsa doc ffmpeg gstreamer gtk oss pulseaudio"
+IUSE="alsa doc ffmpeg gstreamer +gtk oss pulseaudio"
-RDEPEND=">=dev-libs/glib-2.12
+RDEPEND=">=dev-libs/glib-2.16
>=dev-libs/liboil-0.3.1
>=x11-libs/pango-1.16.4
gtk? (
>=x11-libs/gtk+-2.8.0
net-libs/libsoup:2.4
)
- >=x11-libs/cairo-1.2
+ >=x11-libs/cairo-1.6
gstreamer? (
>=media-libs/gstreamer-0.10.11
>=media-libs/gst-plugins-base-0.10.15
@@ -37,6 +37,8 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
doc? ( >=dev-util/gtk-doc-1.6 )"
+RESTRICT="test"
+
pkg_setup() {
if use !gtk ; then
ewarn "swfdec will be built without swfdec-gtk convenience"
@@ -51,16 +53,19 @@ pkg_setup() {
ewarn "as such it requires the 'gstreamer' USE flag to be enabled."
fi
- confutils_use_conflict oss alsa pulseaudio
+ if use alsa && use pulseaudio; then
+ ewarn
+ ewarn "Pulseaudio and ALSA selected. Selecting mature ALSA backend."
+ fi
}
src_compile() {
- local myconf=
-
- #--with-audio=[auto/alsa/oss/none]
- use oss && myconf="${myconf} --with-audio=oss"
- use pulseaudio && myconf="${myconf} --with-audio=pa"
- use alsa && myconf="${myconf} --with-audio=alsa"
+ # Backend logic is from configure.ac:
+ # alsa > pulseaudio > oss
+ local audio="none"
+ use oss && audio="oss"
+ use pulseaudio && audio="pulse"
+ use alsa && audio="alsa"
# bug #216009
# avoid writing to /root/.gstreamer-0.10/registry.xml
@@ -74,7 +79,7 @@ src_compile() {
$(use_enable gtk) \
--disable-ffmpeg \
--disable-mad \
- ${myconf} || die "configure failed"
+ --with-audio=${audio} || die "configure failed"
# bug #216284 image tests are not ready yet
cat >test/image/Makefile <<EOF