summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-21 04:37:21 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-21 04:37:21 +0000
commitd9dbdb5ce55aa1e8d6c7b2cc8b9c4d4b624c597f (patch)
treed23bd93db467ca8c1f22fc01074276bd2fe9ee3d /media-libs/sdl-sound
parenttouchups (diff)
downloadgentoo-2-d9dbdb5ce55aa1e8d6c7b2cc8b9c4d4b624c597f.tar.gz
gentoo-2-d9dbdb5ce55aa1e8d6c7b2cc8b9c4d4b624c597f.tar.bz2
gentoo-2-d9dbdb5ce55aa1e8d6c7b2cc8b9c4d4b624c597f.zip
Add libmodplug support by Tyler Montbriand #89241.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-libs/sdl-sound')
-rw-r--r--media-libs/sdl-sound/ChangeLog10
-rw-r--r--media-libs/sdl-sound/files/digest-sdl-sound-1.0.1-r21
-rw-r--r--media-libs/sdl-sound/sdl-sound-1.0.1-r2.ebuild51
3 files changed, 60 insertions, 2 deletions
diff --git a/media-libs/sdl-sound/ChangeLog b/media-libs/sdl-sound/ChangeLog
index a068d0cba6f8..cef3801d46ad 100644
--- a/media-libs/sdl-sound/ChangeLog
+++ b/media-libs/sdl-sound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/sdl-sound
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/ChangeLog,v 1.16 2004/10/01 06:32:09 mr_bones_ Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/ChangeLog,v 1.17 2005/06/21 04:37:21 vapier Exp $
+
+*sdl-sound-1.0.1-r2 (21 Jun 2005)
+
+ 21 Jun 2005; Mike Frysinger <vapier@gentoo.org>
+ +sdl-sound-1.0.1-r2.ebuild:
+ Add libmodplug support by Tyler Montbriand #89241.
*sdl-sound-1.0.1-r1 (30 Sep 2004)
diff --git a/media-libs/sdl-sound/files/digest-sdl-sound-1.0.1-r2 b/media-libs/sdl-sound/files/digest-sdl-sound-1.0.1-r2
new file mode 100644
index 000000000000..3bda76f3e513
--- /dev/null
+++ b/media-libs/sdl-sound/files/digest-sdl-sound-1.0.1-r2
@@ -0,0 +1 @@
+MD5 49e197ef7c8ab623d0640dc74be43160 SDL_sound-1.0.1.tar.gz 1019056
diff --git a/media-libs/sdl-sound/sdl-sound-1.0.1-r2.ebuild b/media-libs/sdl-sound/sdl-sound-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..62498d90fb0f
--- /dev/null
+++ b/media-libs/sdl-sound/sdl-sound-1.0.1-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/sdl-sound-1.0.1-r2.ebuild,v 1.1 2005/06/21 04:37:21 vapier Exp $
+
+inherit flag-o-matic
+
+MY_P="${P/sdl-/SDL_}"
+DESCRIPTION="A library that handles the decoding of sound file formats"
+HOMEPAGE="http://icculus.org/SDL_sound/"
+SRC_URI="http://icculus.org/SDL_sound/downloads/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="flac mikmod vorbis speex physfs mp3"
+
+RDEPEND=">=media-libs/libsdl-1.2
+ flac? ( media-libs/flac )
+ mikmod? ( >=media-libs/libmikmod-3.1.9 media-libs/libmodplug )
+ vorbis? ( >=media-libs/libvorbis-1.0_beta4 )
+ speex? ( media-libs/speex
+ media-libs/libogg )
+ physfs? ( dev-games/physfs )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ use mikmod \
+ && append-flags $(pkg-config libmodplug --cflags) \
+ && sed -i 's:modplug\.h:libmodplug/modplug.h:' configure
+ econf \
+ --disable-dependency-tracking \
+ --enable-midi \
+ --disable-smpeg \
+ $(use_enable mp3 mpglib) \
+ $(use_enable flac) \
+ $(use_enable speex) \
+ $(use_enable mikmod) \
+ $(use_enable mikmod modplug) \
+ $(use_enable physfs) \
+ $(use_enable vorbis ogg) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGELOG CREDITS INSTALL README TODO
+}