summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2013-09-06 20:02:18 +0000
committerIan Stakenvicius <axs@gentoo.org>2013-09-06 20:02:18 +0000
commita9735e78833a1d703d31cee4e6192441e38a1e4c (patch)
tree48cbb5eab32172a0743353baef3b6b422addfbaa /media-libs/openal
parentCheck for TMPFS_POSIX_ACL when needed (#482336#c24 by Alexander Tsoy) (diff)
downloadgentoo-2-a9735e78833a1d703d31cee4e6192441e38a1e4c.tar.gz
gentoo-2-a9735e78833a1d703d31cee4e6192441e38a1e4c.tar.bz2
gentoo-2-a9735e78833a1d703d31cee4e6192441e38a1e4c.zip
converted to support multilib-build; commit OKd by radhermit
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'media-libs/openal')
-rw-r--r--media-libs/openal/ChangeLog7
-rw-r--r--media-libs/openal/openal-1.15.1-r1.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/media-libs/openal/ChangeLog b/media-libs/openal/ChangeLog
index d37226fa97f5..fa624c866cdb 100644
--- a/media-libs/openal/ChangeLog
+++ b/media-libs/openal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/openal
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/ChangeLog,v 1.166 2013/01/20 14:40:17 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/ChangeLog,v 1.167 2013/09/06 20:02:18 axs Exp $
+
+*openal-1.15.1-r1 (06 Sep 2013)
+
+ 06 Sep 2013; Ian Stakenvicius <axs@gentoo.org> +openal-1.15.1-r1.ebuild:
+ converted to support multilib-build; commit OKd by radhermit
20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -openal-1.13.ebuild,
-openal-1.14.ebuild, -openal-1.15.ebuild:
diff --git a/media-libs/openal/openal-1.15.1-r1.ebuild b/media-libs/openal/openal-1.15.1-r1.ebuild
new file mode 100644
index 000000000000..97f730726c96
--- /dev/null
+++ b/media-libs/openal/openal-1.15.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/openal-1.15.1-r1.ebuild,v 1.1 2013/09/06 20:02:17 axs Exp $
+
+EAPI=5
+inherit cmake-multilib
+
+MY_P=${PN}-soft-${PV}
+
+DESCRIPTION="A software implementation of the OpenAL 3D audio API"
+HOMEPAGE="http://kcat.strangesoft.net/openal.html"
+SRC_URI="http://kcat.strangesoft.net/openal-releases/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="alsa alstream coreaudio debug neon oss portaudio pulseaudio sse"
+
+RDEPEND="alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
+ alstream? ( virtual/ffmpeg )
+ portaudio? ( >=media-libs/portaudio-19_pre[${MULTILIB_USEDEP}] )
+ pulseaudio? ( media-sound/pulseaudio )
+ abi_x86_32? (
+ alsa? ( !<app-emulation/emul-linux-x86-soundlibs-20130224-r4 )
+ portaudio? ( !<app-emulation/emul-linux-x86-soundlibs-20130224-r9 )
+ amd64? (
+ alstream? ( app-emulation/emul-linux-x86-medialibs )
+ pulseaudio? ( app-emulation/emul-linux-x86-soundlibs )
+ )
+ )"
+DEPEND="${RDEPEND}
+ oss? ( virtual/os-headers )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="alsoftrc.sample env-vars.txt hrtf.txt README"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use alsa)
+ $(cmake-utils_use coreaudio)
+ $(cmake-utils_use alstream EXAMPLES)
+ $(cmake-utils_use neon)
+ $(cmake-utils_use oss)
+ $(cmake-utils_use portaudio)
+ $(cmake-utils_use pulseaudio)
+ $(cmake-utils_use sse)
+ )
+
+ cmake-multilib_src_configure
+}