summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-04-16 20:21:31 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-04-16 20:21:31 +0000
commit0382ef30e6f2ce3c2d21ce8a9a80565602d31c93 (patch)
tree191ea7ddfa863409b1ebf3089ecbfa4053206a74 /media-libs/mesa/mesa-6.4.2-r2.ebuild
parentAlphabetize card ordering. (diff)
downloadgentoo-2-0382ef30e6f2ce3c2d21ce8a9a80565602d31c93.tar.gz
gentoo-2-0382ef30e6f2ce3c2d21ce8a9a80565602d31c93.tar.bz2
gentoo-2-0382ef30e6f2ce3c2d21ce8a9a80565602d31c93.zip
Split out ATI cards into mach64, r128 and radeon.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'media-libs/mesa/mesa-6.4.2-r2.ebuild')
-rw-r--r--media-libs/mesa/mesa-6.4.2-r2.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/media-libs/mesa/mesa-6.4.2-r2.ebuild b/media-libs/mesa/mesa-6.4.2-r2.ebuild
index d6697a05a6dd..f90bf8c03cf0 100644
--- a/media-libs/mesa/mesa-6.4.2-r2.ebuild
+++ b/media-libs/mesa/mesa-6.4.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.4.2-r2.ebuild,v 1.6 2006/04/16 20:10:52 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.4.2-r2.ebuild,v 1.7 2006/04/16 20:21:31 spyderous Exp $
inherit eutils toolchain-funcs multilib flag-o-matic portability
@@ -16,10 +16,12 @@ LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE_VIDEO_CARDS="
- video_cards_ati
video_cards_i810
+ video_cards_mach64
video_cards_mga
video_cards_none
+ video_cards_r128
+ video_cards_radeon
video_cards_s3virge
video_cards_savage
video_cards_sis
@@ -114,15 +116,21 @@ src_unpack() {
echo "DEFINES += -DDEFAULT_DRIVER_DIR='\"/usr/$(get_libdir)/xorg/modules/dri\"'" >> ${HOSTCONF}
# Configurable DRI drivers
- if use video_cards_ati; then
- add_drivers mach64 r128 radeon r200 r300
- fi
if use video_cards_i810; then
add_drivers i810 i830 i915
fi
+ if use video_cards_mach64; then
+ add_drivers mach64
+ fi
if use video_cards_mga; then
add_drivers mga
fi
+ if use video_cards_r128; then
+ add_drivers r128
+ fi
+ if use video_cards_radeon; then
+ add_drivers radeon r200 r300
+ fi
if use video_cards_s3virge; then
add_drivers s3v
fi