summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-03 11:39:11 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-03 11:39:11 +0000
commit3cb750ad8503a375406ed8af679aae3706026c7a (patch)
tree942c8f599c3d941b0f787191bbea8087f383936d /media-libs/lv2
parentRemove old (diff)
downloadgentoo-2-3cb750ad8503a375406ed8af679aae3706026c7a.tar.gz
gentoo-2-3cb750ad8503a375406ed8af679aae3706026c7a.tar.bz2
gentoo-2-3cb750ad8503a375406ed8af679aae3706026c7a.zip
Use python-single-r1 for waf + installed Python script. Add missing Python deps.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-libs/lv2')
-rw-r--r--media-libs/lv2/ChangeLog10
-rw-r--r--media-libs/lv2/lv2-1.10.0.ebuild17
-rw-r--r--media-libs/lv2/lv2-1.8.0.ebuild17
3 files changed, 35 insertions, 9 deletions
diff --git a/media-libs/lv2/ChangeLog b/media-libs/lv2/ChangeLog
index cc334f6419c2..40ad7043585a 100644
--- a/media-libs/lv2/ChangeLog
+++ b/media-libs/lv2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/lv2
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lv2/ChangeLog,v 1.9 2014/11/02 18:53:46 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lv2/ChangeLog,v 1.10 2015/01/03 11:39:11 mgorny Exp $
+
+ 03 Jan 2015; Michał Górny <mgorny@gentoo.org> lv2-1.10.0.ebuild,
+ lv2-1.8.0.ebuild:
+ Use python-single-r1 for waf + installed Python script. Add missing Python
+ deps.
*lv2-1.10.0 (02 Nov 2014)
@@ -40,4 +45,3 @@
21 Apr 2012; Alexis Ballier <aballier@gentoo.org> +lv2-1.0.0.ebuild,
+metadata.xml:
initial import, ebuild by me
-
diff --git a/media-libs/lv2/lv2-1.10.0.ebuild b/media-libs/lv2/lv2-1.10.0.ebuild
index bc99eeb88115..67c39dcdbc58 100644
--- a/media-libs/lv2/lv2-1.10.0.ebuild
+++ b/media-libs/lv2/lv2-1.10.0.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lv2/lv2-1.10.0.ebuild,v 1.1 2014/11/02 18:53:46 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lv2/lv2-1.10.0.ebuild,v 1.2 2015/01/03 11:39:11 mgorny Exp $
EAPI=4
-inherit waf-utils
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-single-r1 waf-utils
DESCRIPTION="LV2 is a simple but extensible successor of LADSPA"
HOMEPAGE="http://lv2plug.in/"
@@ -17,6 +19,9 @@ IUSE="doc plugins"
DEPEND="plugins? ( x11-libs/gtk+:2 media-libs/libsndfile )"
RDEPEND="${DEPEND}
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
!<media-libs/slv2-0.4.2
!media-libs/lv2core
!media-libs/lv2-ui"
@@ -31,3 +36,9 @@ src_configure() {
$(use plugins || echo " --no-plugins") \
$(use doc && echo " --docs" )
}
+
+src_install() {
+ waf-utils_src_install
+
+ python_fix_shebang "${D}"
+}
diff --git a/media-libs/lv2/lv2-1.8.0.ebuild b/media-libs/lv2/lv2-1.8.0.ebuild
index 5a8e9195929e..5aace03ebe8a 100644
--- a/media-libs/lv2/lv2-1.8.0.ebuild
+++ b/media-libs/lv2/lv2-1.8.0.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lv2/lv2-1.8.0.ebuild,v 1.1 2014/01/18 12:16:47 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lv2/lv2-1.8.0.ebuild,v 1.2 2015/01/03 11:39:11 mgorny Exp $
EAPI=4
-inherit waf-utils
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-single-r1 waf-utils
DESCRIPTION="LV2 is a simple but extensible successor of LADSPA"
HOMEPAGE="http://lv2plug.in/"
@@ -17,6 +19,9 @@ IUSE="doc plugins"
DEPEND="plugins? ( x11-libs/gtk+:2 media-libs/libsndfile )"
RDEPEND="${DEPEND}
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
!<media-libs/slv2-0.4.2
!media-libs/lv2core
!media-libs/lv2-ui"
@@ -31,3 +36,9 @@ src_configure() {
$(use plugins || echo " --no-plugins") \
$(use doc && echo " --docs" )
}
+
+src_install() {
+ waf-utils_src_install
+
+ python_fix_shebang "${D}"
+}