summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-09-07 22:02:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-09-07 22:02:09 +0000
commit398093555757c062037e1b2b4723b0dfb4149eb3 (patch)
treee16d4a45218c065b56d1008a58e7e19109737c82 /media-libs/libtheora
parentbump to 0.51, fix bug #236998. (diff)
downloadgentoo-2-398093555757c062037e1b2b4723b0dfb4149eb3.tar.gz
gentoo-2-398093555757c062037e1b2b4723b0dfb4149eb3.tar.bz2
gentoo-2-398093555757c062037e1b2b4723b0dfb4149eb3.zip
Don't run encoder tests without use encode, bug #212315
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.3 x86_64)
Diffstat (limited to 'media-libs/libtheora')
-rw-r--r--media-libs/libtheora/ChangeLog6
-rw-r--r--media-libs/libtheora/files/libtheora-1.0_beta3-tests.patch29
-rw-r--r--media-libs/libtheora/libtheora-1.0_beta3-r1.ebuild7
3 files changed, 36 insertions, 6 deletions
diff --git a/media-libs/libtheora/ChangeLog b/media-libs/libtheora/ChangeLog
index 4eb9c4c8074b..3bb328b0d1ff 100644
--- a/media-libs/libtheora/ChangeLog
+++ b/media-libs/libtheora/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libtheora
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.76 2008/06/16 11:47:03 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.77 2008/09/07 22:02:08 aballier Exp $
+
+ 07 Sep 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/libtheora-1.0_beta3-tests.patch, libtheora-1.0_beta3-r1.ebuild:
+ Don't run encoder tests without use encode, bug #212315
16 Jun 2008; Diego Pettenò <flameeyes@gentoo.org>
libtheora-1.0_beta3-r1.ebuild:
diff --git a/media-libs/libtheora/files/libtheora-1.0_beta3-tests.patch b/media-libs/libtheora/files/libtheora-1.0_beta3-tests.patch
new file mode 100644
index 000000000000..2dcef60d61d1
--- /dev/null
+++ b/media-libs/libtheora/files/libtheora-1.0_beta3-tests.patch
@@ -0,0 +1,29 @@
+https://trac.xiph.org/ticket/1423
+
+Index: libtheora-1.0beta3/tests/Makefile.am
+===================================================================
+--- libtheora-1.0beta3.orig/tests/Makefile.am
++++ libtheora-1.0beta3/tests/Makefile.am
+@@ -13,12 +13,19 @@ test: check
+
+ TESTS_ENVIRONMENT = $(VALGRIND_ENVIRONMENT)
+
+-TESTS = noop noop_theoraenc noop_theora \
+- comment comment_theoradec comment_theora \
++TESTS_DEC = noop_theora \
++ comment comment_theoradec comment_theora
++
++TESTS_ENC = noop noop_theoraenc \
+ granulepos granulepos_theoraenc granulepos_theora
+
+-noinst_PROGRAMS = $(TESTS)
++if THEORA_DISABLE_ENCODE
++TESTS = $(TESTS_DEC)
++else
++TESTS = $(TESTS_DEC) $(TESTS_ENC)
++endif
+
++check_PROGRAMS = $(TESTS)
+ # dummy call tests for the current api
+ noop_SOURCES = noop.c
+ noop_LDADD = $(THEORAENC_LIBS)
diff --git a/media-libs/libtheora/libtheora-1.0_beta3-r1.ebuild b/media-libs/libtheora/libtheora-1.0_beta3-r1.ebuild
index 0afea6f9bb69..8b17a4a27114 100644
--- a/media-libs/libtheora/libtheora-1.0_beta3-r1.ebuild
+++ b/media-libs/libtheora/libtheora-1.0_beta3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_beta3-r1.ebuild,v 1.2 2008/06/16 11:47:03 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_beta3-r1.ebuild,v 1.3 2008/09/07 22:02:08 aballier Exp $
inherit autotools eutils toolchain-funcs flag-o-matic
@@ -26,10 +26,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${PN}-1.0_beta2-flags.patch
epatch "${FILESDIR}"/${P}-pic-fix.patch
-
- sed -i -e 's:noinst_PROGRAMS:check_PROGRAMS:' \
- "${S}"/tests/Makefile.am \
- || die "unable to disable tests building"
+ epatch "${FILESDIR}"/${P}-tests.patch
AT_M4DIR="m4" eautoreconf
}