summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-07 16:03:34 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-07 16:03:34 +0000
commit79fd6c1214c64792de490eeea632785dac9cbe9c (patch)
tree23b96eed78ea06498ac9de0f3c3d829a57749acd /media-libs/libsoundtouch
parentVersion bumps (diff)
downloadgentoo-2-79fd6c1214c64792de490eeea632785dac9cbe9c.tar.gz
gentoo-2-79fd6c1214c64792de490eeea632785dac9cbe9c.tar.bz2
gentoo-2-79fd6c1214c64792de490eeea632785dac9cbe9c.zip
Enable multilib support, bug #510686.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-libs/libsoundtouch')
-rw-r--r--media-libs/libsoundtouch/ChangeLog7
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-1.8.0-r1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/media-libs/libsoundtouch/ChangeLog b/media-libs/libsoundtouch/ChangeLog
index cedfac9ab50f..0153f3851076 100644
--- a/media-libs/libsoundtouch/ChangeLog
+++ b/media-libs/libsoundtouch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libsoundtouch
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/ChangeLog,v 1.78 2014/05/11 08:12:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/ChangeLog,v 1.79 2014/06/07 16:03:34 mgorny Exp $
+
+*libsoundtouch-1.8.0-r1 (07 Jun 2014)
+
+ 07 Jun 2014; Michał Górny <mgorny@gentoo.org> +libsoundtouch-1.8.0-r1.ebuild:
+ Enable multilib support, bug #510686.
11 May 2014; Agostino Sarubbo <ago@gentoo.org> libsoundtouch-1.8.0.ebuild:
Stable for ppc64, wrt bug #502842
diff --git a/media-libs/libsoundtouch/libsoundtouch-1.8.0-r1.ebuild b/media-libs/libsoundtouch/libsoundtouch-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..9465dc5de302
--- /dev/null
+++ b/media-libs/libsoundtouch/libsoundtouch-1.8.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/libsoundtouch-1.8.0-r1.ebuild,v 1.1 2014/06/07 16:03:34 mgorny Exp $
+
+EAPI=5
+inherit autotools eutils flag-o-matic multilib-minimal
+
+MY_PN=${PN/lib}
+
+DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates."
+HOMEPAGE="http://www.surina.net/soundtouch/"
+SRC_URI="http://www.surina.net/soundtouch/${P/lib}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="sse2 static-libs"
+
+DEPEND="virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${MY_PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7.0-flags.patch
+ sed -i "s:^\(pkgdoc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' configure.ac || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-shared \
+ --disable-integer-samples \
+ --enable-x86-optimizations=$(usex sse2) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}/html install
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+}