summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-05 09:26:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-05 09:26:49 +0000
commitfcf5630b03b59f08b97d52b50431282e70af1325 (patch)
tree25d7f7d3aa029bc1ac44dafb165b820c33d840f6 /media-libs/libsndfile
parentDo not strip debug QT CFLAGS per bug #329533 (diff)
downloadgentoo-2-fcf5630b03b59f08b97d52b50431282e70af1325.tar.gz
gentoo-2-fcf5630b03b59f08b97d52b50431282e70af1325.tar.bz2
gentoo-2-fcf5630b03b59f08b97d52b50431282e70af1325.zip
Remove append-lfs-flags (#313259) again wrt #335728.
(Portage version: 2.2_rc69/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libsndfile')
-rw-r--r--media-libs/libsndfile/ChangeLog8
-rw-r--r--media-libs/libsndfile/libsndfile-1.0.21-r1.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/media-libs/libsndfile/ChangeLog b/media-libs/libsndfile/ChangeLog
index 43ff22bda56f..be2bca033151 100644
--- a/media-libs/libsndfile/ChangeLog
+++ b/media-libs/libsndfile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libsndfile
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsndfile/ChangeLog,v 1.113 2010/06/25 12:07:14 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsndfile/ChangeLog,v 1.114 2010/09/05 09:26:49 ssuominen Exp $
+
+*libsndfile-1.0.21-r1 (05 Sep 2010)
+
+ 05 Sep 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +libsndfile-1.0.21-r1.ebuild:
+ Remove append-lfs-flags (#313259) again wrt #335728.
25 Jun 2010; Alexis Ballier <aballier@gentoo.org>
-libsndfile-1.0.17-r1.ebuild, -files/libsndfile-1.0.17-autotools.patch,
diff --git a/media-libs/libsndfile/libsndfile-1.0.21-r1.ebuild b/media-libs/libsndfile/libsndfile-1.0.21-r1.ebuild
new file mode 100644
index 000000000000..951324357caf
--- /dev/null
+++ b/media-libs/libsndfile/libsndfile-1.0.21-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsndfile/libsndfile-1.0.21-r1.ebuild,v 1.1 2010/09/05 09:26:49 ssuominen Exp $
+
+inherit eutils libtool autotools
+
+MY_P=${P/_pre/pre}
+
+DESCRIPTION="A C library for reading and writing files containing sampled sound"
+HOMEPAGE="http://www.mega-nerd.com/libsndfile"
+if [[ "${MY_P}" == "${P}" ]]; then
+ SRC_URI="http://www.mega-nerd.com/libsndfile/files/${P}.tar.gz"
+else
+ SRC_URI="http://www.mega-nerd.com/tmp/${MY_P}b.tar.gz"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa minimal sqlite"
+
+RDEPEND="!minimal? ( >=media-libs/flac-1.2.1
+ >=media-libs/libogg-1.1.3
+ >=media-libs/libvorbis-1.2.1_rc1 )
+ alsa? ( media-libs/alsa-lib )
+ sqlite? ( >=dev-db/sqlite-3.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s/noinst_PROGRAMS/check_PROGRAMS/" "${S}/tests/Makefile.am" \
+ "${S}/examples/Makefile.am" || die "sed failed"
+
+ epatch "${FILESDIR}"/${PN}-1.0.17-regtests-need-sqlite.patch
+
+ rm M4/libtool.m4 M4/lt*.m4 || die "rm failed"
+
+ AT_M4DIR=M4 eautoreconf
+ epunt_cxx
+}
+
+src_compile() {
+ econf $(use_enable sqlite) \
+ $(use_enable alsa) \
+ $(use_enable !minimal external-libs) \
+ --disable-octave \
+ --disable-gcc-werror \
+ --disable-gcc-pipe \
+ --disable-dependency-tracking
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" htmldocdir="/usr/share/doc/${PF}/html" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}