summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-09 21:03:31 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-09 21:03:31 +0000
commitaa718deb67de12f50a87cbceddf116bce4fe46fe (patch)
tree4c37ccb18deac391a955bdb99cc61a62d40d66d5 /media-libs/libsdl
parentcall it renamexm instead of xmrename to help tab completion (Manifest recommit) (diff)
downloadgentoo-2-aa718deb67de12f50a87cbceddf116bce4fe46fe.tar.gz
gentoo-2-aa718deb67de12f50a87cbceddf116bce4fe46fe.tar.bz2
gentoo-2-aa718deb67de12f50a87cbceddf116bce4fe46fe.zip
Add patch from upstream to fix variable clashing with linux headers #74608.
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/ChangeLog6
-rw-r--r--media-libs/libsdl/files/1.2.8-linux26.patch37
-rw-r--r--media-libs/libsdl/libsdl-1.2.8.ebuild3
3 files changed, 44 insertions, 2 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index 7a8d947f83a2..db1d623f825a 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libsdl
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.72 2005/01/04 09:53:42 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.73 2005/01/09 21:03:31 vapier Exp $
+
+ 09 Jan 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/1.2.8-linux26.patch, libsdl-1.2.8.ebuild:
+ Add patch from upstream to fix variable clashing with linux headers #74608.
04 Jan 2005; Hardave Riar <hardave@gentoo.org> libsdl-1.2.6-r3.ebuild:
Stable on mips, dep of bug #74475.
diff --git a/media-libs/libsdl/files/1.2.8-linux26.patch b/media-libs/libsdl/files/1.2.8-linux26.patch
new file mode 100644
index 000000000000..d0d009b7543c
--- /dev/null
+++ b/media-libs/libsdl/files/1.2.8-linux26.patch
@@ -0,0 +1,37 @@
+http://bugs.gentoo.org/show_bug.cgi?id=74608
+
+Index: SDL_fbevents.c
+===================================================================
+RCS file: /home/sdlweb/libsdl.org/cvs/SDL12/src/video/fbcon/SDL_fbevents.c,v
+retrieving revision 1.13
+retrieving revision 1.14
+diff -u -r1.13 -r1.14
+--- src/video/fbcon/SDL_fbevents.c 4 Jan 2004 16:49:25 -0000 1.13
++++ src/video/fbcon/SDL_fbevents.c 4 Jan 2005 19:04:14 -0000 1.14
+@@ -835,7 +835,7 @@
+ static void switch_vt(_THIS, unsigned short which)
+ {
+ struct vt_stat vtstate;
+- unsigned short current;
++ unsigned short v_active;
+ SDL_Surface *screen;
+ __u16 saved_pal[3*256];
+ Uint32 screen_arealen;
+@@ -846,7 +846,7 @@
+ (which == vtstate.v_active) ) {
+ return;
+ }
+- current = vtstate.v_active;
++ v_active = vtstate.v_active;
+
+ /* Save the contents of the screen, and go to text mode */
+ SDL_mutexP(hw_lock);
+@@ -864,7 +864,7 @@
+ if ( ioctl(keyboard_fd, VT_ACTIVATE, which) == 0 ) {
+ /* Wait for our console to be activated again */
+ ioctl(keyboard_fd, VT_WAITACTIVE, which);
+- while ( ioctl(keyboard_fd, VT_WAITACTIVE, current) < 0 ) {
++ while ( ioctl(keyboard_fd, VT_WAITACTIVE, v_active) < 0 ) {
+ if ( (errno != EINTR) && (errno != EAGAIN) ) {
+ /* Unknown VT error - cancel this */
+ break;
diff --git a/media-libs/libsdl/libsdl-1.2.8.ebuild b/media-libs/libsdl/libsdl-1.2.8.ebuild
index 2dcea920f6a9..9208128734f0 100644
--- a/media-libs/libsdl/libsdl-1.2.8.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8.ebuild,v 1.8 2005/01/03 02:19:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8.ebuild,v 1.9 2005/01/09 21:03:31 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils gnuconfig
@@ -50,6 +50,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PV}-libcaca.patch #40224
epatch "${FILESDIR}"/${PV}-gcc2.patch #75392
epatch "${FILESDIR}"/${PV}-keyrepeat.patch #76448
+ epatch "${FILESDIR}"/${PV}-linux26.patch #74608
[[ $(gcc-major-version) -eq 2 ]] && \
epatch "${FILESDIR}"/${PV}-gcc2-asm.patch #75392