summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-06-11 06:00:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-06-11 06:00:21 +0000
commit27a8ade8fde194e92fcb780b16e9ce37f5bfb7a2 (patch)
tree5ffa03d0d0eb9f29b619b6a20de25a7d4106c1a6 /media-libs/libsdl
parent+media-libs/libsdl:noflagstrip - Allow users to use any CFLAGS they like comp... (diff)
downloadgentoo-2-27a8ade8fde194e92fcb780b16e9ce37f5bfb7a2.tar.gz
gentoo-2-27a8ade8fde194e92fcb780b16e9ce37f5bfb7a2.tar.bz2
gentoo-2-27a8ade8fde194e92fcb780b16e9ce37f5bfb7a2.zip
Call strip-flags for everyone due to the large number of problems caused by people using unsafe CFLAGS. Added noflagstrip local use flag to avoid the strip-flags call for people who know what they're doing and will fix resulting problems themselves.
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/ChangeLog9
-rw-r--r--media-libs/libsdl/libsdl-1.2.8-r1.ebuild18
2 files changed, 21 insertions, 6 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index f09ce7b6913f..7125df13b2ea 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libsdl
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.81 2005/06/10 13:51:20 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.82 2005/06/11 06:00:21 mr_bones_ Exp $
+
+ 11 Jun 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ libsdl-1.2.8-r1.ebuild:
+ Call strip-flags for everyone due to the large number of problems caused
+ by people using unsafe CFLAGS. Added noflagstrip local use flag to avoid
+ the strip-flags call for people who know what they're doing and will fix
+ resulting problems themselves.
10 Jun 2005; Chris Gianelloni <wolf31o2@gentoo.org>
libsdl-1.2.8-r1.ebuild:
diff --git a/media-libs/libsdl/libsdl-1.2.8-r1.ebuild b/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
index 6c9f0ac6b116..15203c6e4850 100644
--- a/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8-r1.ebuild,v 1.15 2005/06/10 13:51:20 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8-r1.ebuild,v 1.16 2005/06/11 06:00:21 mr_bones_ Exp $
inherit flag-o-matic toolchain-funcs eutils gnuconfig
@@ -11,8 +11,11 @@ SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ppc ~ppc-macos ppc64 sparc x86"
-IUSE="oss alsa esd arts nas X dga xv xinerama fbcon directfb ggi svga aalib opengl libcaca pic noaudio novideo nojoystick"
-# if you disable audio/video/joystick and something breaks, you pick up the pieces
+# WARNING:
+# if you have the noaudio, novideo, nojoystick, or noflagstrip use flags
+# in USE and something breaks, you pick up the pieces. Be prepared for
+# bug reports to be marked INVALID.
+IUSE="oss alsa esd arts nas X dga xv xinerama fbcon directfb ggi svga aalib opengl libcaca pic noaudio novideo nojoystick noflagstrip"
RDEPEND=">=media-libs/audiofile-0.1.9
alsa? ( media-libs/alsa-lib )
@@ -40,6 +43,12 @@ pkg_setup() {
ewarn "you're doing to selectively turn off parts of libsdl."
epause 30
fi
+ if use noflagstrip ; then
+ ewarn "Since you've chosen to use possibly unsafe CFLAGS,"
+ ewarn "don't bother filing libsdl-related bugs until trying to remerge"
+ ewarn "libsdl without the noflagstrip use flag in USE."
+ epause 10
+ fi
}
src_unpack() {
@@ -76,12 +85,11 @@ src_compile() {
if use amd64 ; then
replace-flags -O? -O1 # bug #74608
- strip-flags -funroll-all-loops -fpeel-loops -fomit-frame-pointer # more bug #74608 and also bug #82618
fi
if use x86 ; then
- filter-flags -fforce-addr -msse2 #87077 and #94377
use pic || myconf="${myconf} $(use_enable x86 nasm)"
fi
+ use noflagstrip || strip-flags
use noaudio && myconf="${myconf} --disable-audio"
use novideo \
&& myconf="${myconf} --disable-video" \