summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-11-11 10:18:47 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-11-11 10:18:47 +0000
commit4e5e06d89ac16888dcb614a61304a98e87157a27 (patch)
treebd29f06760bc6059550462ab32f279d8a3c0ed4d /media-libs/libmpeg3/libmpeg3-1.7.ebuild
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-4e5e06d89ac16888dcb614a61304a98e87157a27.tar.gz
gentoo-2-4e5e06d89ac16888dcb614a61304a98e87157a27.tar.bz2
gentoo-2-4e5e06d89ac16888dcb614a61304a98e87157a27.zip
Use virtual/jpeg wrt #327487. cleanup
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libmpeg3/libmpeg3-1.7.ebuild')
-rw-r--r--media-libs/libmpeg3/libmpeg3-1.7.ebuild51
1 files changed, 19 insertions, 32 deletions
diff --git a/media-libs/libmpeg3/libmpeg3-1.7.ebuild b/media-libs/libmpeg3/libmpeg3-1.7.ebuild
index bc2c711b0b37..07326d77c268 100644
--- a/media-libs/libmpeg3/libmpeg3-1.7.ebuild
+++ b/media-libs/libmpeg3/libmpeg3-1.7.ebuild
@@ -1,10 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/libmpeg3-1.7.ebuild,v 1.20 2009/03/10 19:03:14 beandog Exp $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/libmpeg3-1.7.ebuild,v 1.21 2010/11/11 10:18:47 ssuominen Exp $
+EAPI=2
inherit eutils autotools toolchain-funcs
PATCHLEVEL="1"
@@ -19,47 +17,34 @@ KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86"
IUSE="mmx"
RDEPEND="sys-libs/zlib
- media-libs/jpeg
+ virtual/jpeg
media-libs/a52dec"
DEPEND="${RDEPEND}
mmx? ( dev-lang/nasm )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if [[ $(gcc-version) == "3.3" ]]; then
- eerror "You're using an old version of GCC, but this package is"
- eerror "designed to work only with GCC 3.4 or later."
- eerror "Please upgrade your GCC or change the selected profile"
- eerror "and then merge this again."
- die "Package won't build with GCC 3.3."
- fi
-
- epatch "${WORKDIR}/${P}-mpeg3split.patch"
- epatch "${WORKDIR}/${P}-textrel.patch"
- epatch "${WORKDIR}/${P}-gnustack.patch"
- epatch "${WORKDIR}/${P}-a52.patch"
- epatch "${WORKDIR}/${P}-all_gcc4.patch"
- epatch "${WORKDIR}/${P}-all_pthread.patch"
+src_prepare() {
+ epatch "${WORKDIR}"/${P}-mpeg3split.patch
+ epatch "${WORKDIR}"/${P}-textrel.patch
+ epatch "${WORKDIR}"/${P}-gnustack.patch
+ epatch "${WORKDIR}"/${P}-a52.patch
+ epatch "${WORKDIR}"/${P}-all_gcc4.patch
+ epatch "${WORKDIR}"/${P}-all_pthread.patch
# warning: incompatible implicit declaration of built-in function memcpy
epatch "${FILESDIR}"/${P}-memcpy.patch
- cp -rf "${WORKDIR}/${PV}"/* .
+ cp -rf "${WORKDIR}"/${PV}/* .
eautoreconf
-
}
-src_compile() {
+src_configure() {
#disabling css since it's a fake one.
#One can find in the sources this message :
# Stubs for deCSS which can't be distributed in source form
- econf $(use_enable mmx )\
- --disable-css || die "Configure failed"
-
- emake || die "make failed"
+ econf \
+ $(use_enable mmx) \
+ --disable-css
}
src_install() {
@@ -72,5 +57,7 @@ src_install() {
# This patch patches the .h files that get installed into /usr/include
# to show the correct include syntax '<>' instead of '""' This patch
# was also generated using info from SF's src.rpm
- epatch "${WORKDIR}/gentoo-p2.patch"
+ epatch "${WORKDIR}"/gentoo-p2.patch
+
+ find "${D}" -name '*.la' -exec rm -f '{}' +
}