summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-18 20:29:29 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-18 20:29:29 +0000
commitda70129c0ccfd326276f7b822a15385245b811b4 (patch)
treea18e4c01f889f0b1cf25455cd3909cb65ad90481 /media-libs/libmatroska
parentAdd patch to respect LDFLAGS and CXX. (diff)
downloadgentoo-2-da70129c0ccfd326276f7b822a15385245b811b4.tar.gz
gentoo-2-da70129c0ccfd326276f7b822a15385245b811b4.tar.bz2
gentoo-2-da70129c0ccfd326276f7b822a15385245b811b4.zip
Add patch to respect LDFLAGS and CXX.
(Portage version: 2.1_pre6-r3)
Diffstat (limited to 'media-libs/libmatroska')
-rw-r--r--media-libs/libmatroska/ChangeLog8
-rw-r--r--media-libs/libmatroska/files/libmatroska-0.8.0-respectflags.patch13
-rw-r--r--media-libs/libmatroska/libmatroska-0.8.0.ebuild14
3 files changed, 28 insertions, 7 deletions
diff --git a/media-libs/libmatroska/ChangeLog b/media-libs/libmatroska/ChangeLog
index 749c260ad756..fbd933b1124f 100644
--- a/media-libs/libmatroska/ChangeLog
+++ b/media-libs/libmatroska/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libmatroska
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/ChangeLog,v 1.64 2005/12/09 01:51:49 flameeyes Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/ChangeLog,v 1.65 2006/03/18 20:29:28 flameeyes Exp $
+
+ 18 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/libmatroska-0.8.0-respectflags.patch, libmatroska-0.8.0.ebuild:
+ Add patch to respect LDFLAGS and CXX.
09 Dec 2005; Diego Pettenò <flameeyes@gentoo.org>
libmatroska-0.7.3-r1.ebuild, libmatroska-0.7.6.ebuild,
diff --git a/media-libs/libmatroska/files/libmatroska-0.8.0-respectflags.patch b/media-libs/libmatroska/files/libmatroska-0.8.0-respectflags.patch
new file mode 100644
index 000000000000..dcf9de4fbffb
--- /dev/null
+++ b/media-libs/libmatroska/files/libmatroska-0.8.0-respectflags.patch
@@ -0,0 +1,13 @@
+Index: libmatroska-0.8.0/make/linux/Makefile
+===================================================================
+--- libmatroska-0.8.0.orig/make/linux/Makefile
++++ libmatroska-0.8.0/make/linux/Makefile
+@@ -102,7 +102,7 @@ $(LIBRARY): $(objects)
+ $(RANLIB) $@
+
+ $(LIBRARY_SO): $(objects_so)
+- $(CXX) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so) -lebml
++ $(CXX) $(LINKFLAGS) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so) -lebml
+ ln -s $(LIBRARY_SO_VER) $(LIBRARY_SO)
+
+ clean: cleantest
diff --git a/media-libs/libmatroska/libmatroska-0.8.0.ebuild b/media-libs/libmatroska/libmatroska-0.8.0.ebuild
index 385685cef164..7a9138aa4819 100644
--- a/media-libs/libmatroska/libmatroska-0.8.0.ebuild
+++ b/media-libs/libmatroska/libmatroska-0.8.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/libmatroska-0.8.0.ebuild,v 1.3 2005/12/09 01:51:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmatroska/libmatroska-0.8.0.ebuild,v 1.4 2006/03/18 20:29:29 flameeyes Exp $
-IUSE=""
+inherit flag-o-matic eutils toolchain-funcs
-inherit flag-o-matic eutils
+IUSE=""
DESCRIPTION="Extensible multimedia container format based on EBML"
HOMEPAGE="http://www.matroska.org/"
@@ -18,6 +18,9 @@ DEPEND=">=dev-libs/libebml-0.7.6"
src_unpack() {
unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}/${P}-respectflags.patch"
cd ${S}/make/linux
sed -i -e 's/CXXFLAGS=/CXXFLAGS+=/g' Makefile
@@ -31,7 +34,8 @@ src_compile() {
emake PREFIX=/usr \
LIBEBML_INCLUDE_DIR=/usr/include/ebml \
- LIBEBML_LIB_DIR=/usr/$(get_libdir) || die "make failed"
+ LIBEBML_LIB_DIR=/usr/$(get_libdir) \
+ CXX="$(tc-getCXX)" || die "make failed"
}
src_install() {