summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-05-29 18:01:24 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-05-29 18:01:24 +0000
commitabd62db76ff547703f85bd1b72856708f33dd400 (patch)
tree23f9abe62e42ab5465e26c7b9ff45a0862b2dfa3 /media-libs/libjsw
parentStable on hppa. (diff)
downloadgentoo-2-abd62db76ff547703f85bd1b72856708f33dd400.tar.gz
gentoo-2-abd62db76ff547703f85bd1b72856708f33dd400.tar.bz2
gentoo-2-abd62db76ff547703f85bd1b72856708f33dd400.zip
Bump, and fix bug #110789 about online help
(Portage version: 2.1_rc2-r3)
Diffstat (limited to 'media-libs/libjsw')
-rw-r--r--media-libs/libjsw/ChangeLog10
-rw-r--r--media-libs/libjsw/files/digest-libjsw-1.5.63
-rw-r--r--media-libs/libjsw/files/libjsw-1.5.6-build.patch109
-rw-r--r--media-libs/libjsw/libjsw-1.5.6.ebuild57
4 files changed, 178 insertions, 1 deletions
diff --git a/media-libs/libjsw/ChangeLog b/media-libs/libjsw/ChangeLog
index 61ead0d07629..402459b453a8 100644
--- a/media-libs/libjsw/ChangeLog
+++ b/media-libs/libjsw/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/libjsw
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libjsw/ChangeLog,v 1.10 2006/04/25 00:04:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libjsw/ChangeLog,v 1.11 2006/05/29 18:01:24 tupone Exp $
+
+*libjsw-1.5.6 (29 May 2006)
+
+ 29 May 2006; <Tupone@gentoo.org> +files/libjsw-1.5.6-build.patch,
+ +libjsw-1.5.6.ebuild:
+ Bump version.
+ Fix online help, bug #110789 by Toralf Förster
+ Fix compiling without the jsw.h header file already in
25 Apr 2006; Mike Frysinger <vapier@gentoo.org>
+files/libjsw-1.5.5-build.patch, files/libjsw-1.5.5-gcc33.patch,
diff --git a/media-libs/libjsw/files/digest-libjsw-1.5.6 b/media-libs/libjsw/files/digest-libjsw-1.5.6
new file mode 100644
index 000000000000..bda76eb0e15d
--- /dev/null
+++ b/media-libs/libjsw/files/digest-libjsw-1.5.6
@@ -0,0 +1,3 @@
+MD5 d75948b7ff464982cc6e1de4c94008be libjsw-1.5.6.tar.bz2 322826
+RMD160 37d562beb1ebde7cede53daca2ef7d9237985db6 libjsw-1.5.6.tar.bz2 322826
+SHA256 59495f4a1c090d32977da96300d17b165ad181518e4c3ac4702d3a8c7ed7ccc3 libjsw-1.5.6.tar.bz2 322826
diff --git a/media-libs/libjsw/files/libjsw-1.5.6-build.patch b/media-libs/libjsw/files/libjsw-1.5.6-build.patch
new file mode 100644
index 000000000000..2f554fd332c3
--- /dev/null
+++ b/media-libs/libjsw/files/libjsw-1.5.6-build.patch
@@ -0,0 +1,109 @@
+--- libjsw/Makefile.old 2006-05-29 18:49:16.000000000 +0200
++++ libjsw/Makefile 2006-05-29 18:58:27.000000000 +0200
+@@ -51,10 +51,10 @@
+ # to debug the program.
+ #
+
+-CFLAGS = -Wall -O2 -g
+-CFLAGS += -ffast-math
++CFLAGS += -fPIC
++CXXFLAGS += -fPIC
+
+-CPPFLAGS = -D__cplusplus
++CPPFLAGS += -D__cplusplus
+
+
+ # ########################################################################
+@@ -82,11 +82,9 @@
+ OBJ_C = $(SRC_C:.c=.o)
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+- @echo "Compiling module $*.o"
+- @+$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++ $(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
+ .cpp.o:
+- @echo "Compiling module $*.o"
+- @+$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ $(CPP) -c $*.cpp $(INC_DIRS) $(CXXFLAGS) $(CPPFLAGS)
+
+
+ # ########################################################################
+@@ -95,12 +93,7 @@
+ $(LIB): prebuild modules postbuild
+
+ modules: $(OBJ_C) $(OBJ_CPP)
+- @echo -n "Linking modules..."
+- @$(CC) $(OBJ_C) $(OBJ_CPP) -Wl,-soname=$(LIB) -shared -o $(LIB) $(LIBS) $(LIB_DIRS)
+- @echo -n " "
+- @$(RM) $(RMFLAGS) $(LIBPFX).so
+- @$(LINK) -s $(LIB) $(LIBPFX).so
+- @-$(LS) $(LSFLAGS) $(LIB)
++ $(CPP) $(OBJ_C) $(OBJ_CPP) -o $(LIB) $(LDFLAGS) $(LIBS) $(LIB_DIRS)
+
+ prebuild:
+ @echo "Building library \"$(LIB)\"..."
+--- jscalibrator/Makefile.old 2006-05-29 19:01:28.000000000 +0200
++++ jscalibrator/Makefile 2006-05-29 19:05:54.000000000 +0200
+@@ -59,9 +59,6 @@
+ #CFLAGS = -Wall -O -g \
+ # `gtk-config --cflags`
+
+-CFLAGS = -Wall -O6 -fomit-frame-pointer -funroll-loops -ffast-math \
+- `gtk-config --cflags`
+-
+ CPPFLAGS = -D__cplusplus
+
+
+@@ -76,7 +73,7 @@
+ # to the LIB line depending on what you have set in the CFLAGS line
+ # farther above.
+ #
+-LIBS = -ljsw `gtk-config --libs`
++LIBS := -ljsw $(shell gtk-config --libs)
+
+ # Library Directories:
+ #
+@@ -85,7 +82,7 @@
+ # Each argument is of the format -L<dir> where <dir> is the full
+ # path to the directory.
+ #
+-LIB_DIRS =
++LIB_DIRS = -L../libjsw
+
+ # Header File Directories:
+ #
+@@ -95,7 +92,7 @@
+ # Each argument is of the format -I<dir> where <dir> is the full
+ # path to the directory.
+ #
+-INC_DIRS =
++INC_DIRS = $(shell gtk-config --cflags) -I../libjsw
+
+
+ # ########################################################################
+@@ -117,11 +114,9 @@
+ OBJ_C = $(SRC_C:.c=.o)
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .c.o:
+- @echo "Compiling module $*.o"
+- @+$(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
++ $(CC) -c $*.c $(INC_DIRS) $(CFLAGS)
+ .cpp.o:
+- @echo "Compiling module $*.o"
+- @+$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ $(CPP) -c $*.cpp $(INC_DIRS) $(CXXFLAGS) $(CPPFLAGS)
+
+
+ # ########################################################################
+@@ -130,10 +125,7 @@
+ $(BIN): prebuild modules postbuild
+
+ modules: $(OBJ_C) $(OBJ_CPP)
+- @echo -n "Linking modules..."
+- @$(CC) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIBS) $(LIB_DIRS)
+- @echo -n " "
+- @-$(LS) $(LSFLAGS) $(BIN)
++ $(CC) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LDFLAGS) $(LIB_DIRS) $(LIBS)
+
+ prebuild:
+ @echo "Building program \"$(BIN)\"..."
diff --git a/media-libs/libjsw/libjsw-1.5.6.ebuild b/media-libs/libjsw/libjsw-1.5.6.ebuild
new file mode 100644
index 000000000000..fb9146aa35fa
--- /dev/null
+++ b/media-libs/libjsw/libjsw-1.5.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libjsw/libjsw-1.5.6.ebuild,v 1.1 2006/05/29 18:01:24 tupone Exp $
+
+inherit eutils
+
+DESCRIPTION="provide a uniform API and user configuration for joysticks and game controllers"
+HOMEPAGE="http://wolfpack.twu.net/libjsw/"
+SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk"
+
+DEPEND="gtk? ( =x11-libs/gtk+-1.2* )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cp include/jsw.h libjsw/
+ epatch "${FILESDIR}"/${P}-build.patch
+ bunzip2 libjsw/man/* jscalibrator/jscalibrator.1.bz2 || die "bunzip failed"
+}
+
+src_compile() {
+ cd libjsw
+ emake || die "main build failed"
+ ln -s libjsw.so.${PV} libjsw.so
+
+ if use gtk ; then
+ cd ../jscalibrator
+ emake || die "jscalibrator failed"
+ fi
+}
+
+src_install() {
+ insinto /usr/include
+ doins include/jsw.h || die "doins jsw.h failed"
+
+ dodoc AUTHORS README
+ docinto jswdemos
+ dodoc jswdemos/*
+
+ cd "${S}"/libjsw
+ dolib.so libjsw.so.${PV} || die "dolib.so"
+ dosym libjsw.so.${PV} /usr/$(get_libdir)/libjsw.so
+ doman man/*
+
+ if use gtk ; then
+ cd "${S}"/jscalibrator
+ dobin jscalibrator || die
+ doman jscalibrator.1
+ insinto /usr/share/${PN}
+ doins -r data/help
+ fi
+}