summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-10-01 05:25:58 +0000
committerJon Hood <squinky86@gentoo.org>2004-10-01 05:25:58 +0000
commit9382ffb743d236edbc32bbbb4db31db289459fa0 (patch)
tree977738ed487074bcd1932cbe06f2d2e8018f38af /media-libs/libextractor/libextractor-0.3.7.ebuild
parentstable x86 (Manifest recommit) (diff)
downloadgentoo-2-9382ffb743d236edbc32bbbb4db31db289459fa0.tar.gz
gentoo-2-9382ffb743d236edbc32bbbb4db31db289459fa0.tar.bz2
gentoo-2-9382ffb743d236edbc32bbbb4db31db289459fa0.zip
stable x86 and testing branch bumps
Diffstat (limited to 'media-libs/libextractor/libextractor-0.3.7.ebuild')
-rw-r--r--media-libs/libextractor/libextractor-0.3.7.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/libextractor/libextractor-0.3.7.ebuild b/media-libs/libextractor/libextractor-0.3.7.ebuild
new file mode 100644
index 000000000000..e986047f955f
--- /dev/null
+++ b/media-libs/libextractor/libextractor-0.3.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libextractor/libextractor-0.3.7.ebuild,v 1.1 2004/10/01 05:25:58 squinky86 Exp $
+
+inherit libtool
+
+IUSE="oggvorbis static"
+DESCRIPTION="A simple library for keyword extraction"
+HOMEPAGE="http://www.ovmj.org/~samanta/libextractor"
+SRC_URI="http://www.ovmj.org/~samanta/libextractor/download/${P}.tar.bz2"
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+DEPEND="virtual/libc
+ >=sys-devel/libtool-1.4.1
+ oggvorbis? ( >=media-libs/libvorbis-1.0_beta4 )"
+
+src_compile() {
+ elibtoolize
+ econf --with-gnu-ld \
+ `use_enable static` || die "econf failed"
+ make || die "compile failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "install failed"
+}