summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2004-11-13 01:52:19 +0000
committerKito Danya Dietrich <kito@gentoo.org>2004-11-13 01:52:19 +0000
commitb93bdf8db49e5bd5e33b808646ec6fcfb5bd68e6 (patch)
treef8c29b46c7838392ae95d1d9d7ba80b8933a6ecb /media-libs/libao
parentMarked stable on x86. (Manifest recommit) (diff)
downloadgentoo-2-b93bdf8db49e5bd5e33b808646ec6fcfb5bd68e6.tar.gz
gentoo-2-b93bdf8db49e5bd5e33b808646ec6fcfb5bd68e6.tar.bz2
gentoo-2-b93bdf8db49e5bd5e33b808646ec6fcfb5bd68e6.zip
added ppc-macos patch. fixes dyld linking errors
Diffstat (limited to 'media-libs/libao')
-rw-r--r--media-libs/libao/ChangeLog6
-rw-r--r--media-libs/libao/files/libao-0.8.5-ppc-macos.patch66
-rw-r--r--media-libs/libao/libao-0.8.5.ebuild7
3 files changed, 75 insertions, 4 deletions
diff --git a/media-libs/libao/ChangeLog b/media-libs/libao/ChangeLog
index 8ad930069fa8..02f9a227071e 100644
--- a/media-libs/libao/ChangeLog
+++ b/media-libs/libao/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libao
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/ChangeLog,v 1.43 2004/11/06 14:40:45 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/ChangeLog,v 1.44 2004/11/13 01:52:19 kito Exp $
+
+ 12 Nov 2004; Kito <kito@gentoo.org> +files/libao-0.8.5-ppc-macos.patch,
+ libao-0.8.5.ebuild:
+ added ppc-macos patch
06 Nov 2004; Lars Weiler <pylon@gentoo.org> libao-0.8.5.ebuild:
Stable on ppc.
diff --git a/media-libs/libao/files/libao-0.8.5-ppc-macos.patch b/media-libs/libao/files/libao-0.8.5-ppc-macos.patch
new file mode 100644
index 000000000000..d0ade8a794bd
--- /dev/null
+++ b/media-libs/libao/files/libao-0.8.5-ppc-macos.patch
@@ -0,0 +1,66 @@
+diff -uNr libao-0.8.5/configure libao-0.8.5-new/configure
+--- libao-0.8.5/configure Fri Mar 19 09:49:41 2004
++++ libao-0.8.5-new/configure Fri Nov 12 16:01:29 2004
+@@ -5873,7 +5873,7 @@
+ allow_undefined_flag='-undefined suppress'
+ ;;
+ *) # Darwin 1.3 on
+- allow_undefined_flag='-flat_namespace -undefined suppress'
++ allow_undefined_flag='-undefined dynamic_lookup'
+ ;;
+ esac
+ # FIXME: Relying on posixy $() will cause problems for
+@@ -8081,9 +8081,10 @@
+ PROFILE="-pg -g -O20 -D__NO_MATH_INLINES -fsigned-char -mv8" ;;
+ *-darwin*)
+ PLUGIN_LDFLAGS="-module -avoid-version"
+- DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char -Ddlsym=dlsym_auto_underscore"
+- CFLAGS="-D__NO_MATH_INLINES -fsigned-char -Ddlsym=dlsym_auto_underscore"
+- PROFILE="-g -pg -D__NO_MATH_INLINES -fsigned-char -Ddlsym=dlsym_auto_underscore" ;;
++ DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char"
++ CFLAGS="-D__NO_MATH_INLINES -fsigned-char"
++ LIBS="-Wl,-framework -Wl,CoreAudio"
++ PROFILE="-g -pg -D__NO_MATH_INLINES -fsigned-char" ;;
+ *)
+ PLUGIN_LDFLAGS="-export-dynamic -avoid-version"
+ DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char"
+@@ -8184,7 +8185,7 @@
+ DLOPEN_FLAG='(RTLD_LAZY)'
+ SHARED_LIB_EXT='.sl'
+ ;;
+- *openbsd* | *netbsd* | *solaris2.7)
++ *darwin* | *openbsd* | *netbsd* | *solaris2.7)
+ DLOPEN_FLAG='(RTLD_LAZY)'
+ SHARED_LIB_EXT='.so'
+ ;;
+diff -uNr libao-0.8.5/src/plugins/macosx/ao_macosx.c libao-0.8.5-new/src/plugins/macosx/ao_macosx.c
+--- libao-0.8.5/src/plugins/macosx/ao_macosx.c Tue Jun 24 07:15:00 2003
++++ libao-0.8.5-new/src/plugins/macosx/ao_macosx.c Fri Nov 12 16:08:25 2004
+@@ -173,6 +173,27 @@
+ return 0;
+ }
+
++ if (internal->outputStreamBasicDescription.mChannelsPerFrame != format->channels)
++ {
++ internal->outputStreamBasicDescription.mChannelsPerFrame = format->channels;
++ internal->outputStreamBasicDescription.mBytesPerFrame =
++ internal->outputStreamBasicDescription.mChannelsPerFrame * sizeof (float);
++ internal->outputStreamBasicDescription.mBytesPerPacket =
++ internal->outputStreamBasicDescription.mBytesPerFrame *
++ internal->outputStreamBasicDescription.mFramesPerPacket;
++ status = AudioDeviceSetProperty(internal->outputDeviceID, 0, 0, 0,
++ kAudioDevicePropertyStreamFormat,
++ sizeof (internal->outputStreamBasicDescription),
++ &internal->outputStreamBasicDescription);
++ if (status != noErr)
++ {
++ fprintf(stderr, "ao_macosx_open: AudioDeviceSetProperty returned %.*s when setting kAudioDevicePropertyStreamFormat\n",
++ (int) sizeof (status), (char *) &status);
++ return 0;
++ }
++ }
++
++
+ fprintf(stderr, "hardware format...\n");
+ fprintf(stderr, "%f mSampleRate\n", internal->outputStreamBasicDescription.mSampleRate);
+ fprintf(stderr, "%c%c%c%c mFormatID\n", (int)(internal->outputStreamBasicDescription.mFormatID & 0xff000000) >> 24,
diff --git a/media-libs/libao/libao-0.8.5.ebuild b/media-libs/libao/libao-0.8.5.ebuild
index 1a2d142e9539..8c85be6e17c9 100644
--- a/media-libs/libao/libao-0.8.5.ebuild
+++ b/media-libs/libao/libao-0.8.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/libao-0.8.5.ebuild,v 1.14 2004/11/06 14:40:45 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/libao-0.8.5.ebuild,v 1.15 2004/11/13 01:52:19 kito Exp $
-inherit libtool
+inherit libtool eutils
DESCRIPTION="the audio output library"
HOMEPAGE="http://www.xiph.org/ao/"
@@ -22,6 +22,7 @@ DEPEND="virtual/libc
src_unpack() {
unpack ${A}
cd ${S}
+ use ppc-macos && epatch ${FILESDIR}/${P}-ppc-macos.patch
elibtoolize
}
@@ -46,4 +47,4 @@ src_install () {
rm -rf ${D}/usr/share/doc
dodoc AUTHORS CHANGES COPYING README TODO
dohtml -A c doc/*.html
-}
+} \ No newline at end of file