summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-09-27 18:09:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-09-27 18:09:06 +0000
commit57865f5d3296c34a7bfcf2260c6c9a6422c5e8c5 (patch)
tree18a203c251d5e95e78e03a9fc2479aadb3915b1f /media-libs/libaacplus
parentppc/ppc64 stable wrt #382171 (diff)
downloadgentoo-2-57865f5d3296c34a7bfcf2260c6c9a6422c5e8c5.tar.gz
gentoo-2-57865f5d3296c34a7bfcf2260c6c9a6422c5e8c5.tar.bz2
gentoo-2-57865f5d3296c34a7bfcf2260c6c9a6422c5e8c5.zip
initial import, ebuild by me
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libaacplus')
-rw-r--r--media-libs/libaacplus/ChangeLog10
-rw-r--r--media-libs/libaacplus/libaacplus-2.0.2.ebuild55
-rw-r--r--media-libs/libaacplus/metadata.xml5
3 files changed, 70 insertions, 0 deletions
diff --git a/media-libs/libaacplus/ChangeLog b/media-libs/libaacplus/ChangeLog
new file mode 100644
index 000000000000..9ae6b4de1627
--- /dev/null
+++ b/media-libs/libaacplus/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-libs/libaacplus
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libaacplus/ChangeLog,v 1.1 2011/09/27 18:09:06 aballier Exp $
+
+*libaacplus-2.0.2 (27 Sep 2011)
+
+ 27 Sep 2011; Alexis Ballier <aballier@gentoo.org> +libaacplus-2.0.2.ebuild,
+ +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/media-libs/libaacplus/libaacplus-2.0.2.ebuild b/media-libs/libaacplus/libaacplus-2.0.2.ebuild
new file mode 100644
index 000000000000..f49ec46cf014
--- /dev/null
+++ b/media-libs/libaacplus/libaacplus-2.0.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libaacplus/libaacplus-2.0.2.ebuild,v 1.1 2011/09/27 18:09:06 aballier Exp $
+
+EAPI=4
+
+inherit autotools
+
+# This file cannot be mirrored.
+# See the notes at http://tipok.org.ua/node/17
+# The .tar.gz, ie the wrapper library, is lgpl though.
+TGPPDIST=26410-800.zip
+
+DESCRIPTION="HE-AAC+ v2 library, based on the reference implementation"
+HOMEPAGE="http://tipok.org.ua/node/17"
+SRC_URI="http://dev.gentoo.org/~aballier/${P}.tar.gz
+ http://tipok.ath.cx/downloads/media/aac+/libaacplus/${P}.tar.gz
+ http://217.20.164.161/~tipok/aacplus/${P}.tar.gz
+ http://www.3gpp.org/ftp/Specs/archive/26_series/26.410/${TGPPDIST}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="bindist fftw static-libs"
+RESTRICT="mirror"
+REQUIRED_USE="!bindist"
+
+RDEPEND="!media-sound/aacplusenc
+ fftw? ( sci-libs/fftw:3.0 )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+}
+
+src_prepare() {
+ eautoreconf
+ cp "${DISTDIR}/${TGPPDIST}" "${S}/src/" || die
+}
+
+src_configure() {
+ econf $(use_with fftw fftw3) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete
+}
diff --git a/media-libs/libaacplus/metadata.xml b/media-libs/libaacplus/metadata.xml
new file mode 100644
index 000000000000..ae573a60407f
--- /dev/null
+++ b/media-libs/libaacplus/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>