summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2011-07-29 05:56:34 +0000
committerMart Raudsepp <leio@gentoo.org>2011-07-29 05:56:34 +0000
commit888b73633be1a985b16da60563d457e0a03ceba5 (patch)
tree4e456bc1cd0ec5000725bcbf2104d061539557aa /media-libs/gst-plugins-bad
parentVersion bump. (diff)
downloadgentoo-2-888b73633be1a985b16da60563d457e0a03ceba5.tar.gz
gentoo-2-888b73633be1a985b16da60563d457e0a03ceba5.tar.bz2
gentoo-2-888b73633be1a985b16da60563d457e0a03ceba5.zip
Version bump. Audioparsers moved to gst-plugins-good-0.10.29, make sure to upgrade. New elements: hlsdemux, fieldanalysis, h263parse, zebrastripe, patchdetect, scenechange, sdimux, sdidemux, tsdemux
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gst-plugins-bad')
-rw-r--r--media-libs/gst-plugins-bad/ChangeLog18
-rw-r--r--media-libs/gst-plugins-bad/gst-plugins-bad-0.10.22.ebuild56
2 files changed, 73 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-bad/ChangeLog b/media-libs/gst-plugins-bad/ChangeLog
index 2a9c90a1fcb0..027eca2591d9 100644
--- a/media-libs/gst-plugins-bad/ChangeLog
+++ b/media-libs/gst-plugins-bad/ChangeLog
@@ -1,6 +1,22 @@
# ChangeLog for media-libs/gst-plugins-bad
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-bad/ChangeLog,v 1.83 2011/07/25 18:11:40 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-bad/ChangeLog,v 1.84 2011/07/29 05:56:34 leio Exp $
+
+*gst-plugins-bad-0.10.22 (29 Jul 2011)
+
+ 29 Jul 2011; Mart Raudsepp <leio@gentoo.org>
+ +gst-plugins-bad-0.10.22.ebuild:
+ Version bump. Audioparsers moved to gst-plugins-good-0.10.29, make sure to
+ upgrade. New elements:
+ * hlsdemux - HTTP live streaming parser/demuxer element
+ * fieldanalysis - Analyse fields from video frames to identify if they are
+ progressive/telecined/interlaced
+ * h263parse - Parses H.263 streams
+ * zebrastripe - Overlays zebra striping on overexposed areas of video
+ * patchdetect - Detects color patches from a color calibration chart
+ * scenechange - Detects scene changes in video
+ * sdimux and sdidemux - Multiplex raw audio/video to SDI and vice-versa
+ * tsdemux - new (not-yet autoplugged) MPEG TS demuxer rewrite
25 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org>
gst-plugins-bad-0.10.21.ebuild:
diff --git a/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.22.ebuild b/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.22.ebuild
new file mode 100644
index 000000000000..f876321f3af8
--- /dev/null
+++ b/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.22.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.22.ebuild,v 1.1 2011/07/29 05:56:34 leio Exp $
+
+EAPI=1
+GCONF_DEBUG="no"
+
+inherit gst-plugins-bad gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Less plugins for GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~amd64-linux ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-linux"
+IUSE="+orc"
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.33
+ >=media-libs/gstreamer-0.10.33
+ >=dev-libs/glib-2.22
+ orc? ( >=dev-lang/orc-0.4.11 )
+ !<media-plugins/gst-plugins-farsight-0.12.11"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# Avoid --enable-bad passing by the eclass blindly
+GST_PLUGINS_BUILD=""
+
+src_compile() {
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # (Bug #22249)
+
+ gst-plugins-bad_src_configure \
+ $(use_enable orc) \
+ --disable-examples \
+ --disable-debug
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}