summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-06-09 08:11:48 +0000
committerTim Harder <radhermit@gentoo.org>2011-06-09 08:11:48 +0000
commit0a7e0f268fec3eaf0f892a7494431dc3a19e7f37 (patch)
treefaed267c820cd93997bbd90741c69e8e12dc643b /media-libs/gexiv2
parentVersion bump. (diff)
downloadgentoo-2-0a7e0f268fec3eaf0f892a7494431dc3a19e7f37.tar.gz
gentoo-2-0a7e0f268fec3eaf0f892a7494431dc3a19e7f37.tar.bz2
gentoo-2-0a7e0f268fec3eaf0f892a7494431dc3a19e7f37.zip
Version bump and add static-libs USE flag.
(Portage version: 2.2.0_alpha38/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gexiv2')
-rw-r--r--media-libs/gexiv2/ChangeLog9
-rw-r--r--media-libs/gexiv2/gexiv2-0.3.1.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/media-libs/gexiv2/ChangeLog b/media-libs/gexiv2/ChangeLog
index 5d7b4675a8e5..1e2335c31cc0 100644
--- a/media-libs/gexiv2/ChangeLog
+++ b/media-libs/gexiv2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/gexiv2
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/ChangeLog,v 1.3 2010/12/21 15:14:54 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/ChangeLog,v 1.4 2011/06/09 08:11:48 radhermit Exp $
+
+*gexiv2-0.3.1 (09 Jun 2011)
+
+ 09 Jun 2011; Tim Harder <radhermit@gentoo.org> +gexiv2-0.3.1.ebuild:
+ Version bump and add static-libs USE flag.
21 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> gexiv2-0.2.1.ebuild,
+files/gexiv2-0.2.1-new-exiv2.patch:
diff --git a/media-libs/gexiv2/gexiv2-0.3.1.ebuild b/media-libs/gexiv2/gexiv2-0.3.1.ebuild
new file mode 100644
index 000000000000..c1b763cb1cdf
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/gexiv2-0.3.1.ebuild,v 1.1 2011/06/09 08:11:48 radhermit Exp $
+
+EAPI=4
+inherit versionator multilib toolchain-funcs
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="gexiv2 is a GObject-based wrapper around the Exiv2 library."
+HOMEPAGE="http://trac.yorba.org/wiki/gexiv2"
+SRC_URI="http://www.yorba.org/download/${PN}/${MY_PV}/lib${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=media-gfx/exiv2-0.21
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/lib${P}
+
+src_configure() {
+ tc-export CXX
+ ./configure --prefix=/usr || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIB="$(get_libdir)" install
+ dodoc AUTHORS NEWS README THANKS
+
+ use static-libs || find "${D}" \( -name '*.a' -or -name '*.la' \) -delete
+}