summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-20 19:46:07 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-20 19:46:07 +0000
commit71aa389727ed99f103c9fe16609ad5f3782b7b78 (patch)
tree30681184233266b5ff561d5a41fbd0bf3355a531 /media-libs/ctl
parentFix ipv6 stuff, thanks to bluebird in #gentoo-dev (diff)
downloadgentoo-2-71aa389727ed99f103c9fe16609ad5f3782b7b78.tar.gz
gentoo-2-71aa389727ed99f103c9fe16609ad5f3782b7b78.tar.bz2
gentoo-2-71aa389727ed99f103c9fe16609ad5f3782b7b78.zip
Fix gcc-4.3 compilation. Thanks to Robert Piasek <robert.piasek@member.fsf.org> in bug 227395 for the first part of the patch.
(Portage version: 2.1.5.5)
Diffstat (limited to 'media-libs/ctl')
-rw-r--r--media-libs/ctl/ChangeLog8
-rw-r--r--media-libs/ctl/ctl-1.4.1.ebuild6
-rw-r--r--media-libs/ctl/files/ctl-1.4.1-gcc43.patch113
3 files changed, 125 insertions, 2 deletions
diff --git a/media-libs/ctl/ChangeLog b/media-libs/ctl/ChangeLog
index 172365211d9b..762fb8159788 100644
--- a/media-libs/ctl/ChangeLog
+++ b/media-libs/ctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/ctl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ChangeLog,v 1.13 2008/04/13 10:49:47 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ChangeLog,v 1.14 2008/06/20 19:46:06 loki_val Exp $
+
+ 20 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/ctl-1.4.1-gcc43.patch, ctl-1.4.1.ebuild:
+ Fix gcc-4.3 compilation. Thanks to Robert Piasek
+ <robert.piasek@member.fsf.org> in bug 227395 for the first part of the
+ patch.
13 Apr 2008; Markus Rothe <corsair@gentoo.org> ctl-1.4.1.ebuild:
Stable on ppc64; bug #207663
diff --git a/media-libs/ctl/ctl-1.4.1.ebuild b/media-libs/ctl/ctl-1.4.1.ebuild
index 66a83665f8c0..3f741f20f53b 100644
--- a/media-libs/ctl/ctl-1.4.1.ebuild
+++ b/media-libs/ctl/ctl-1.4.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ctl-1.4.1.ebuild,v 1.8 2008/04/13 10:49:47 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ctl-1.4.1.ebuild,v 1.9 2008/06/20 19:46:06 loki_val Exp $
+
+inherit base
DESCRIPTION="AMPAS' Color Transformation Language"
HOMEPAGE="http://sourceforge.net/projects/ampasctl"
@@ -15,6 +17,8 @@ RDEPEND="media-libs/ilmbase"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
+
src_install() {
emake DESTDIR="${D}" install || die "install failed"
dodoc AUTHORS ChangeLog NEWS README
diff --git a/media-libs/ctl/files/ctl-1.4.1-gcc43.patch b/media-libs/ctl/files/ctl-1.4.1-gcc43.patch
new file mode 100644
index 000000000000..425ce1205054
--- /dev/null
+++ b/media-libs/ctl/files/ctl-1.4.1-gcc43.patch
@@ -0,0 +1,113 @@
+diff -NrU5 ctl-1.4.1.orig/IlmCtl/CtlLex.h ctl-1.4.1/IlmCtl/CtlLex.h
+--- ctl-1.4.1.orig/IlmCtl/CtlLex.h 2008-06-20 18:30:55.000000000 +0200
++++ ctl-1.4.1/IlmCtl/CtlLex.h 2008-06-20 18:31:24.000000000 +0200
+@@ -58,10 +58,11 @@
+ //-----------------------------------------------------------------------------
+
+ #include <CtlLContext.h>
+ #include <CtlTokens.h>
+ #include <string>
++#include <cstdlib>
+
+ namespace Ctl {
+
+
+ class Lex
+diff -NrU5 ctl-1.4.1.orig/IlmCtlMathTest/testAffineRec.cpp ctl-1.4.1/IlmCtlMathTest/testAffineRec.cpp
+--- ctl-1.4.1.orig/IlmCtlMathTest/testAffineRec.cpp 2008-06-20 18:30:55.000000000 +0200
++++ ctl-1.4.1/IlmCtlMathTest/testAffineRec.cpp 2008-06-20 18:37:21.000000000 +0200
+@@ -43,13 +43,14 @@
+ // OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
+ // IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ //
+ ///////////////////////////////////////////////////////////////////////////
+
+-#include <string>
++#include <cstring>
+ #include <fstream>
+ #include <iostream>
++#include <cstdlib>
+ #include <assert.h>
+ #include <CtlRbfInterpolator.h>
+ #include <ImathVec.h>
+
+ using namespace std;
+diff -NrU5 ctl-1.4.1.orig/IlmCtlMathTest/testGaussRec.cpp ctl-1.4.1/IlmCtlMathTest/testGaussRec.cpp
+--- ctl-1.4.1.orig/IlmCtlMathTest/testGaussRec.cpp 2008-06-20 18:30:55.000000000 +0200
++++ ctl-1.4.1/IlmCtlMathTest/testGaussRec.cpp 2008-06-20 18:37:31.000000000 +0200
+@@ -43,13 +43,14 @@
+ // OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
+ // IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ //
+ ///////////////////////////////////////////////////////////////////////////
+
+-#include <string>
++#include <cstring>
+ #include <fstream>
+ #include <iostream>
++#include <cstdlib>
+ #include <assert.h>
+ #include <CtlRbfInterpolator.h>
+ #include <ImathVec.h>
+
+ using namespace std;
+diff -NrU5 ctl-1.4.1.orig/IlmCtlSimd/CtlSimdReg.h ctl-1.4.1/IlmCtlSimd/CtlSimdReg.h
+--- ctl-1.4.1.orig/IlmCtlSimd/CtlSimdReg.h 2008-06-20 18:30:55.000000000 +0200
++++ ctl-1.4.1/IlmCtlSimd/CtlSimdReg.h 2008-06-20 18:31:24.000000000 +0200
+@@ -50,10 +50,11 @@
+ #define INCLUDED_CTL_SIMD_REG_H
+
+ #include <typeinfo>
+ #include <CtlExc.h>
+ #include <Iex.h>
++#include <cstring>
+
+ //-----------------------------------------------------------------------------
+ //
+ // Registers for the SIMD color transformation engine
+ //
+diff -NrU5 ctl-1.4.1.orig/IlmCtlTest/testExamples.cpp ctl-1.4.1/IlmCtlTest/testExamples.cpp
+--- ctl-1.4.1.orig/IlmCtlTest/testExamples.cpp 2008-06-20 18:30:55.000000000 +0200
++++ ctl-1.4.1/IlmCtlTest/testExamples.cpp 2008-06-20 18:41:52.000000000 +0200
+@@ -43,10 +43,11 @@
+ // OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
+ // IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ //
+ ///////////////////////////////////////////////////////////////////////////
+
++#include <cstring>
+ #include <CtlSimdInterpreter.h>
+ #include <CtlFunctionCall.h>
+ #include <CtlType.h>
+ #include <assert.h>
+
+diff -NrU5 ctl-1.4.1.orig/IlmCtlTest/testVarying.cpp ctl-1.4.1/IlmCtlTest/testVarying.cpp
+--- ctl-1.4.1.orig/IlmCtlTest/testVarying.cpp 2008-06-20 18:30:55.000000000 +0200
++++ ctl-1.4.1/IlmCtlTest/testVarying.cpp 2008-06-20 18:43:28.000000000 +0200
+@@ -49,10 +49,11 @@
+ #include <CtlSimdInterpreter.h>
+ #include <CtlFunctionCall.h>
+ #include <CtlType.h>
+ #include <ImathMath.h>
+ #include <iostream>
++#include <cstring>
+ #include <exception>
+ #include <assert.h>
+ #include <sstream>
+ #include <limits>
+ #include <half.h>
+diff -NrU5 ctl-1.4.1.orig/IlmCtlTest/testVaryingReturn.cpp ctl-1.4.1/IlmCtlTest/testVaryingReturn.cpp
+--- ctl-1.4.1.orig/IlmCtlTest/testVaryingReturn.cpp 2008-06-20 18:30:55.000000000 +0200
++++ ctl-1.4.1/IlmCtlTest/testVaryingReturn.cpp 2008-06-20 18:46:34.000000000 +0200
+@@ -49,10 +49,11 @@
+ #include <CtlSimdInterpreter.h>
+ #include <CtlFunctionCall.h>
+ #include <CtlType.h>
+ #include <ImathMath.h>
+ #include <iostream>
++#include <cstring>
+ #include <exception>
+ #include <assert.h>
+ #include <sstream>
+ #include <limits>
+ #include <half.h>