summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2012-01-01 12:37:53 +0000
committerSebastian Pipping <sping@gentoo.org>2012-01-01 12:37:53 +0000
commit3fceffd3ce990c2b0c94c1d4ca3fe3dbe855e47b (patch)
tree1f3f4389356ea05adfd81dd3ab5006c828f97db2 /media-libs/babl
parentMask more prerelease x11 packages. (diff)
downloadgentoo-2-3fceffd3ce990c2b0c94c1d4ca3fe3dbe855e47b.tar.gz
gentoo-2-3fceffd3ce990c2b0c94c1d4ca3fe3dbe855e47b.tar.bz2
gentoo-2-3fceffd3ce990c2b0c94c1d4ca3fe3dbe855e47b.zip
media-libs/babl: 0.1.6
(Portage version: 2.1.10.43/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/babl')
-rw-r--r--media-libs/babl/ChangeLog10
-rw-r--r--media-libs/babl/babl-0.1.6.ebuild45
-rw-r--r--media-libs/babl/files/babl-0.1.6-introspection.patch11
3 files changed, 64 insertions, 2 deletions
diff --git a/media-libs/babl/ChangeLog b/media-libs/babl/ChangeLog
index 7899aa11d604..f7cecfb80b54 100644
--- a/media-libs/babl/ChangeLog
+++ b/media-libs/babl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/babl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/ChangeLog,v 1.31 2011/12/22 10:38:01 scarabeus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/ChangeLog,v 1.32 2012/01/01 12:37:53 sping Exp $
+
+*babl-0.1.6 (01 Jan 2012)
+
+ 01 Jan 2012; Sebastian Pipping <sping@gentoo.org> +babl-0.1.6.ebuild,
+ +files/babl-0.1.6-introspection.patch:
+ Bump to 0.1.6: bump dependency version, port patch
22 Dec 2011; Tomáš Chvátal <scarabeus@gentoo.org> -babl-0.0.22.ebuild:
remove old
diff --git a/media-libs/babl/babl-0.1.6.ebuild b/media-libs/babl/babl-0.1.6.ebuild
new file mode 100644
index 000000000000..6720e91bd2cd
--- /dev/null
+++ b/media-libs/babl/babl-0.1.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/babl-0.1.6.ebuild,v 1.1 2012/01/01 12:37:53 sping Exp $
+
+EAPI=3
+
+inherit autotools eutils
+
+DESCRIPTION="A dynamic, any to any, pixel format conversion library"
+HOMEPAGE="http://www.gegl.org/babl/"
+SRC_URI="ftp://ftp.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="altivec +introspection sse mmx"
+
+RDEPEND="introspection? ( >=dev-libs/gobject-introspection-0.10 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-introspection.patch
+ eautoreconf
+}
+
+src_configure() {
+ # Automagic rsvg support is just for website generation we do not call,
+ # so we don't need to fix it
+ # w3m is used for dist target thus no issue for us that it is automagically
+ # detected
+ econf \
+ --disable-static \
+ --disable-maintainer-mode \
+ $(use_enable altivec) \
+ $(use_enable introspection) \
+ $(use_enable mmx) \
+ $(use_enable sse)
+ # TODO expose --without-vala ?
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ find "${ED}" -name '*.la' -delete
+ dodoc AUTHORS ChangeLog README NEWS || die "dodoc failed"
+}
diff --git a/media-libs/babl/files/babl-0.1.6-introspection.patch b/media-libs/babl/files/babl-0.1.6-introspection.patch
new file mode 100644
index 000000000000..840678c9b0c3
--- /dev/null
+++ b/media-libs/babl/files/babl-0.1.6-introspection.patch
@@ -0,0 +1,11 @@
+--- babl/Makefile.am 2012-01-01 13:24:26.837016532 +0100
++++ babl/Makefile.am 2012-01-01 13:24:38.047876380 +0100
+@@ -95,7 +95,7 @@
+ Babl-$(BABL_API_VERSION).gir: $(G_IR_SCANNER) $(library_include_HEADERS) $(c_sources) $(srcdir)/Makefile.am
+ $(INTROSPECTION_SCANNER) -v --namespace Babl --nsversion=$(BABL_API_VERSION) \
+ --add-include-path=$(srcdir) --add-include-path=. \
+- --library=babl-$(BABL_API_VERSION) \
++ --library=libbabl-$(BABL_API_VERSION).la \
+ --libtool="$(LIBTOOL)" \
+ --output $@ \
+ -DBABL_IS_BEING_COMPILED \