summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-01-08 18:38:31 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-01-08 18:38:31 +0000
commit526f84d31f12a359ce533467b81fd0852ba0ea30 (patch)
treedc6d7057b03c6d5df952b8febb3c0cf52eec682b /media-libs/atlas-c++/atlas-c++-0.6.0.ebuild
parentStable on sparc wrt #160163 (diff)
downloadgentoo-2-526f84d31f12a359ce533467b81fd0852ba0ea30.tar.gz
gentoo-2-526f84d31f12a359ce533467b81fd0852ba0ea30.tar.bz2
gentoo-2-526f84d31f12a359ce533467b81fd0852ba0ea30.zip
Version bump. Bug #117655
(Portage version: 2.1.1-r2)
Diffstat (limited to 'media-libs/atlas-c++/atlas-c++-0.6.0.ebuild')
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.6.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild b/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild
new file mode 100644
index 000000000000..80f6d673f3d6
--- /dev/null
+++ b/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.0.ebuild,v 1.1 2007/01/08 18:38:31 tupone Exp $
+
+inherit eutils
+
+MY_PN="Atlas-C++"
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Atlas protocol standard implementation in C++. Atlas protocol is used in role playing games at worldforge."
+HOMEPAGE="http://www.worldforge.net"
+SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc"
+IUSE="bzip2 doc zlib"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_compile() {
+ econf \
+ $(use_enable zlib) \
+ $(use_enable bzip2 bzlib) \
+ || die "Error: econf failed!"
+ emake || die "Error: emake failed!"
+ if use doc; then
+ emake docs || die "Error: emake failed!"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dohtml -r doc/html/*
+ dodoc AUTHORS ChangeLog HACKING NEWS README ROADMAP THANKS TODO
+}