summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2010-04-06 14:29:05 +0000
committerMichael Januszewski <spock@gentoo.org>2010-04-06 14:29:05 +0000
commite3d794bec48c128b76d5246ea37fbbfd2ca25ad4 (patch)
treecb203792717ef219b4fdd2b38be63c5a3c17293e /media-libs/adplug
parentgames herd (diff)
downloadgentoo-2-e3d794bec48c128b76d5246ea37fbbfd2ca25ad4.tar.gz
gentoo-2-e3d794bec48c128b76d5246ea37fbbfd2ca25ad4.tar.bz2
gentoo-2-e3d794bec48c128b76d5246ea37fbbfd2ca25ad4.zip
Version bump, should fix bug #304955.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/adplug')
-rw-r--r--media-libs/adplug/ChangeLog7
-rw-r--r--media-libs/adplug/adplug-2.2.1.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/media-libs/adplug/ChangeLog b/media-libs/adplug/ChangeLog
index 0382a1099570..7090a2b594a4 100644
--- a/media-libs/adplug/ChangeLog
+++ b/media-libs/adplug/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/adplug
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/adplug/ChangeLog,v 1.29 2010/02/08 11:58:00 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/adplug/ChangeLog,v 1.30 2010/04/06 14:29:05 spock Exp $
+
+*adplug-2.2.1 (06 Apr 2010)
+
+ 06 Apr 2010; Michał Januszewski <spock@gentoo.org> +adplug-2.2.1.ebuild:
+ Version bump, should fix bug #304955.
*adplug-2.2 (08 Feb 2010)
diff --git a/media-libs/adplug/adplug-2.2.1.ebuild b/media-libs/adplug/adplug-2.2.1.ebuild
new file mode 100644
index 000000000000..dd0c4ea76767
--- /dev/null
+++ b/media-libs/adplug/adplug-2.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/adplug/adplug-2.2.1.ebuild,v 1.1 2010/04/06 14:29:05 spock Exp $
+
+inherit eutils
+
+DESCRIPTION="A free, cross-platform, hardware independent AdLib sound player library"
+HOMEPAGE="http://adplug.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-cpp/libbinio-1.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf --disable-dependency-tracking $(use_enable debug)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+}