summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-07 20:48:33 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-07 20:48:33 +0000
commitc3b9d3b04bfeafca8db0b28eeee13c7f5a0db58b (patch)
tree0f1c927c88bf34b2bac5162f481b3e02c55feaa5 /media-libs/a52dec
parentuse emake for hot parallel make action; more error checking/messages (diff)
downloadgentoo-2-c3b9d3b04bfeafca8db0b28eeee13c7f5a0db58b.tar.gz
gentoo-2-c3b9d3b04bfeafca8db0b28eeee13c7f5a0db58b.tar.bz2
gentoo-2-c3b9d3b04bfeafca8db0b28eeee13c7f5a0db58b.zip
hppa support
Diffstat (limited to 'media-libs/a52dec')
-rw-r--r--media-libs/a52dec/a52dec-0.7.4.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/media-libs/a52dec/a52dec-0.7.4.ebuild b/media-libs/a52dec/a52dec-0.7.4.ebuild
index f09b2384cc85..02977631f00b 100644
--- a/media-libs/a52dec/a52dec-0.7.4.ebuild
+++ b/media-libs/a52dec/a52dec-0.7.4.ebuild
@@ -1,36 +1,35 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/a52dec/a52dec-0.7.4.ebuild,v 1.10 2003/11/04 23:17:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/a52dec/a52dec-0.7.4.ebuild,v 1.11 2003/11/07 20:48:33 vapier Exp $
-DESCRIPTION="A free library for decoding ATSC A/52 streams used in DVD, etc with a test program"
+inherit flag-o-matic
+
+DESCRIPTION="library for decoding ATSC A/52 streams used in DVD"
+HOMEPAGE="http://liba52.sourceforge.net/"
SRC_URI="http://liba52.sourceforge.net/files/${P}.tar.gz"
-HOMEPAGE="http://liba52.sourceforge.net"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc hppa amd64"
IUSE="oss static"
-KEYWORDS="x86 ppc sparc amd64"
DEPEND=">=sys-devel/autoconf-2.52d-r1"
src_compile() {
+ append-flags -fPIC
local myconf
- export CFLAGS="${CFLAGS} -fPIC"
use oss \
|| myconf="${myconf} --disable-oss"
-
use static \
&& myconf="${myconf} --disable-shared --enable-static" \
|| myconf="${myconf} --enable-shared --disable-static"
econf ${myconf} || die
emake || die "emake failed"
-
}
src_install() {
einstall docdir=${D}/usr/share/doc/${PF}/html || die
- dodoc AUTHORS ChangeLog HISTORY NEWS README TODO doc/liba52.txt || \
- die "dodoc failed"
+ dodoc AUTHORS ChangeLog HISTORY NEWS README TODO doc/liba52.txt
}