summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-09-14 09:06:34 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-09-14 09:06:34 +0000
commitbabe1935ce4f39ddb1b2eed9ba39ebaed50a0861 (patch)
tree50e3fe44cb3461b3b0eddd8574d5edb932e5925e /media-gfx
parentFix typo on elog message. Bug #336798. Thanks to Marco Paolone <marcopaolone@... (diff)
downloadgentoo-2-babe1935ce4f39ddb1b2eed9ba39ebaed50a0861.tar.gz
gentoo-2-babe1935ce4f39ddb1b2eed9ba39ebaed50a0861.tar.bz2
gentoo-2-babe1935ce4f39ddb1b2eed9ba39ebaed50a0861.zip
Version bump. Bug #336900. Thanks to David King <amigadave@amigadave.com> for the ebuild and the patch.
(Portage version: 2.2_rc81/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/simple-scan/ChangeLog11
-rw-r--r--media-gfx/simple-scan/files/simple-scan-2.31.90.2-support-non-pkgconfig-zlib.patch32
-rw-r--r--media-gfx/simple-scan/simple-scan-2.31.91.ebuild44
3 files changed, 86 insertions, 1 deletions
diff --git a/media-gfx/simple-scan/ChangeLog b/media-gfx/simple-scan/ChangeLog
index 1ae1b1c9b5bb..7154f6e0f9a7 100644
--- a/media-gfx/simple-scan/ChangeLog
+++ b/media-gfx/simple-scan/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-gfx/simple-scan
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/simple-scan/ChangeLog,v 1.2 2010/08/03 19:34:54 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/simple-scan/ChangeLog,v 1.3 2010/09/14 09:06:34 hwoarang Exp $
+
+*simple-scan-2.31.91 (14 Sep 2010)
+
+ 14 Sep 2010; Markos Chandras <hwoarang@gentoo.org>
+ +files/simple-scan-2.31.90.2-support-non-pkgconfig-zlib.patch,
+ +simple-scan-2.31.91.ebuild:
+ Version bump. Bug #336900. Patch to configure with old zlib versions as
+ well. Thanks to David King <amigadave@amigadave.com> for the ebuild and
+ the patch.
03 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
simple-scan-2.31.1.ebuild:
diff --git a/media-gfx/simple-scan/files/simple-scan-2.31.90.2-support-non-pkgconfig-zlib.patch b/media-gfx/simple-scan/files/simple-scan-2.31.90.2-support-non-pkgconfig-zlib.patch
new file mode 100644
index 000000000000..75b0adcf9013
--- /dev/null
+++ b/media-gfx/simple-scan/files/simple-scan-2.31.90.2-support-non-pkgconfig-zlib.patch
@@ -0,0 +1,32 @@
+Index: simple-scan-2.31.90.2/configure.ac
+===================================================================
+--- simple-scan-2.31.90.2.orig/configure.ac 2010-08-30 08:49:27.000000000 +1000
++++ simple-scan-2.31.90.2/configure.ac 2010-08-30 08:49:41.147411001 +1000
+@@ -30,7 +30,6 @@
+ gconf-2.0
+ gmodule-export-2.0
+ gthread-2.0
+- zlib
+ cairo
+ gdk-pixbuf-2.0
+ cairo-pdf
+@@ -41,6 +40,7 @@
+
+ AC_CHECK_HEADERS([sane/sane.h],[],[AC_MSG_ERROR([SANE not found])])
+ AC_CHECK_HEADERS([sane/saneopts.h],[],[AC_MSG_ERROR([SANE not found])])
++AC_CHECK_HEADERS([zlib.h],[],[AC_MSG_ERROR([ZLib not found])])
+ AC_CHECK_HEADERS([jpeglib.h],[],[AC_MSG_ERROR([libjpeg not found])])
+
+ dnl ###########################################################################
+Index: simple-scan-2.31.90.2/src/Makefile.am
+===================================================================
+--- simple-scan-2.31.90.2.orig/src/Makefile.am 2010-08-30 08:49:24.000000000 +1000
++++ simple-scan-2.31.90.2/src/Makefile.am 2010-08-30 08:49:29.997411002 +1000
+@@ -30,6 +30,7 @@
+ $(SIMPLE_SCAN_LIBS) \
+ -lsane \
+ -ljpeg \
++ -lz \
+ -lm
+
+ DISTCLEANFILES = \
diff --git a/media-gfx/simple-scan/simple-scan-2.31.91.ebuild b/media-gfx/simple-scan/simple-scan-2.31.91.ebuild
new file mode 100644
index 000000000000..2c1c952fa5b5
--- /dev/null
+++ b/media-gfx/simple-scan/simple-scan-2.31.91.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/simple-scan/simple-scan-2.31.91.ebuild,v 1.1 2010/09/14 09:06:34 hwoarang Exp $
+
+EAPI=3
+
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Simple document scanning utility"
+HOMEPAGE="https://launchpad.net/simple-scan"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="app-text/gnome-doc-utils
+ >=x11-libs/gtk+-2.18.0:2
+ dev-libs/glib:2
+ gnome-base/gconf:2
+ >=media-gfx/sane-backends-1.0.20
+ media-libs/jpeg
+ sys-fs/udev[extras]
+ sys-libs/zlib
+ x11-libs/cairo"
+RDEPEND="${COMMON_DEPEND}
+ x11-misc/xdg-utils
+ x11-themes/gnome-icon-theme"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.35.0
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Expects a zlib with pkg-config support (>=1.2.5).
+ epatch "${FILESDIR}"/${PN}-2.31.90.2-support-non-pkgconfig-zlib.patch
+ eautoreconf
+}