summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-04-30 06:47:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-04-30 06:47:27 +0000
commit835370ca3dee4e55accf8e05d4616ff10f075883 (patch)
tree415bc165b6ed5f8ce538ff58987fd3f9c34523ae /media-gfx
parentFix building with automake-1.13 - bug #467788 (diff)
downloadgentoo-2-835370ca3dee4e55accf8e05d4616ff10f075883.tar.gz
gentoo-2-835370ca3dee4e55accf8e05d4616ff10f075883.tar.bz2
gentoo-2-835370ca3dee4e55accf8e05d4616ff10f075883.zip
Fix building with libpng16 from which we don't get <cstring> within <png.h> anymore wrt #467918 by Antoine Lemoine
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/png2ico/ChangeLog9
-rw-r--r--media-gfx/png2ico/files/png2ico-2002.12.08-memset_and_strcmp.patch13
-rw-r--r--media-gfx/png2ico/png2ico-2002.12.08.ebuild14
3 files changed, 28 insertions, 8 deletions
diff --git a/media-gfx/png2ico/ChangeLog b/media-gfx/png2ico/ChangeLog
index 857c48a286db..29da7b72ed70 100644
--- a/media-gfx/png2ico/ChangeLog
+++ b/media-gfx/png2ico/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/png2ico
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/png2ico/ChangeLog,v 1.1 2011/10/09 09:04:00 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/png2ico/ChangeLog,v 1.2 2013/04/30 06:47:27 ssuominen Exp $
+
+ 30 Apr 2013; Samuli Suominen <ssuominen@gentoo.org>
+ png2ico-2002.12.08.ebuild, +files/png2ico-2002.12.08-memset_and_strcmp.patch:
+ Fix building with libpng16 from which we don't get <cstring> within <png.h>
+ anymore wrt #467918 by Antoine Lemoine
*png2ico-2002.12.08 (09 Oct 2011)
diff --git a/media-gfx/png2ico/files/png2ico-2002.12.08-memset_and_strcmp.patch b/media-gfx/png2ico/files/png2ico-2002.12.08-memset_and_strcmp.patch
new file mode 100644
index 000000000000..96720bebd18f
--- /dev/null
+++ b/media-gfx/png2ico/files/png2ico-2002.12.08-memset_and_strcmp.patch
@@ -0,0 +1,13 @@
+png2ico.cpp:133:31: error: ‘memset’ was not declared in this scope
+png2ico.cpp:443:34: error: ‘strcmp’ was not declared in this scope
+
+--- png2ico.cpp
++++ png2ico.cpp
+@@ -33,6 +33,7 @@
+
+
+ #include <cstdio>
++#include <cstring>
+ #include <vector>
+ #include <climits>
+
diff --git a/media-gfx/png2ico/png2ico-2002.12.08.ebuild b/media-gfx/png2ico/png2ico-2002.12.08.ebuild
index dda9667905a6..2805a4d8774c 100644
--- a/media-gfx/png2ico/png2ico-2002.12.08.ebuild
+++ b/media-gfx/png2ico/png2ico-2002.12.08.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/png2ico/png2ico-2002.12.08.ebuild,v 1.1 2011/10/09 09:04:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/png2ico/png2ico-2002.12.08.ebuild,v 1.2 2013/04/30 06:47:27 ssuominen Exp $
-EAPI=4
-inherit toolchain-funcs
+EAPI=5
+inherit eutils toolchain-funcs
DESCRIPTION="PNG to icon converter"
HOMEPAGE="http://winterdrache.de/freeware/png2ico/index.html"
@@ -14,13 +14,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="media-libs/libpng
- sys-libs/zlib"
+RDEPEND="media-libs/libpng:0=
+ sys-libs/zlib:="
DEPEND="${RDEPEND}"
S=${WORKDIR}/${PN}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-memset_and_strcmp.patch
+
sed -i \
-e 's:CPPFLAGS=-W -Wall -O2:CXXFLAGS+=-W -Wall:' \
-e 's:g++ $(CPPFLAGS):$(CXX) $(LDFLAGS) $(CXXFLAGS):' \