summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-11 21:56:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-11 21:56:09 +0000
commit89470297a80142e2dc3dc27b2a148f210b7b06df (patch)
treebb11c1536a9a79cbd9e82f0fc8bc2bfd124ba5bb /media-gfx/pstoedit
parentversion bump, allow split qt4 deps (diff)
downloadgentoo-2-89470297a80142e2dc3dc27b2a148f210b7b06df.tar.gz
gentoo-2-89470297a80142e2dc3dc27b2a148f210b7b06df.tar.bz2
gentoo-2-89470297a80142e2dc3dc27b2a148f210b7b06df.zip
gcc 4.3 build fix by Martin Väth <vaeth@mathematik.uni-wuerzburg.de>, bug #218013
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'media-gfx/pstoedit')
-rw-r--r--media-gfx/pstoedit/ChangeLog7
-rw-r--r--media-gfx/pstoedit/files/pstoedit-3.45-gcc-4.3.patch11
-rw-r--r--media-gfx/pstoedit/pstoedit-3.45.ebuild3
3 files changed, 19 insertions, 2 deletions
diff --git a/media-gfx/pstoedit/ChangeLog b/media-gfx/pstoedit/ChangeLog
index 3704d17d3236..95defff3a699 100644
--- a/media-gfx/pstoedit/ChangeLog
+++ b/media-gfx/pstoedit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/pstoedit
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/ChangeLog,v 1.51 2008/03/17 12:45:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/ChangeLog,v 1.52 2008/05/11 21:56:08 aballier Exp $
+
+ 11 May 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/pstoedit-3.45-gcc-4.3.patch, pstoedit-3.45.ebuild:
+ gcc 4.3 build fix by Martin Väth <vaeth@mathematik.uni-wuerzburg.de>, bug
+ #218013
17 Mar 2008; Alexis Ballier <aballier@gentoo.org> pstoedit-3.45.ebuild:
dont use -pedantic for building as 'long long' used by latest imagemagick
diff --git a/media-gfx/pstoedit/files/pstoedit-3.45-gcc-4.3.patch b/media-gfx/pstoedit/files/pstoedit-3.45-gcc-4.3.patch
new file mode 100644
index 000000000000..3bec05e69e6e
--- /dev/null
+++ b/media-gfx/pstoedit/files/pstoedit-3.45-gcc-4.3.patch
@@ -0,0 +1,11 @@
+--- src/cppcomp.h
++++ src/cppcomp.h
+@@ -122,6 +122,8 @@
+ #define I_iomanip <iomanip>
+ #define I_ios <ios>
+ #define I_iostream <iostream>
++#include <cstdlib>
++#include <cstring>
+
+ #if (defined (_MSC_VER) && _MSC_VER >= 1100)
+ // 1100 is version 5.0
diff --git a/media-gfx/pstoedit/pstoedit-3.45.ebuild b/media-gfx/pstoedit/pstoedit-3.45.ebuild
index f11c6cef1d1f..8ec1c8d871a2 100644
--- a/media-gfx/pstoedit/pstoedit-3.45.ebuild
+++ b/media-gfx/pstoedit/pstoedit-3.45.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/pstoedit-3.45.ebuild,v 1.10 2008/03/17 12:45:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/pstoedit-3.45.ebuild,v 1.11 2008/05/11 21:56:08 aballier Exp $
inherit base eutils
@@ -40,6 +40,7 @@ src_unpack() {
# Fails due to imagemagick having 'long long' in its headers (at least in
# 6.3.9.8).
sed -i -e "s/-pedantic //" configure
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch"
}
src_compile() {